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Introduction
About Aloha Online Ordering
Aloha Online Ordering enables you to increase consumer traffic and sales by making it easy and con-
venient for consumers to do business with you by providing instant access to menus and pricing,
transmit orders electronically to your store, Benefits include:

• Enhance consumer satisfaction - Extend your business by allowing consumers to place 
orders anytime and anywhere. By making it easier to do business, you also enhance con-
sumer satisfaction.

• Gain consumer intelligence - Gather data about your consumers when they place online 
orders, which you can use to optimize marketing and operational decisions. 

• Provide transparent pricing - Provide consumers with order totals, including sales tax, and 
allow them to receive notifications when their food will be ready.

• Improve security and convenience - Speed up the transaction process by allowing consum-
ers to enter their payment information and save the information for a future order. Aloha 
Online Ordering includes a number of security measures to keep consumer data safe.

• Drive consumer traffic - Allow consumers to interact with your restaurant in a non-tradi-
tional way. They can order the food they want, when they want it, and enjoy it in the comfort 
of their own home or on the go. 

• Decrease labor and data errors - Reduce staff labor and data input error with online orders 
rather than accepting orders by fax and call-in. 

Aloha Online Ordering provides you with two tools to manage your online ordering site. Web Admin,
accessible through a web browser, allows you to configure your site settings, assign users, manage
consumers, customize your graphics, and much more. Menu Configurator, a tool you download
through Web Admin, enables you to build out your web menu. 
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How Aloha Online Ordering Works
Communication between your online ordering site and the data center occurs to determine the avail-
able order modes, store locations, and items to display on the specific web menu. As the consumer
completes their order, communication between your online ordering site and ATO retrieves the prep
time, tax and total, and sends the order to your store.

Is This Guide for You?
The NCR Aloha Online Ordering User Guide is intended for anyone who manages online orders and
menus, website graphics, and more. This guide assumes you have the following knowledge:

• Basic understanding of terminology and concepts.
• Basic understanding of PCs and Microsoft Windows.
• Understanding of the operation of a computer mouse and keyboard.
• Basic understanding of how to work with Microsoft Windows-based menu structures and 

basic application components, such as scroll bars, buttons, drop-down lists, text boxes, radio 
buttons, and check boxes.

Figure i - 1  Aloha Online Ordering Process
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How This Guide is Organized
This guide is organized as follows:

Introduction
The Introduction discusses NCR Aloha Online Ordering, the pre-screening process, and system
requirements.

Chapter 1: Configuring Company and Site Settings
This chapter discusses how to configure essential company and site settings for your online ordering
site.

Chapter 2: Building Your Online Menu
This chapter discusses how to use of Menu Configurator to build out your web menu.

Chapter 3: Customizing Your Graphics and Content
This chapter discusses the customizing of graphics and content for your online ordering site.

Chapter 4: Working with Comps, Promos, and Upsells
This chapter discusses the configuration of comps, promos, and transaction upsells for your online
ordering site.

Chapter 5: Managing Customer Accounts and Orders
This chapter discusses the management of consumer accounts and orders. 

Chapter 6: Accessing Company Dashboard and Reports
This chapter discusses the various analytics and reports available for you to review and manage your
online ordering site.

Chapter 7: Configuring Online Ordering Features
This chapter discusses select online ordering features, such as group ordering, call center ordering,
and more.

Appendix A: Company Settings
This appendix provides a list of the company settings within Aloha Online Ordering, their purpose,
and values, 

Appendix B: Email Templates and Variables
This appendix provides a listing of the various email templates available within Web Admin. 

Appendix C: Design Elements
This appendix provides a list of the various design elements within Aloha Online Ordering, a descrip-
tion of the element, and their file size.
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Conventions Used in This Guide
Numerous graphics and instructions appear throughout this guide. These conventions make it easy
to find and understand information. 

Symbols and Alerts
The following graphic symbols alert you to important points throughout this guide:

Highlights a special point of interest about the topic under discussion.

Alerts you that the operation being described can cause problems if you are not
careful.

Directs you to a more complete discussion in another chapter of the current
guide, or other reference material.

Points to a useful hint that may save you time or trouble.
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Getting Started with Aloha Online Ordering
A successful implementation of Aloha Online Ordering requires a number of steps. First, you must
gather information about your sites, systems, menus, objectives, and determine your needs. Second,
the NCR Aloha Online Ordering team conducts a pre-screening assessment to determine if your con-
figuration meets the minimum requirements. Once you pass the pre-screening process, the Aloha
Online Ordering team prepares your system for online ordering, which involves making a series of
changes to your system and retrieving your menu data, which they then import into Menu Configura-
tor for you. 

Gathering Information for Your Online Ordering Site
Gather the following information to help you plan your implementation of Aloha Online Ordering. 

• Which store will be your Master store? A master store contains all of the possible menu 
items available for sale online. For example, if you offer menu items at only some locations, 
you must include these items in the master store menu. You can later designate which menu 
items are available on the web menu of a store location. The Aloha Online Ordering team 
imports the menu data from the master store for your online ordering menu.

• Will you have pilot stores? If so, which ones? Some restaurants prefer to roll out their online 
ordering to pilot stores as a means of testing the menu and settings before implementing 
online ordering with all of their sites.

• What types of menus do you have? Some stores have a menu with individual items and a 
separate menu for catering. 

• What order modes do you plan to offer? You might offer pickup, delivery, catering, and 
curbside, or only selected order modes.

• What version of Aloha POS are you running? In some cases, the version of the Aloha POS 
determines the features your online menu can support. 

• Who will have access to configure your settings, site, and menu? Aloha Online Ordering 
provides a number of different access levels for you to control user access.

• Do you plan to customize the graphics for your online ordering site? You can create a 
‘graphics’ user role for the individual whose sole responsibility is to update and maintain your 
online ordering graphic files.

Performing the Pre-Screening Assessment
The Aloha Online Ordering team screens your system to ensure it meets the basic requirements nec-
essary for successfully installing and using Aloha Online Ordering. The screening process seeks to
provide a smoother on-boarding process and identify any potential problems. Use the NCR Aloha
Online Ordering Pre-Screening and System Requirements Quick Reference Guide to familiarize your-
self with the things the Aloha Online Ordering team reviews and to understand the minimum system
requirements.

Preparing Your System
Once a company successfully completes the pre-screening process, the Aloha Online Ordering team
enrolls the company for online ordering and makes adjustments to the client BOH and to the Aloha
configuration to ensure proper communication. Once these changes are complete, the Aloha Online
Ordering team uploads the menu data, imports it into Menu Configurator, and creates the client URL
for you to access Web Admin and configure your online ordering site. 
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About Web Admin
You use Web Admin to control how your online ordering site looks and operates in collaboration with
your in-store operations. You control such things as the users who can access Web Admin, the store
locations that can accept online orders, the time of day during which consumers can submit orders,
the email templates used to communicate with consumers, the look and graphics of your site, dis-
counts, upsell suggestions, and more.

You access Web Admin through a browser the Aloha Online Ordering team provides with a link spe-
cific to your company, and a preliminary user name and password.

1. Open a web browser and enter the URL provided to you by the Online Ordering team. The 
Aloha Online Ordering login screen appears.  

2. Type your user name and password.
3. Click Log In. 

Configuring a Web Admin Member
Aloha Online Ordering refers to user accounts as members. You can create as many members as nec-
essary for your restaurant and assign them specific access levels to restrict their ability to perform
functions, as necessary. In addition to adding new members, you can edit member profiles and
delete members. 

Understanding Member Roles
When creating a member, you must assign the member a role, similar to a POS access level. Each role
provides the member the access necessary to perform their job function.

Figure 1 - 1  Aloha Online Ordering Login Screen
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Table 1: Description of Member Roles 

Role Description

ClientAdmin Permits access to all client functions of Web Admin and Menu Configura-
tor. Provides the ability to manage user roles. Use this role to grant admin-
istrative-level access to a member in Aloha Online Ordering.

ClientSupport Permits all of the same access as the ClientAdmin user role, except does 
not permit the ability to manage user roles.

CallCenterOperator Permits a user to place orders on behalf of consumers and account hold-
ers, view and delete accounts, and view company-wide order history.

SiteAdmin Permits access to manage settings for assigned stores. Can manage such 
things as store information, special events, and view orders and analytics. 
Use this role to grant administrative oversight to users who oversee a 
store or group of stores.

NOTE: Once you create a user with the SiteAdmin role, click ‘+’ next to their 
email address, and then click ‘New’ to assign the user to specific stores.

GraphicDesigner Permits access to the Graphics & Content section of Web Admin. The user 
can upload, download, and delete all graphical files. Use this role for third-
party graphic designers, or to limit the access for internal graphic design-
ers.

MappingAdmin Permits access to the Delivery Zones section of Web Admin. The user can 
assign delivery zones and delivery zone fees. Use this role for users who 
are familiar with the area surrounding a store and who know where to set 
the delivery zone boundaries.

Reporting Permits access to the various reporting functions within Web Admin. The 
user can review accounts, add new accounts, configure contact reasons, 
review past orders, and access the Analytics page. Use this role for market-
ing teams or management personnel to allow them to evaluate the online 
ordering web site performance and to extract consumer information for 
marketing campaigns.

HelpDeskOperator Permits a user to update store information, perform an emergency close, 
set item exclusions, configure special events, and view orders. The role 
operates similarly to SiteAdmin. Use this role for help desk operators who 
assist a store with above store functions.

RestaurantPortal Permits the user to place orders on behalf of consumers, update store 
information, configure special events, and view orders. Users with this role 
can create an order for a consumer and override lead times, prep times, 
and granularity.

NOTE: Once you create a user with the RestaurantPortal role, click ‘+’ next 
to their email address, and then click ‘New’ to assign the user to specific 
stores.
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To create a Web Admin member:

1. In Web Admin, select Admin > Members.
2. Click Add. The Add Member screen appears.

3. Type the email address for the member.
4. Type the first name of the member.
5. Type the last name of the member.
6. Select the role for the member from the ‘Role’ drop-down list. 
7. Type the password for the member and retype the password in ‘Verify Password.’
8. Select Active to activate the member role.
9. Click Update. You must provide the member with the logon link, their user name, and pass-

word.

To change your password:

1. In Web Admin, select Admin > Members.
2. Select your member profile. The Add Member screen appears.
3. Click Change Password.
4. Enter your current password.
5. Type your new password, and retype the password in ‘Verify Password.’
6. Click Update.

Figure 1 - 2  Add Member Screen
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To edit or delete a member:

You can edit a member to change their email address, first or last name, role, and lock an active
member, which prevents them from accessing Aloha Online. The lockout also restricts a consumer
already logged in prior to a lockout from creating and sending an order. You can also delete a mem-
ber.

1. In Web Admin, select Admin > Members.
2. Select the member to edit. The Add Member screen appears.
3. Click Edit, make the necessary changes, and click Update. 

-OR-

Click Delete to remove the member. 

Viewing Logs
You can use logs to view system activity and assist you in troubleshooting issues, such as consumers
experiencing problems placing online orders. At the Logs screen, the most recent information for all
message types, up to one hundred rows, appears. You can filter the log by date and time, message
type, activity module, design ID, site, or by order. 

To filter a log view:

1. In Web Admin, select Admin > Logs.
2. Select a starting and ending date for which to filter the log. The system does not require you 

to select an ending date.
3. Select a message from the ‘Message Type’ drop-down list. The options are ‘All,’ ‘Info,’ ‘Warn-

ing,’ and ‘Error.’
4. (Optional) Enter the following to further filter the log:

• Module - The activity module. A specific module of the application that performs a set of 
specific actions, such as Data Import or POS Config Change.

• Design - The design ID.
• Site - The site location number.
• Order- The consumer order number.

5. Click Search. Results appear to the right of the filter.

Configuring Company Settings
Company settings allow you to define how your online ordering site looks and operates. Company
settings control the configuration for all of your site locations; however, you can override some set-
tings on a site by site basis. When you access the Company Settings Setup page, the systems lists the
available company settings in alphabetic order. You can create multiple sets of company settings, and
apply a set to a specific site location. 

Use caution when deleting a member as the system does not provide a warning mes-
sage prior to deleting the member.
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At a minimum, you must configure the following company settings:

• AccountCreationSubject
• AccountManagementDisplayName
• AdvancedLandingPage
• AllowedPaymentLocations
• BufferAm
• BufferPM
• MaxOrderTotalAmount
• MinOrderTotalAmount
• MaxPayAtSite
• OrderCancelReceiptSubject
• OrderDisplayName
• OrderReceiptSubject
• OrderWebsiteTitle
• PrivacyPolicyURL
• SupportDisplayName
• SupportEmailAddress
• TermsOfUseURL

Refer to Company Settings for more information on the available settings, their purpose, the possible
values, and the default value, if any.

Use caution when editing the value of a company setting. Entering an incorrect value 
can cause your online ordering site to work improperly.

Figure 1 - 3  Company Setup Screen
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To add or edit a company setting:

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select the settings set to edit from the ‘Choose Settings Set’ drop-down list. If you do not 

plan on creating multiple sets, select the ‘Default Set.’
3. Select the setting to add or edit.

4. Click Add Setting or Edit Setting. The appropriate screen appears.
5. Type the setting in ‘Setting,’ if needed. 
6. Change the value, as necessary.
7. Click Update.

To create a copy of company settings: 

Use the Clone Settings function to create a copy (clone) of the default company settings with their
original values, which you can then customize and apply to other store locations. Cloning a set does
not copy all of the custom values you entered in the set you copy from. You must edit the values in
the new set.

1. In Web Admin, select Configuration > Company Settings Setup, 
2. Click Clone. The Clone Setting Set screen appears.

3. Type a name for the new set.
4. Type a description for the new set.
5. Click Update. 

When you copy (clone) a site, the system copies the site setup configuration from the original site to
the new site. You can optionally include all site group or comp associations, essentially mimicking the
configuration from the originating site. 

Figure 1 - 4  Edit Company Setting

Figure 1 - 5  Clone Setting Set
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To clone a site with site group and comp configuration: 

1. In Web Admin, select Configuration > Site Setup > Sites. 

2. Select a site from the list, and click Clone Site. A message appears asking you if you want to 
apply the site groups or comps from the originating site to the cloned site. 

3. Select Site Groups to add the site groups associated with the originating site to the new site. 
4. Select Comps to add the comps associated with the originating site to the new site. 
5. Click Clone to complete the copying of the originating site to the new site or click Cancel to 

stop the operation. 

Configuring an Email Template
Aloha Online Ordering contains a number of email templates for you to use with your online ordering
site to communicate with your consumers. The email templates contain default text and email vari-
ables. The email message generated by the system uses the values from the email variables or infor-
mation entered by the consumer at the online ordering site. Each email template contains a limited
number of email variables, and the system lists these to the right of the email message template edi-
tor.

Refer to Email Templates and Variables for more information on the email templates and the vari-
ables available within each template.

Figure 1 - 6  Sites Screen

Figure 2  Clone Site Message
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To edit an email template: 

1. In Web Admin, select Configuration > Template Setup > Email Template Setup.

2. Select an email template from the ‘Select By Email Type’ drop-down list.
3. Type the from email address for the email message.

• You must specify a ‘from email address’ for each email template.
• The Aloha Online Ordering site does not prevent consumers from replying to an automat-

ically generated email message. To prevent consumers from replying to these email tem-
plates, configure a ‘do not reply’ email address, such as ‘donotreply@alohadiner.com.’ 
Also, consider including text in the email template informing your consumers the email 
address is unmonitored and to call the store with any questions.

• If a specific site location wants to receive a copy of all order email messages as the system 
generates them: 

a. Select Configuration > Site Setup > Sites.
b. Select the site.
c. Click Edit Site.
d. On the Site Details tab, type the email address in Retail Order BCC email to send a 

blind-copy confirmation email to the site when a consumer places a retail order. For 
example, you may want to enter the address that your retail manager specifically 
uses. 

e. Type the email address in Catering Order BCC email to send a blind-copy confirma-
tion email to the site when a consumer places a catering order. For example, you may 
want to enter the address that your catering manager specifically uses. 

f. Click Update.

4. Type the display name for the email message. The display name controls what the consumer 
sees when they receive the email message in their email client. Update the name to reflect 
the company online ordering site, such as ‘Nico Cocina Online Ordering.’

Figure 1 - 1  Email Template Setup
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5. Modify the subject line for the email message template. Update the name to reflect the com-
pany name and the email message. For example, for an order confirmation email message, 
change the subject line to ‘Nico Cocina Order Confirmation.’

6. (Optional) Add or remove the available variable tags within the email template. 

• You may only use the allowed variable tags for the email template. The system does not 
display any unsupported variable tags. 

• To use a tag, copy and paste the entire tag line, including the brackets, into the available 
space within the email message template.

7. (Optional) Edit the text to display on the email message template. 

• Use the editing toolbar at the top of the email text box, as necessary.
• To use or view the HTML tags, select the HTML Editor button at the bottom left of the 

screen. The system hides the editing toolbar and you can edit the text using basic HTML 
tags. Click the Design button to exit the HTML editor and display the editing toolbar. 

8. Click the Preview button at the bottom left of the screen to preview your changes.
9. Click Save.

Configuring an FAQ Page
Create an FAQ page to assist your consumers with the use and navigation of your online ordering
web site. When you enable the FAQ page, the system adds a link to the navigation bar, which the con-
sumer can click to access your FAQ page. You can use the rich text editor to enter and edit the text for
your FAQ page, or you can use an HTML editor. You can even include hyperlinks on your FAQ page.
Configuring an FAQ page is a two step process. You must first enable the FAQ page through company
settings, then create your FAQ page.  

To enable the FAQ page:

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select the set for which you want to enable the FAQ page from the ‘Choose Settings Set’ drop-

down list.

Figure 1 - 2  FAQ Page
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3. Select FAQEnabled.
4. Click Edit Setting.
5. Enter True for the value.
6. Click Update and continue to the next procedure to define the content for your FAQ page.

To define the content for the FAQ page:

1. In Web Admin, select Configuration > Template Setup > FAQ Page Setup.

2. Enter and edit the text to appear on the FAQ page.

• Use the editing tool bar at the top of the email text box, as necessary.
• To use or view the HTML tags, select the HTML Editor button on the bottom left side of 

the screen.The system hides the editing tool bar and you can edit the text using basic 
HTML tags. Click the Design button to exit the HTML editor and display the editing tool 
bar. 

3. Click the Preview button on the bottom left side of the screen to preview your changes.
4. Click Save. 
5. Click OK. Your online store contains an FAQ page with the text you entered.

Figure 1 - 3  FAQ Configuration
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Configuring Text to Appear on Your Site
Use Messages Setup to customize any of the standard text appearing on your online ordering site.
The Messages Setup screen contains the following columns:

• Id - Contains the name representing the text body.
• Description - Provides a description of the text body.
• Default - Displays the standard text appearing on your online ordering site.
• Custom Message - Displays the custom message you entered. 

To edit a message:

1. In Web Admin, select Configuration > Messages Setup.
2. Select the culture from the ‘Choose Culture’ drop-down list, if needed. You must change the 

message for each culture you use.
3. Select the message to edit. 

Figure 1 - 4  Messages Setup

To locate a specific message, type a specific portion of the message in the Default box. Mes-
sages with matching text appear in the list.

Click Edit to 
change the text 
for a a message.
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4. Click Edit on the right side. The Edit Message screen appears.

5. Type the custom message to appear on your online ordering site.
6. Click Update. The system returns to the Message Setup screen.

Configuring Settings for each Store Location
You can manage the online ordering settings for each store location. You must first add the store
locations for which you plan to use online ordering. Use Site Locations to manage the settings for
each store location. 

Adding a Site Location
The Sites screen enables you to add and edit site locations, and to manage the settings for a specific
location. Use this screen to enter information about the store location, such as the physical address,
the store hours, delivery hours, site messaging, mobile settings, and other settings specific to the
store. The Aloha Online Implementation team handles the settings related to the Submission Details
tab.

Figure 1 - 5  Edit Message
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To add a site location:

1. In Web Admin, select Configuration > Site Setup > Sites.
2. Click Add Site to add a new site location. 

3. Type the store location name. 
4. Type a description for the location, if desired. The description does not appear on the Loca-

tions page. Large multi-site operations may use a description to designate between corporate 
versus franchise store. 

5. Enter the store location physical address.
6. Type the city, state and postal code for the store location.
7. Type the external Id for the store location, if needed.
8. Type the voice phone number for the store location.
9. Type the fax phone number for the store location.
10. Select Browsable from the ‘Locator’ drop-down list to make the store visible on the Locations 

page of your online ordering site, or select NotBrowsable to hide the store on the Locations 
page. 

11. Select from the ‘Live Orders’ drop-down list, according to one of the following settings:

• NotAcceptingOrders - A consumer can view the menu, if you set the Store Locator set-
ting to Browsable, but the store cannot accept online orders.

• PreLive - The store is in the testing phase, where you submit online orders to ensure all 
operational needs are satisfied. During the implementation process, it should set a store 
to PreLive. The Live Orders setting controls the ability of the store to take online orders, 

Figure 1 - 6  Edit Site Settings Screen
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• PublicLive - The store is live and accepting online orders from consumers.
• CallInOrdersOnly - Use this setting only when using Call Center Functionality.  

12. Select True from the ‘Ordering Enabled’ drop-down list to enable the store to receive orders, 
or select False to disable the store from receiving orders. Do not make changes to this setting 
without consulting the Aloha Online Ordering Implementation team.

13. Enter the delivery range for the store location, or do not specify a range if you want to use 
the delivery ranges established in company settings. The delivery range identifies the delivery 
radius for the site location, unless you configure a delivery zone.

14. Click Geocode at the bottom of the screen. The system determines and then fills in the ‘Lati-
tude’ and ‘Longitude’ of the site location based on the address you entered.

15. Select True from the ‘Pickup Enabled’ drop-down list if the store location offers the pickup 
order mode, or select False to disable customer pickup.

16. Click Curbside if you offer curbside pickup to your consumers. When you enable curbside 
pickup, additional options appear on the check out page of the online ordering site for the 
consumer to enter their car make, model, and color. 

17. Select True from the ‘Delivery Enabled’ drop-down list, if the store location offers delivery of 
orders, or select False to disable delivery. 

18. Select the web design ID from the drop-down list. The web design ID reads as the concept 
name and associates features within other areas of Web Admin to a particular location.

19. (Optional) Enter an email address to designate an email address at the store location to 
receive copies of all order email messages generated by the system. To enter multiple 
addresses, enter a semicolon between email addresses.

20. Enter the amount of time in minutes for the pickup prep lead time for the store location. 
Leave blank if you plan to use the value established in company settings.

21. Enter the amount of time in minutes for the delivery prep lead time for the store location. 
Leave blank if you plan to use the value established in company settings.

22. Click Update at the bottom of the screen. 

Consult with the Aloha Online Implementation Team at support@alohaenter-
prise.com prior to making changes to the ‘Live Orders’ setting.

For the order modes you select, You must set the same order modes in Menu Configurator > 
Web Menu > Menu Management.
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To define the store hours of the online ordering site for the store location:

Use the Store Hours tab to designate the times of day during which you want the online ordering site
to allow consumers to submit orders to the store location. 

1. While still in the Sites function, select the Store Hours tab.
2. Select the day of week to edit.

3. Click Edit.
4. Make the desired changes. 

• Click Closed to prevent a consumer from submitting online orders for a particular day. 
• To change the time of day, select the hour, minutes, or AM/PM, and use the up and 

down arrow buttons to make the desired changes.

5. Click Update to the right of the day.
6. Repeat steps 2 through 5 to edit other days of the week.
7. Click Update at the bottom of the screen.

To define the online order delivery hours for a store location:

Use the Delivery Hours tab to designate the time of day during which a consumer can place an online
order for delivery. If necessary, you can set staggered times, if you only support delivery at specific
times during the day. If your delivery hours are the same as your store hours, it is not necessary to
add the information again. If you select Closed for a day of the week on the Delivery Hours tab, when
a consumer attempts to place an order for delivery, they receive the following message, ‘Sorry, there
are no available delivery times for this date.’

1. While still in the Sites function, the Delivery Hours tab.
2. Select the day of week to edit. 

Figure 1 - 7  Edit Store Hours

Figure 1 - 8  Edit Delivery Hours
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3. Click Edit to the far right of the selected day.
4. Make the desired changes.

• Click Closed to prevent a consumer from submitting a delivery order for the selected day. 
• To create a time period in which you allow delivery for online orders, enter the start time 

in ‘Period 1 Start’ and the end time in ‘Period 1 End.’ The system allows you to create two 
periods for delivery for each day.

5. Click Update to the far right of the selected day.
6. Repeat steps 4 through 7 to edit other days of the week.
7. Click Update at the bottom right of the screen.

To add site-specific text to the receipt area:

Use the Site Messaging tab to specify site-specific information to appear in the receipt area on the
Select a Pickup Time page of the online ordering site when the receipt area is empty. The Site-specific
messaging supports the use of basic HTML tags and rich text editing. Typically, depending on the font
size and box dimensions, you can display between nine hundred and a thousand characters. 

Figure 1 - 9  Receipt Area of Web site
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1. White still in the Sites function, select the Site Messaging tab. 

2. Enter and edit the text to appear.

• Use the rich text editing tool bar at the top, as necessary.
• To use or view the HTML tags, select the HTML Editor button on the bottom left side of 

the screen. The system hides the editing tool bar and you can edit the text using basic 
HTML tags. Click the Design button to exit the HTML editor and display the editing tool 
bar. 

3. Click the preview button on the bottom left side of the screen to preview your changes. 
4. Click Update at the bottom of the screen. 

To apply settings specific to a store location:

Use the Site Settings tab to override the company settings for a specific store location. The system
only allows you to override the following settings:

• Pickup Minimum
• Delivery Minimum
• Maximum Order Total Amount
• Maximum Line Item Quantity
• Maximum Order Line Count
• Menu Lead Time Days
• Pickup Lead Time Hours
• Delivery Lead Time Hours
• Maximum Order Future Day Count
• Hide Tax

Figure 1 - 10  Site Messaging Edit Site Screen
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Refer to Company Settings for more information on the values you can enter for these settings.

1. While still in the Sites function, select the Site Settings tab.

2. Enter the value for the setting you want to override.
3. Click Update on the bottom of the screen.

To configure mobile settings for a store location:

Use the Mobile Settings tab to override the company settings related to mobile ordering for a specific
store location.

1. While still in the Sites function, select the Site Details tab. 
2. Select True from the ‘Mobile Enabled’ drop-down list.
3. Select the Mobile Settings tab.

Figure 1 - 11  Site Settings Edit Site

Figure 1 - 12  Mobile Settings Tab
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4. Under ‘Optional mobile specific settings that will override company settings,’ specify the 
mobile settings for which you want to override the values in company settings. Refer to 
Company Settings for more information on the values you can enter for these settings. You 
can modify the following:

• Minimum Order Total Amount
• Maximum Order Total Amount
• Maximum Line Item Quantity
• Maximum Order Line Count

5. Under ‘Optional Site-Specific Instructions for Mobile orders,’ select the destinations to lock 
and select the mobile setting for which to apply the destinations from the ‘Configure Instruc-
tions For’ drop-down list.

6. (Optional) Under ‘Optional Site-Specific Mobile Curbside Zone Configuration,’ select Disable 
Curbside Zones.

7. Click Update at the bottom of the screen. 

To configure PayPal settings for a store location:

Before you can configure the settings for PayPal, you must change the value for EnablePayPalHere in
company settings to True. After which, the PayPal tab appears on the Edit Site screen. For information
on editing a company setting, refer to “To add or edit a company setting:” on page 1-8.

1. While still in the Sites functions, select the PayPal tab.

2. Enter the access token.
3. Enter the refresh token.
4. Enter the Id token.
5. Enter the token type.
6. Enter the expiration date.
7. Type the merchant email address.
8. Enter the PayPal location ID.
9. Click Update at the bottom of the screen. 

To edit a site location:

You can quickly and easily edit the information and configuration for an online ordering site location.

1. In Web Admin, select Configuration > Site Setup > Sites.
2. Select a store location.
3. Click Edit Site.

Figure 1 - 13  PayPal Tab
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4. Make the necessary changes.
5. Click Update.

To clone a site location:

Use the Clone Site function to quickly add an additional location. This saves data-entry time as the
system creates a new store and copies the data from the first location into the cloned location. When
you click Clone Site, the system displays the Edit Site screen for you to edit the information for the
additional location.

1. In Web Admin, select Configuration > Site Setup > Sites.
2. Select a store location to clone.
3. Click Clone Site. The system duplicates the store location information and displays the Edit 

Site screen for the new location.
4. Update the information as necessary. For example, you may need to edit the address, 

phone, live order status, and online ordering store hours information.
5. Click Update.

Assigning Company Settings to a Site Location
By default, the system assigns the default company settings to all site locations. If you create addi-
tional sets, use the Site Setting Assignment function to assign the set to a site location. If you plan to
use the default set for all of your site locations, skip this procedure.

1. In Web Admin, select Configuration > Site Setup > Site Setting Assignment.

2. Select a setting set from the ‘Choose Setting Set’ drop-down list. The sites assigned to the set 
appear under ‘Selected Sites,’ and the sites assigned to other sets appear under ‘Available 
Sites.’

3. Under ‘Available Sites,’ select the site location to which to apply the set, and click Add 
Selected. The system moves the site to ‘Selected Sites.’ To remove a site location from a set, 
under ‘Selected Sites,’ select the site location, and click Remove Selected.

4. Click Update.

Figure 1 - 14  Site Setting Assignment
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Using a Special Event to Override Normal Hours
Use Special Events to designate specific periods of time during which the online ordering store does
not accept orders or when the online ordering store will open or close at other than normal times.
Special Events temporarily override the hours listed in Site Set Up > Sites. If you plan to close or oper-
ate at shortened hours for holidays, you must use the Special Events function to define those time
periods. If you configure overlapping special events, the system applies the first special event in the
list.

To create a special event to override normal hours:

1. In Web Admin, select Configuration > Site Setup > Special Events. 
2. Click Add Special Event.

3. Type a name for the special event. The name only appears in Web Admin. When a consumer 
selects the Time page, the date is not available for selection. 

4. Select a start date for the special event.
5. Select an end date for the special event.
6. Select Is Closed if you plan to close for the entire day for the special event. When you select ‘Is 

Closed,’ ‘Open Time’ and ‘Close Time’ are not available and the system automatically selects ‘Is 
Closed For Delivery.’

-OR-

Enter an open time and a close time for the special event.

Web Admin does not recognize holiday patterns, such as Christmas Day or New Year’s Day. 
Each year, you must enter or edit the holiday information.

Figure 1 - 15  Special Events 
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7. (Optional) Type a description for the event purpose. The description only appears in Web 
Admin.

8. Click Is Closed for Delivery, if you do not plan to offer delivery for online orders for the spe-
cial event.

-OR-

Enter the start time and end time for the specific periods for which you plan to offer deliv-
ery for orders.

If you configure a special event, do not select ‘Is Closed For Delivery,’ and do not enter a start 
and end time for delivery, the system uses the store times for the available delivery times.

9. To assign a special event to a site, perform one of the following: 

• To assign a special event to all site locations, select Is Company Wide. The system moves 
all site locations from ‘Available Sites’ to ‘Selected Sites.’ 

• To assign a special event by adding the sites from a site group, select a site group from 
the ‘Add/Remove by Site Group’ list and click Add Selected Group. The sites included in 
the site group appear in the ‘Selected Sites’ list. 

• To unassign a special event by removing the sites found in the site group, select a site 
group from the ‘Add/Remove by Site Group’ list and click Remove Selected Group. The 
sites included in the site group are removed from the ‘Selected Sites’ list. 

• To assign a special event to a single site, select the site from the ‘Available Sites’ list box 
and click Add Selected to move the site to the ‘Selected Sites’ list box. 

• To assign a special event to all sites, click Add All to move all sites to the ‘Selected Sites’ 
list box. Notes: This is the default behavior when you first add a special event. 

• To exclude a special event from a single site, select the site from the ‘Selected Sites’ list 
box and click Remove Selected to move the site to the ‘Available Sites’ list box. 

• To exclude a special event from all sites, click Remove All to move all sites to the ‘Avail-
able Sites’ list box. 

10. Click Save.
11. Click Close.

To edit or delete a special event:

1. Select Configuration > Site Setup > Special Events. 
2. Select the special event to edit or delete.
3. Click Edit Special Event, make the necessary changes, click Save, and click Close.

-OR-

Click Delete Special Event to remove the special event. 

Use caution when deleting a special event as the system does not provide a warning 
message prior to deleting the special event.
1 - 24 Configuring Company and Site Settings Aloha Online Ordering User Guide



 

Designating a Site as Closed
In some situations, it may be necessary to designate a site as closed for emergency purposes.

1. In Web Admin, select Configuration > Site Setup > Emergency Close. 

2. To assign an emergency closed event to a site, perform one of the following: 

• To assign an emergency closed event to a single site, select the site from the ‘Available 
Sites’ list box and click Add Selected to move the site to the ‘Selected Sites’ list box. 

• To assign an emergency closed event to all sites, click Add All to move all sites to the 
‘Selected Sites’ list box. Notes: This is the default behavior when you first add a emer-
gency closed event. 

• To exclude an emergency closed event from a single site, select the site from the 
‘Selected Sites’ list box and click Remove Selected to move the site to the ‘Available Sites’ 
list box. 

• To exclude an emergency closed event from all sites, click Remove All to move all 
sites to the ‘Available Sites’ list box. 

3. Click Update.

Adding Text About a Site to Store Locator
Site attributes enable you to add text about a site location on the Store Locator page, such as ‘Now
Serving Shrimp!’ This text appears below the address, phone, and hours of operation, and the system
offsets the site attribute text with an asterisk. You can add multiple lines of site attribute text and
arrange the order in which they appear. After you create the site attribute text, you then assign the
text to site locations.

Figure 1 - 16  Emergency Close Screen
Aloha Online Ordering User Guide Configuring Company and Site Settings 1 - 25



To create the text to appear on store locator:

1. In Web Admin, select Configuration > Site Setup > Site Attributes. 

2. Click Add Attribute. The Edit Attribute screen appears.
3. Leave the Attribute ID blank as the system assigns this number to the site attribute.
4. Type the text to appear on the website in the name field.
5. Assign a ranking to the text with a numerical value. If you assign multiple site attributes to a 

site location, the system displays them according to their ranking, with ‘1’ being the highest 
ranking.

6. Click Show on Store Locator.
7. (Optional) type the file name for a graphics file to display with the site attributes text.
8. Click Update, and continue to the next procedure to assign the site attribute text to a site 

location.

To assign a site attribute to a site location:

1. IN Web Admin, select Configuration > Site Setup > Site Attribute Assignment.
2. Select a site location from the ‘Choose Site’ drop-down list. 
3. Click Add Attribute. The Add Attribute to Site screen appears. 

4. Select the site attribute to add to the site location.
5. Click Update. The system adds the site attribute to the site location.

Figure 1 - 17  Edit Attribute Screen

Figure 1 - 18  Add Attribute to Site Screen
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To edit or delete a site attribute:

1. Select Configuration > Site Setup > Site Attributes.
2. Select the site attribute to edit or delete.
3. Click Edit Attribute, make the necessary changes, and then click Update.

-OR-

Click Delete Attribute to remove the site attribute.

To remove a site attribute from a site location:

In some cases, you may not want to delete a site attribute, but you may want to remove it from a par-
ticular site location.

1. Select Configuration > Site Setup > Site Attribute Assignment.
2. Select the site location from the ‘Choose Site’ drop-down list.
3. Select the site attribute to remove from the store location.
4. Click Delete Attribute. The system only removes the site attribute from the store location; it 

does not delete the site attribute.

Use caution when deleting a site attribute as the system does not provide a warning 
message prior to deleting the site attribute.
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Configuring Lead Times and Prep Times
Prep times and lead times allow you to calculate the next available time slot during which a con-
sumer can receive an order. You can establish a global prep time and lead time at the company level
and then override these settings at the site level, if needed. You can also configure the number of
minutes after a store opens at which the online ordering site can begin accepting orders. For exam-
ple, if the online site opens at 11:00 a.m., you may set a buffer of 15 minutes and begin accepting
online orders at 11:15 a.m. The system supports the buffer setting at the company level only. 

Configuring Lead Times
You can specify the next available time slot for which a consumer can receive an order, relative to the
time at which the consumer places the order. Aloha Online Ordering does not require you to config-
ure lead times.

You can set three types of lead times:

• Menu Lead Time Days — Specifies the number of days in the future for the first available 
order. The order time available is always the first available time for that day. You can create 
menu lead time days as a company setting, and you can create a site setting to override the 
value in company settings.

• Pickup Lead Time Hours — Specifies the exact number of hours in the future for the first 
available order time for pickup orders. The hours calculate in exact calendar hours from the 
current time. Menu Lead Time Days overrides Pickup Menu Lead Time Hours. You can create 
menu lead time days as a company setting, and you can create a site setting to override the 
value in company settings.

• Delivery Lead Time Hours — Specifies the exact number of hours in the future for the first 
available order time for delivery orders. The hours calculate in exact calendar hours from the 
current time. Menu Lead Time Days overrides Delivery Menu Lead Time Hours. You can cre-
ate menu lead time days as a company setting, and you can create a site setting to override 
the value in company settings.

• (Pickup/Delivery) Prep Lead Time — Specifies a certain number of minutes after open 
when the first order is available. This is available as a site setting only. This setting works in 
conjunction with ‘Menu Lead Time Days.’

To configure Menu Lead Time Days as a company setting:

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select MenuLeadTimeDays.
3. Click Edit Setting.
4. Change the value to the desired lead time. For example, if you were to enter ‘2’ as the value, 

the first available order time is two days in the future, at the time the store opens. 
5. Click Update.

To configure Menu Lead Time Days as a site setting:

1. In Web Admin, select Configuration > Site Setup > Sites.
2. Select the site location.
3. Click Edit Site.
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4. Select the Site Settings tab.

5. Type the number of days in Menu Lead Time Days.
6. Click Update.

To configure Pickup Lead Time Hours as a company setting:

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select PickupLeadTimeHours.
3. Click Edit Setting.
4. Change the value to the desired lead time. For example, if you were to enter ‘24’ as the value, 

the first available order time is twenty four hours from the present time.
5. Click Update.

To configure Delivery Lead Time Hours as a company setting:

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select DeliveryLeadTimeHours.
3. Click Edit Setting.
4. Change the value to the desired lead time. For example, if you were to enter ‘24’ as the value, 

the first available order time is twenty four hours from the present time.
5. Click Update.

To configure Pickup and Delivery Lead Time Hours as a site setting:

1. In Web Admin, select Configuration > Site Setup > Sites.
2. Select the site location.
3. Click Edit Site.

Figure 1 - 19  Menu Lead Time Days Site Settings Tab
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4. Select the Site Settings tab.

5. Type the number of hours in Pickup Lead Time Hours.
6. Type the number of hours in Delivery Lead Time Hours.
7. Click Update.

To configure (Pickup/Delivery) prep lead time:

1. In Web Admin, select Configuration > Site Setup > Sites.
2. Select the site location for which you want to add a prep lead time.
3. Click Edit Site.
4. Select the Site Details tab.
5. Type the minutes for a Pickup Prep Lead Time, and type the minutes for a Delivery Prep 

Lead Time. For example, if the Menu Lead Time Day is ‘1’ and the Pickup Prep Lead Time is 
‘120’ and the Delivery Prep Lead Time is ‘60,’ then for an order placed on Monday at 3 p.m. the 
next available order time is Tuesday at 5 p.m. for pickup and 4 p.m. for delivery.

6. Click Update.

Configuring a Prep Time
Aloha Online Ordering allows you to configure prep times for your online orders. If you use Aloha
Takeout, you can employ those configured prep times, or you can create a separate setting in Web
Admin.  

To configure a prep time in Web Admin:

1. In Web Admin, select Configuration > Site Setup > Sites.
2. Select the site.
3. Click Edit Site.

Figure 1 - 20  Menu Lead Time Days Site Settings Tab

Refer to the NCR Aloha Takeout Implementation Guide for more information on configuring 
prep times. 
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4. Select the Submission Details tab.

5. Select Use Below Store PrepTimes. A prompt appears.
6. Click OK.
7. Select the time zone for the site location from the drop-down list.
8. Type the minutes for Pickup Prep Time.
9. Type the minutes for Delivery Prep Time.
10. Click Update.

Configuring a Prep Time Adjustment
Prep time adjustments enable you to configure additional prep time for your kitchen staff when a
consumer places an order at or above a certain amount. As the consumer adds items to their online
order and reaches the specified amount, the system notifies the consumer of the new promise time
before the Payment page. The consumer must accept the new promise time or reduce the number of
items contained in the order. 

You can create tiers of prep time adjustments. For example, for orders reaching $100, you can create
a prep time adjustment of 30 minutes. For orders reaching $200, you can create a second tier further
adjusting the prep time to 60 minutes. For orders reaching $300, you can create a third tier further
adjusting the prep time to 90 minutes.

Figure 1 - 21  Submission Details Tab
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To add a prep time adjustment:

1. In Web Admn, select Configuration > Site Setup > Prep Time Adjustments. 
2. Click Add Adjustment.

3. Type the name for the adjustment.
4. Type a description for the adjustment. 
5. Select the Adjustment Tiers tab. 

6. Click New.
7. Enter the minimum amount for the tier.
8. Enter the additional minutes of prep time.
9. Click Update.
10. Click New to add additional tiers, if necessary. You can also edit a tier by clicking Edit, or 

delete a tier by clicking Delete. 
11. Select the Assigned Sites tab. 

Figure 1 - 22  Edit Adjustment

Figure 1 - 23  Edit Adjustment Tiers

Figure 1 - 24  Assigned Sites

Click New.
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12. Click Add All to add the prep time adjustment for all store locations.

-OR-

Select a specific site location and click Add Selected to add the prep time adjustment for 
the site location.

13. Click Update.

To edit or delete a prep time adjustment:

1. In Web Admin, select Configuration > Site Setup > Prep Time Adjustment.
2. Select the prep time adjustment to edit or delete.
3. Click Edit Adjustment, make the necessary changes, and click Update.

-OR-

Click Delete Adjustment to remove the prep time adjustment.

Configuring Buffer A.M. Pickup and Buffer A.M. 
Delivery Prep Times
You can configure the number of minutes after a store opens at which the online ordering site can
begin accepting orders. For example, if the online site opens at 11:00 a.m., you may set a buffer of 15
minutes and begin accepting online orders at 11:15 a.m. 

Use caution when deleting an adjustment as the system does not provide a warning 
message prior to deleting the adjustment.

Figure 1 - 25  Edit Site - Site Settings Tab
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These settings allow you to establish a buffer for each individual site and override the company set-
ting ‘BufferAM’ in Configuration > Company Settings Setup. 

The ‘Buffer AM Pickup Prep Time Minutes’ and ‘Buffer AM Delivery Prep Time Minutes’ also respect
the company setting ‘MenuLeadTimeDays’ in Configuration > Company Setting Setup. The system
adds the number of days of lead time to the buffer AM value. 

When you enter a value for the company setting ‘MenuLeadTimeDays’ the ‘Buffer AM Pickup Prep
Time Minutes’ and ‘Buffer AM Delivery Prep Time Minutes’ also respect the ‘Pickup Prep Lead Time’
and ‘Delivery Lead Time’ options in Configuration > Site Setup > Sites > Site Details tab. If you set a
value in these options, the system uses the higher value of the pickup or delivery configuration,

Figure 1 - 26  BufferAM Setting in Configuration > Company Settings Setup

Figure 1 - 27  MenuLeadTimeDays in Configuration > Company Settings Setup
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respectively. For example, if you enter ‘30’ in ‘Pickup Prep Lead Time’ and also enter ‘15’ in ‘Buffer AM
Pickup Prep Time Minutes,’ the system uses the value in ‘Pickup Prep Lead Time’ because it has the
higher value and it does not use the value in ‘Buffer AM Pickup Prep Time Minutes.’ 

To configure a buffer for the pickup and delivery prep time minutes at the site level: 

1. In Web Admin, select Configuration > Site Setup > Site. 
2. Select a site from the list and click Edit Site.
3. Select the Site Settings tab (Figure 1 - 25). 
4. Type the number of minutes in ‘Buffer AM Pickup Prep Time Minutes.’
5. Type the number of minutes in ‘Buffer AM Delivery Prep Time Minutes.’ 
6. Click Update.
7. Repeat this procedure for each site for which you want to configure the pickup and delivery 

prep time minutes. 
8. Exit the Site Setup function. 

Figure 1 - 28  Lead Time Options in Configuration > Site Setup > Sites > Site Details Tab
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Assigning Settings to a Group of Stores
Use Site Group Setup to assign settings or attributes to a group of stores, rather than making your
changes on a store-by-store basis. You can use site groups for exclusions, First, you create a site
group, and then you assign the store locations to the site group. 

To create a site group:

You must first create a site group before you can assign store locations to a group. You can create as
many site groups as necessary.

1. In Web Admin, select Configuration > Site Group Setup > Site Groups.
2. Click Add Site Group. The Add Site Group screen appears. 

3. Type the name for the site group.
4. Type a description for the site group to assist you in quickly identifying the group, such as 

‘Dallas stores,’ or ‘Fort Worth stores.’
5. Click Update.

To edit or delete a site group:

1. In Web Admin, select Configuration > Site Group Setup > Site Groups.
2. Select the site group to edit or delete.
3. Click Edit Site Group, make the necessary changes, and then click Update.

-OR-

Click Delete Site Group to remove the site group.

To add a store location to a site group:

After you create a site group, you can assign store locations to the site group.

1. In Web Admin, select Configuration > Site Group Setup > Site Group Assignments.
2. Select the site group for which you want to add store locations from the ‘Choose Site Group’ 

drop-down list.

Figure 1 - 29  Add Site Group Screen

Use caution when deleting a site group as the system does not provide a warning 
message prior to deleting the site group.
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3. Under ‘Available Stores,’ select the store location to add to the site group, and click Add 
Selected. The system moves the store location to ‘Selected Sites.’ To remove a store location 
from a site group, under ‘Available Stores,’ select the store location and click Remove 
Selected. The system moves the store location to ‘Available Sites.’

4. Click Update.
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Configuring a Delivery Zone
Aloha Online Ordering can use a defined delivery radius or a delivery zone to determine a delivery
area for your online ordering. By default, Aloha Online Ordering uses the defined delivery radius,
which you set in Configuration > Site Setup > Sites > Site Details tab. It is possible to have some site
locations using a delivery radius, and other site locations using a delivery zone. 

You configure a delivery zone by site location. Additionally, you can define areas within a delivery
zone to which you do not deliver. When you configure the delivery zone for a site location, the deliv-
ery area appears on the online ordering site. For site locations close together, it is possible to create
delivery zones that overlap. Consumers can then choose the store location from which to place an
online order for delivery. If a consumer enters an address for delivery, and the address falls outside
of the delivery area, the online ordering site allows the consumer to place an order for pickup.    

Prior to configuring a delivery zone, you must contact your Aloha Online Ordering represen-
tative or send an email message to the Aloha Online Ordering Team at support@alohaenter-
prise.com to enable delivery zone functionality for you.

Figure 1 - 30  Online Ordering Site - One Site Location Available
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Figure 1 - 31  Online Ordering Site - Consumer Resides Inside Two Delivery Zones
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To configure a delivery zone:

1. In Web Admin, select Configuration > Delivery Zones > Delivery Zone Configuration.

2. Select the site location for which you want to add a delivery zone from the ‘Select Site’ drop-

down list. The system navigates to a map view, and  indicates the site location on the 
map. If the system navigates to a different address, reset the longitude and latitude settings 
for the site location using the Geocode button in Configuration > Site Setup > Sites > Site 
Details tab.

3. Type a name for the delivery zone.
4. Click Add Zone. The delivery zone you create for the site location is exclusive to the selected 

site location. The system adds ‘Site Zones’ to the left of the map.
5. (Optional) Change the color for the delivery zone, using one of the following: 

Select the color from the color palette from the ‘Polygon Colors’ drop-down list.

-OR-

Enter the polygon color number.

6. (Optional) Enter the numeric value for the zone priority of the delivery zone. By default, the 
system sets the value to ‘0.’ Zone priority determines which zone to use when an address falls 
across multiples zones, since different zones may have different delivery fees. For example, 
for an outer delivery zone you may charge a delivery fee of $5.00, and for an inner delivery 
zone you may charge a delivery fee of $4.00. When an address appears in all zones, zone pri-
ority indicates which zone to use when assessing a delivery fee. 

Figure 1 - 32  Delivery Zone Configuration
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7. Confirm the delivery zone is for delivery. By default, the system selects deliverable for the 
delivery zone. If you want to create an undeliverable delivery zone, clear Deliverable. You 
may want to create an undeliverable delivery zone for areas with high crime rates. Undeliver-
able delivery zones appear in black on the map. You may want to consider creating undeliver-
able delivery zones first.

8. Determine the boundary points of the delivery zone, and click those points on the map. The 

system places a red marker icon at the boundary point. To move a boundary point, press 
and hold the left mouse button on the boundary point, drag the boundary point to the 
desired location on the map, and release the left mouse button.

9. Click Save.

Figure 1 - 33  Delivery Zone Area
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Configuring a Delivery Fee
You can configure a delivery fee for use with Aloha Online Ordering. Prior to configuring delivery fees,
you must decide which software application will define the delivery fees for your restaurant. You can
choose to allow ATO or AOO to determine the delivery fee. With ATO, you can set the delivery fee to
be a flat amount or use minimum charge, maximum charge, or check percentage. You cannot use the
delivery fees associated with distance or location as configured in ATO. If you want to assess delivery
fees by location, you must configure AOO to assess those charges by creating delivery zones and
associating a delivery to those zones. 

Determining the Delivery Fee Through ATO
When you elect to have ATO determine the delivery fee for online orders, you can use the delivery fee
options in ATO except those related to location or distance. Assigning delivery fees for online orders
with Aloha Takeout requires ATO v12.1.5 or higher. If you plan to use AOO to determine delivery fees,
you may skip this section.

Determining the delivery fee through ATO requires the following:

• Create a POS order mode charge and set it to a fixed rate of ‘$0.00.’
• Configure the ATO delivery fees.
• For flat amount delivery fees, in Web Admin, set the UseSiteLevelFees company setting to 

True. It is not necessary to create a matching delivery fee in AOO unless you set the Use-
SiteLevelFees company setting to False. Then you must create a delivery fee in AOO to match 
those in ATO and assign it to the store location.

• For non-flat rate delivery fees, set the UseSiteLevelFees company setting to True and disable 
any delivery fees in AOO. 

To create a POS order mode charge: 

1. In CFC or new Aloha Manager, select Maintenance > System Settings > Order Mode.
2. Click New to add a new order mode.
3. Select Active.
4. Select All Items.
5. Select Include Ordered Items. (QS only)
6. Select Apply service charge.
7. Type Delivery Fee for the charge line text.
8. Select None for the tax to apply to the service charge.
9. Select Fixed.
10. Type 0.00 for the amount of the service charge. ATO calculates the delivery fee based on the 

ATO configuration and passes the amount to the POS, replacing the 0.00 amount.
11. Click Save and exit the Order Mode function. 

Refer to the NCR Aloha Table Service or Quick Service Reference Guide for additional infor-
mation. 
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In ATO, configure the delivery fees you want to use.

To change the UseSiteLevelFees company setting: 

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select the set to edit from the ‘Choose Settings Set’ drop-down list.
3. Select UseSiteLevelFees.
4. Click Edit Setting.
5. Type True to use the ATO delivery fee settings.
6. Click Update.

To create a flat rate delivery fee in AOO:

You only need to create a flat rate delivery fee in AOO if you set the UseSiteLevelFees company set-
ting to False. In that scenario, the flat rate delivery fee in AOO and the delivery fee in ATO must match.

1. In Web Admin, select Designs > Fees.
2. Click Add Fee. The Edit Fee screen appears.

3. On the Fee Details tab, type the name for the delivery fee.
4. Type a Description for the fee.
5. Select Delivery from the ‘Fee Type’ drop-down list. 
6. Select the Fee Tiers tab.
7. Click New.
8. Enter the amount for the delivery fee. This is the same amount you configured in ATO. 
9. Select the Assigned Sites tab. The system lists the available site locations in ‘Available Sites.’

Click Add All to associate the delivery fee with all site locations. The system moves all the site 
locations from ‘Available Sites’ to ‘Selected Sites.’

-OR-

Under ‘Available Sites,’ select the site locations to which to apply the delivery fee, and click 
Add Selected. The system moves only the locations you specified to ‘Selected Sites.’ To disas-
sociate a delivery fee from a site location, under ‘Selected Sites,’ select the site and click 
Remove Selected. 

10. Click Update.

For information on configuring delivery fees in ATO, refer to the NCR Aloha Takeout Imple-
mentation Guide.

Figure 1 - 34  Edit Fee Screen
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To delete a delivery fee:

You only need to use this procedure if you previously configured a delivery fee and now plan to use a
non-flat rate delivery fee from ATO.

1. In Web Admin, select Designs > Fees. 
2. Select the delivery fee to edit or delete.
3. Click Delete Fee to remove the delivery fee.

Determining the Delivery Fee Through AOO
When you elect to have AOO determine the delivery fee for online orders, you create a delivery zone,
a delivery fee, and assign the delivery fee to the delivery zone. 

Determining the delivery fee through AOO requires the following:

• Create a POS order mode charge and set it to a fixed rate of ‘$0.00.’ Refer to “To create a POS 
order mode charge:” on page 1-42. 

• Configure an ATO delivery fee.

• Configure a delivery zone in AOO. Refer to “To configure a delivery zone:” on page 1-40.
• Set the UseSiteLevelFees company setting to False.
• Configure a delivery fee in AOO. 
• Assign the AOO delivery fee you created to the delivery zone.

To change the UseSiteLevelFees company setting: 

1. In Web Admin, Select Configuration > Company Settings Setup.
2. Select the set to edit from the ‘Choose Settings Set’ drop-down list.
3. Select UseSiteLevelFees.
4. Click Edit Setting.
5. Type False to not use the ATO delivery fee settings.
6. Click Update.

Use caution when deleting a delivery fee as the system does not provide a warning 
message prior to deleting the delivery fee.

Refer to the NCR Aloha Takeout Implementation Guide.
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To create a delivery fee in AOO:

You create a delivery fee, but do not assign it to a site location on the Edit Fee screen.

1. In Web Admin, select Designs > Fees.
2. Click Add Fee. The Edit Fee screen appears.

3. At the Fee Details tab, type the name for the delivery fee.
4. Type a Description for the fee.
5. Select Delivery from the ‘Fee Type’ drop-down list. 
6. Select the Fee Tiers tab.
7. Click New.
8. Enter the amount for the delivery fee.
9. Click Update.

To assign a delivery fee to a delivery zone:

1. In Web Admin, select Configuration > Delivery Zones > Delivery Zone Maintenance. 

2. Select a site from the ‘Select Site’ drop-down list.
3. Select a delivery zone from the ‘Select Delivery Zone’ drop-down list.
4. Select a delivery fee from the ‘Select Delivery Fee’ drop-down list.
5. Click Save. 

Figure 1 - 35  Edit Fee Screen

Figure 1 - 36  Delivery Zone Maintenance
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Controlling the Number of Online Orders 
You Can Receive
Aloha Online Ordering enables you to control the number of online orders or the number of items
submitted by online orders for a specified time frame. Aloha Online Ordering refers to this feature as
capacity management. You can configure the feature by order mode, within specified intervals, and
assign the feature to individual stores. Additionally, for operations using capacity management in
Aloha Takeout, you can use the settings in ATO rather than those configured in Aloha Online Order-
ing. When choosing between the capacity management of Aloha Takeout and Aloha Online Ordering,
keep in mind that Aloha Takeout calculates capacity management according to both in-store and
online orders, whereas Aloha Online Ordering calculates capacity management according to online
orders only.

Configuring Capacity Management Using Aloha 
Takeout
When using the capacity management controls of Aloha Takeout, the system considers all orders,
both in-store and online, when determining if a consumer can submit an online order for a particular
time. If you do not plan to use Aloha Takeout as your capacity management tool, skip this section.  

After defining the capacity management settings in Aloha Takeout, you control the activation of Aloha
Takeout capacity management through company settings.

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select UseATOCapacity.
3. Click Edit Setting.
4. Type True.
5. Click Update.
6. Select DisableAdvancedCommands.
7. Click Edit Setting.
8. Type False.
9. Click Update.

Configuring Capacity Management Using Aloha Online 
Ordering
Instead of using Aloha Takeout for capacity management, you can define capacity management set-
tings in Aloha Online Ordering. You can set capacity restrictions for web orders based on the number
of items, the number of orders, or a combination of the two.

For more information on configuring capacity management within ATO, refer to the NCR 
Aloha Takeout Order Scheduling Feature Focus Guide.
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To configure capacity management using item count:

1. In Web Admin, select Designs > Capacity Management > Capacity Multipliers and Portion 
Counts.

2. Select the item for which you want to define a limit.
3. Click Edit on the right side of the screen.
4. Under ‘Count Multiplier,’ enter the value for the selected item. The system uses this value in 

calculating the allowed items in accordance with your capacity restrictions. For example, for 
most items, you enter a value of ‘1;’ however, some items, due to the preparation effort 
require a value of ‘2’ or higher. If you set the capacity restrict to ‘10’ items for every ‘30’ min-
utes, the system uses the value of the item in the calculation. You might receive orders for 
eight items with a value of ‘1,’ and then one order for an item with a value of ‘2.’ You are now 
at your capacity limit of ‘10’ for the thirty-minute time period.

5. Click Update.

To configure capacity management using item or order count:

Using this option, you place a count and a limit on the raw number of orders and items to go against
the count multiplier. Once your online ordering site reaches the maximum number of orders or items
for a store location, the site restricts the specific time frame from the promise time selection page.

1. In Web Admin, select Designs > Capacity Management > Capacity Configurations.
2. Select Add Capacity Configuration. The Add Capacity Configuration screen appears.

3. Type a name for the capacity configuration.
4. Type a description for the capacity configuration.

Figure 1 - 37  Capacity Multipliers and Portion Count

Figure 1 - 38  Capacity Configuration
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5. Enter the interval in minutes for the capacity configuration. For example, if you set the 
interval for 30 minutes and the order count to 4, the system only allows 4 online orders every 
30 minutes.

6. Specify an item count to define how many items for order the system allows within an inter-
val.

7. Specify an order count to define how many orders the system allows within an interval.
8. Select the days of the week for which the capacity configuration applies.
9. Select a start time and an end time for the capacity configuration.

-OR-

Select All Day to apply the capacity configuration to the entire day.

10. Select each order mode to which to apply capacity management. For example, you may want 
to exclude your catering order mode from the capacity management settings.

11. Select each menu type to which to apply capacity management. For example, you may want 
to exclude your catering menu from the capacity management settings.

12. Under ‘Available Sites,’ select each store to which capacity management applies, and click 
Add Selected. The system moves the selected store to ‘Selected Sites.’ To apply capacity man-
agement to multiple stores, click Add All, or left-click a store, press the Ctrl key, select the 
next store to add, and click Add Selected.

13. Click Save.

Enabling Credit Card Charge Upon Order 
Submission
Instant credit card charge enables you to charge credit cards and debit cards at the time of web order
submittal. If the merchant processor declines the card, the system displays a notification to the con-
sumer, and prompts them to provide another form of payment. 

Instant Credit Card Charge submission requires Aloha Takeout v14.1 or later, and you must configure
deposits in ATO and the Aloha POS. 

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select EnableATODeposits.
3. Click Edit Setting.
4. Type True to activate instant credit card charge, or type False to disable the feature.
5. Select DisableAdvanceCommands.
6. Click Edit Setting.
7. Type False.
8. Click Update.

Refer to the NCR Aloha Takeout Implementation Guide for more information. 
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About Menu Configurator
Menu Configurator, an application you download onto your desktop from Web Admin, enables you
to build out the menu structure of your items and to define how the system displays those items on
your web menu. The Aloha Online Ordering team provides the initial import of items from your POS
into Menu Configurator. Since consumers use the web menu to place orders, you may want to edit
your menu and modifier items for their ease of use in ordering. You will likely want to edit how items
appear and the manner in which consumers can select modifiers. You perform these functions in
Menu Configurator, where you can rename items, create descriptions, arrange modifier groups, and
much more. Once you create your online ordering menu, you assign it to site locations. 

As you work with Menu Configurator, keep the following concepts in mind:

• A Copy of the POS Data - The online menu is only a copy of your POS data. As part of the on-
boarding process, the Aloha Online Ordering Implementation team retrieves your POS menu 
data and imports it into Menu Configurator. This creates the initial menu data, which you can 
then alter to create a consumer-friendly interface. When you delete an item or a modifier 
from the online menu, the system does not delete the corresponding item or modifier from 
the POS. 

• Data Relationships - In your online menu, menu items, modifier groups, and modifier items 
may share ‘data relationships.’ When you edit a modifier name or group, the change occurs in 
all instances of your web menu where you use that item or group. For example, you may 
have a modifier group named, ‘Pizza sauces.’ If you change the modifier group name to 
‘Sauces’ on one item, the system applies that change to every item with that modifier group.

• Single User Editing - Only one user at a time can edit the menu data. If multiple users have 
access to Menu Configurator, always ‘check-out your design and verify you ‘check-in’ your 
design so the next person accesses the latest web menu design data; otherwise, another user 
may override your work, and all of the changes you made will be lost.

• Promoting POS Changes - The system imports POS menu changes nightly; however, it does 
not automatically implement these menu changes to your web menu. You must manually 
implement any POS menu changes to the web menu. Common changes include price 
updates, modifier group changes, and modifier group addition or removal. When you access 
Menu Configurator and POS menu updates appear, a Promotion wizard launches to guide 
you through the import process.

• Internet Access - Updating your Web menu requires Internet access. The menu update pro-
cess requires you to access the menu data stored on the Aloha Online Ordering file server 
through the Internet. You store the menu data on the file server until you open the menu and 
promote the changes.

• Automatic Updates - Menu Configurator automatically receives new versions and updates 
of the utility as they become available. You do not need to restart your computer to imple-
ment the updates.
Aloha Online Ordering User Guide Building Your Online Menu 2 - 3



Overview of the Aloha Online Ordering Menu 
Structure
The following provides a hierarchical overview of the menu structure for Aloha Online Ordering.

Figure 2 - 1  Aloha Online Ordering Menu Structure

Contains the below elements as configured in Menu 
Configurator. You can assign a menu according to 
the pickup or delivery order mode, and by individual 
and catering menu types. 

Organizational elements used to contain menu 
items, such as ‘Appetizers,’ ‘Entrees,’ and ‘Beverages.’

Indicates the name of the item, description, and 
associated sales items. Can contain multiple sales 
items, so as to distinguish the different sizes of the 
items.

An optional group used to group sales items. Using 
multiple web sales groups allows for multiple sales 
item selections from the modifier window. 

The menu item with an assigned price, modifier 
group, and a specific POS item number. Aloha 
Online Ordering imports sales items directly from 

The group containing modifiers associated with the 
menu item. The POS pre-determines these groups; 
however, you can customize them for each menu 

The modifier item with an assigned price and a spe-
cific POS item number. Modifiers are POS items 
linked with specific modifier groups.
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Installing Menu Configurator
Prior to using Menu Configurator to build out your online menu, you must download and install the
Menu Configurator utility. You must use Internet Explorer® to download the utility.

1. Log in to Aloha Online Ordering through Internet Explorer.
2. Select Menu Configurator > Download Menu Configurator. The system verifies your com-

puter meets the necessary prerequisites for downloading and running Menu Configurator.
3. Click Download Menu Configurator. The system installs Menu Configurator and opens the 

program upon the completion of installation.  

Working with Menu Configurator
Updating your online menu with Menu Configurator works as follows:

• Check out the menu data from the Aloha Online Ordering data server.
• Make the desired menu changes.
• Publish the new menu to the online ordering web site. The system checks your design back in 

upon publishing your changes.

To check out the menu:

To edit your web menu, you must first check out the menu. Only one user at a time can check out the
menu, preventing menu change conflicts.

1. Launch Menu Configurator.
2. Select File > Check Out Design. The login screen appears.
3. Type your Login. This is the same login you use to access Web Admin.
4. Type your password. This is the same password you use to access Web Admin.
5. Click OK. The Select Company Design screen appears.
6. Select the company name. Most users see only one company name.
7. Click OK. Menu Configurator downloads and opens your most recent menu data.

Microsoft® .NET Framework 4.5 must be in use to install and run Menu Configurator.

You may want to create a desktop shortcut for accessing Menu Configurator at a later date.
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To publish the menu:

Once you make a change to your menu, publish the changes to your online ordering web site. 

Recommendation: Publish often, such as after each menu change. Computer crashes and lost Inter-
net connections, along with other problems, can eradicate any work you have completed. Addition-
ally, if you make an error, such as adding an existing duplicate modifier to a modifier group, the
system prevents you from completing the publication process. If you make multiple changes prior to
publishing, locating the error can be a cumbersome process.

1. Select File > Publish.The Publish Design Wizard screen appears.  

2. Select Keep Checked Out After Publish if you plan to keep editing the menu.

-OR-

Select Force Check In if you are done editing the menu.

3. Click Next. The system reviews your menu changes for errors. If the system finds errors, you 
can still publish the menu; however, consumers may experience problems when attempting 
to place an online order. To print the list of errors for review, click Print. 

4. Click Next. The wizard publishes your menu changes.
5. Click Finish.

Figure 2 - 2  Publish Design Wizard
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Understanding the Menu Configurator 
Screen
The Menu Configurator screen contains four windows: menu tree, menu preview, item properties,
and known relationships. 

The menu tree on the left side of the screen, contains the items and modifiers in a collapsible menu
tree. In addition to identifying the specific menu, the menu tree includes:

• Submenu - The headings you use to organize the web menu. Common submenus include 
‘Appetizers,’ ‘Entrees,’ and ‘Drinks.’

• Menu Item - The name of the item, such as ‘Pepperoni Pizza.’ Menu Configurator identifies 
menu items with a folder to the left of menu item name.

• Sales Item - The name of the individual menu item, such as ‘Large Pepperoni Pizza.’ Menu 
Configurator identifies sales items with a green dollar sign to the left of the item name.

• Modifier Groups - The name of the collection of item modifiers, such as ‘Crust.’ Menu Config-
urator places a double check mark icon to the left of a modifier group. The Aloha POS prede-
termines the modifier groups, but you can customize them for the web menu. You must 
relate a modifier group to a sales item in the Aloha POS prior to web menu implementation.

• Modifiers - The name of the individual item modifier, such as “Regular Crust,’ or ‘Wheat 
Crust.’ Menu Configurator places a single green check mark icon to the left of the modifier 
name. It is necessary to create the relationship between a modifier item and a modifier group 
in the Aloha POS prior to web menu implementation.

The menu preview in the center of the screen, enables you to view selected item or submenu attri-
butes. Use this screen to preview the organization of menu items, modifier groups, and modifier
items prior to publishing.

The item properties appear on the top right side of the screen, and enable you to make changes to
the selected item, such as the name, description, minimum and maximum selections, and much
more.

Figure 2 - 3  Menu Configurator Screen
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Aloha Online Ordering User Guide Building Your Online Menu 2 - 7



The known relationships appear on the bottom right side of the screen and indicate the additional
locations in the online menu where the item exists. Review this section prior to making changes to
shared modifier names and modifier groups. A change may make sense in one location, but not in
another.

Managing Submenus
Submenus control the menu headings that appear to your consumers on your web menu. You may
want to rename an existing menu to make it more consumer-friendly, and you can add additional
submenus with fewer items to better organize your web menu. You can also restrict the time of day,
and days of the week, for when a submenu is available.

To add a submenu:

1. Right-click the menu name, usually named Default Menu and select Create New Submenu 
from the menu that appears. The new submenu appears at the bottom of the list.

2. Select SubMenu (New).
3. In Item Properties, type the submenu name to appear on the web site.  

4. Publish the change. 

To rename a submenu:

1. Select the submenu for which you want to change the name.
2. In Item Properties, type the submenu name to appear on the web site.
3. Publish the change.

Figure 2 - 4  New SubMenu
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To create a time of day restriction: 

When you create a time of day restriction, you are selecting the days and times during which the sub-
menu is available.  

1. In the menu tree, right-click the submenu and select Time of Day Restrictions from the 
menu that appears. The Submenu Time of Day Restrictions window appears.

2. Click Add. The Submenu Restriction Window appears.

3. Select the day of the week for which you want to make the submenu available from the ‘Day 
of the Week’ drop-down list.

4. Select the start time at which the submenu is to become available.

Figure 2 - 5  Submenu Time of Day Restrictions

Figure 2 - 6  Submenu Restriction

It is not necessary for the available times to match the store hours. For example, to create a 
Monday special, select Monday as the day, and set the time from 12:00 a.m. to 12:00 a.m., 
even though the store opens at 5:00 a.m. The system prevents consumers from ordering the 
item until the store opens.
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5. Select the end time at which the submenu is no longer available. 

6. Click OK to exit the submenu restriction window.
7. Click OK to return to Menu Configurator.
8. Publish the change.

Managing Menu Items
Menu Configurator enables you to add, edit, rename, hide, and delete menu items from the web
menu. You can also move existing menu items from one submenu to another, combine like items,
and even offer menu items by the day of the week. 

To add a menu item: 

You can add a menu item, not yet displayed, to your online menu, as long as the item exists in a sales
category and on a panel or subpanel in the POS. 

Currently, the restricting of submenus by day part is for API users only. 

Figure 2 - 7  Create New Web Menu Items
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1. In the menu tree, right-click the submenu on which you want to list the item and select Cre-
ate New Web Menu Items from the menu that appears. The Create New Web Menu Items 
screen appears.

2. Type the item name or the POS code in ‘Find Items’ to search for the menu item. As you 
enter the name or POS code, the matching search results appear.

3. Select the item to add to your submenu.
4. Select the method by which to build out the information for the menu item:

• POS Item - Builds the item directly from the POS data, or as the servers see it in-store. 
You may need to edit the menu item, sales item, and modifier groups.

• Existing Web Item - Constructs the item using an existing item modifier group. It is nec-
essary to manually edit the sales and menu items.

• Existing Web Modifier - 
• Selected Web Modifier Groups - Builds the item using already edited modifier groups. 

This can be useful for items that share the same groups, like steak temperature and 
entree sides.

5. Click OK.
6. Publish the change.

To hide a menu item:

In some cases, it may be necessary to temporarily remove an item from the online menu. Using the
Visible flag, you can remove an item from the web menu, but not from the menu tree. This allows you
to retain all customization of the item. You can also hide modifiers, modifier groups, and submenus.

1. In the menu tree, right-click the item to hide and select Visible from the menu that appears. 
Visible items contain a blue check mark next to Visible, and hidden items do not. When you 
clear Visible, the item appears in gray italic text on the menu tree, indicating it is invisible.

2. Publish the change.

To delete a menu item:

You can also delete an item to prevent it from appearing on the web menu. Deleting an item does not
permanently remove the item from the database; however, deleting an item removes any customiza-
tion you have made to the item. If you add the item back to the web menu, you must build out and
customize the item again. 

1. In the menu tree, right-click the item to delete and select Delete from the menu that 
appears. Use caution in deleting items as the system does not provide a prompt after you 
click Delete.

2. Publish the change.
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To rename a menu item:

You can change the menu item name to match your paper menu, rather than displaying the POS text
your employees see. For example, you can rename the menu item ‘BACON CHZBURG’ to ‘Bacon
Cheeseburger.’ 

1. In the menu tree, select the item to edit.
2. In Item Properties, type the name to appear for the item on the web menu.
3. (Optional), Type the description for the item to match the paper menu. For example, the 

description for a bacon cheeseburger could be, ‘Two thick bacon strips, cheddar cheese, and 
ketchup on an all-beef patty cooked to your liking. Served with your choice of side.’ 

4. Publish the change.

To move an existing menu item to a different submenu: 

You can move existing menu items to a different submenu that may make it easier for consumers to
navigate your web menu. For example, you may move salads out of an existing appetizer submenu
and into a separate salads submenu. When you move a menu item to a different submenu, all config-
uration, such as descriptions and modifier groups, moves with the menu item.

1. In the menu tree, right-click the item to move, and select Change Submenu. The Move Menu 
Item screen appears. 

Review all naming changes before publishing as Menu Configurator does not contain a spell 
check utility.

For the description to be visible on the web menu, you should add the description at the 
folder level.

Figure 2 - 8  Move Menu Item Screen
2 - 12 Building Your Online Menu Aloha Online Ordering User Guide



 

2. Type the submenu name in Find Web Submenu to locate the target submenu for the item. 
The matching search results appear on the screen.

-OR-

Use the scroll bar to locate the target submenu.
New submenus appear at the bottom of the list.

3. Select the target submenu.
4. Click OK.
5. Publish the change.

To offer a menu item by day of the week:

You can restrict the offering of items on your web menu to certain days of the week. For example,
you may have particular menu items available only on certain days of the week. You can only restrict
menu items, not modifier items.

1. In the menu tree, right-click the menu item you want to restrict by days of the week, and 
select Day of Week Restrictions from the drop-down list. The Menu Item Restrictions screen 
appears.

2. Select the days of the week the menu is available. For example, if a menu item is available 
on Sunday, select Sunday. To select multiple days, click the first day the item is available, hold 
down the Ctrl key and click the next the day the item is available.

3. Click OK.
4. Publish the changes.

Figure 2 - 9  Menu Item Restrictions
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To combine like items:

You can combine like menu items to simplify the ordering process for your consumers. For example,
for items such as Chicken Wings, which can come in different sizes and quantities, you can combine
them into a single menu item. You can then add a size or quantity for the item.

1. In the menu tree, select one of the menu items you want to combine. The menu item you 
select will be the default size for the web menu item. You can later change the default item by 
changing the default item ID.

2. In Item Properties, type the new item name for the menu item. Choose a generic name that 
encompasses all the items included.

3. Type the description for the new item. Include information about the sizes and options avail-
able.

4. Right-click the item and select Create New Web Items from the menu that appears. The Cre-
ate New Web items screen appears.

5. Select the items to add, and click OK.
6. Rename each sales item to accurately reflect the size.
7. For each item you rename, if it appears elsewhere on the web menu, delete those instances.
8. In Item Properties, type an item selection label to appear on the web menu.
9. Publish the changes.

Managing Modifier Groups
Menu Configurator enables you to manage the modifier groups for your web menu. You can create
new modifier groups, share groups, split groups, rename groups, and change the required selections
for a modifier group. 

To create a new modifier group:

You can create a new modifier group to allow for the customization of a menu item. When you create
a new modifier group, it is exclusive to the item for which you create it. This is commonly used when
building a specific recipe group for a menu item. You can create several new groups simultaneously.
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1. In the menu tree, right-click a sales item, and select Create New Web Modifier Groups from 
the menu that appears. The Create New Web Modifier Groups screen appears. 

2. Under ‘Create,’ select the POS modifier group to include in the new modifier group. The 
available modifier items appear under ‘Modifiers.’

3. Select the modifier items for the new modifier group. Use Shift + left mouse click to select 
multiple items in a row or Ctrl + left mouse click to select several scattered items.

4. Click OK. The system adds the new modifier group at the bottom of the list of modifier 
groups for the sales item.

5. (Optional) Select the new modifier group and change the Web Modifier Group Name, 
description, and other items, as necessary.

6. Publish the changes.

Figure 2 - 10  Create New Web Modifier Group
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To share a modifier group:

For sales items requiring the same modifier group, you can share a modifier group rather than creat-
ing a modifier group for each sales item. For example, you can share an entree sides modifier group
with all entree items.  

1. In the menu tree, right-click the sales item for which you want to add the modifier group of 
another item and select Share Existing Web Modifier Groups from the menu that appears. 
The Share Existing Web Modifier Groups screen appears.  

2. Under ‘Share,’ select the modifier group to share. The system displays the web modifiers 
that belong to the group.

3. Click OK. The system adds the modifier group to the sales item, and places it at the bottom of 
the modifier groups for the item.

4. Publish the changes.

To split a modifier group:

When you have modifier group with numerous modifier items, you can split the modifier group into
smaller groups to make it easier for the consumer to navigate the web menu and make their selec-
tions. For example, with a pizza menu, in your POS you may list all the available toppings in one mod-
ifier group. For your web menu, you can split the toppings into multiple modifier groups, such as one
for meats and one for vegetables.

1. In the menu tree, right-click the modifier group to split and select Split Web Modifier Group 
from the menu that appears.

2. Under ‘Web Modifier,’ select the modifiers for the new group. Use Shift + left mouse click to 
select multiple items in a row or Ctrl + left mouse click to select several scattered items.

When you make any modifications to a shared modifier group, those changes appear 
across each instance where you use the modifier group. To make a modification on 
one menu item, build a unique group for the item.

Figure 2 - 11  Share Existing Web Modifier Group
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3. Click OK. The system moves the selected modifier items to the new group and adds the mod-
ifier group to the bottom of the list of modifier groups for the sales item

4. Select the new modifier group and change the Web Modifier Group Name, description, 
and other items, as necessary.

5. Publish the changes.

To change the min/max selections:

In some cases, your POS may not require a modifier group for in-store operations, but it is necessary
for online ordering. For example, for a restaurant that sells build your own burritos or tacos, the con-
sumer tells the employee what type of tortilla, flour or wheat, they want. The POS system may not
require the tortilla type for check-out; however, for a consumer placing an online order, it is neces-
sary to require this as a modifier group so you can prepare the item to their specifications.

Prior to configuring the item in Menu Configurator, access your POS, add the modifier group to the
menu item and set the minimum and maximum selection requirement to ‘0.’ In Menu Configurator,
you can change the minimum and maximum selection requirement, which only affects online orders.

1. In the menu tree, select the modifier group for which you want to change the min/max selec-
tions. 

2. In ‘Item Properties,’ enter the minimum number of modifiers for the item.

3. Enter the maximum number of modifiers for the item. The maximum number of modifiers 
cannot be less than the minimum number of modifiers. 

4. Publish the changes.

Figure 2 - 12  Web Modifier Group Properties Window

For an item with a minimum number greater than ‘0’ in the POS, you cannot change the 
minimum number to a lesser number in Menu Configurator. For example, if a menu item 
contains three minimum modifiers in the POS, you cannot change the minimum number of 
modifiers to ‘two in Menu Configurator. When a consumer attempts to place an order for 
the item using the online ordering site, they receive an error message informing them they 
have not chosen the required number of modifiers. You must change the POS first, before 
changing Menu Configurator. 
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To rename a modifier group:

You may want to change the name and description of a modifier group to match your paper menu,
and make it easier for your consumers to identify the items for an order.

1. In the menu tree, select the modifier group for which you want to change the name and 
description.

2. In ‘Item Properties,’ type the modifier name you want to appear on your web menu for the 
group. The new name for the modifier group occurs in every instance where the modifier 
group appears.

3. Type the description you want to appear on your web menu for the group. Use this to 
describe the modifier group, and include instructions for the consumer to choose an item. By 
default, the system leaves the description blank. If you do not enter text for the description, 
‘Optional’ appears for modifier groups without min/max selections, and ‘Required’ appears 
for modifier groups with min/max selections.

4. Publish the changes.

To alphabetize modifier items within a group:

For modifier groups with multiple items, you can alphabetize the modifier items to provide a more
user-friendly interface. 

1. In the menu tree, right-click the modifier group for which you want to alphabetize the items 
and select Sort Modifier Groups A-Z from the menu that appears. 

2. Publish the changes. 

To move a common or popular modifier item to the top of the modifier item list, right-click 
the modifier item, and select Move Up from the drop-down list.
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Managing Modifier Items
Menu Configurator allows you to manage modifier items for your Web menu. You can rename and
hide modifier items, as well as configure recipes to communicate to your consumers what modifier
items come with a menu item. You can also set the default modifier items for a menu item, and allow
consumers to order additional quantities of a modifier item.

To rename a modifier item:

You can rename a modifier item so that it appears the same as it does on your paper menu, making it
easier for a consumer to identify the modifiers for their order.

1. In the menu tree, select the modifier item to edit.

2. In Item Properties, change the ‘Display Name’ to reflect what you want to appear on the web 
menu.

3. Publish the changes.

To hide a modifier item:

In some scenarios, such as a seasonal modifier item, you may want to prevent the modifier item from
appearing on your web menu, rather than delete the modifier item. Hiding a modifier item makes it
invisible everywhere it appears on the web menu.

1. In the menu tree, right-click the modifier item and select Visible from the menu that 
appears. Visible items contain a blue check mark next to Visible, and hidden items do not. 
When you clear Visible, the item appears in gray italic text on the menu tree, indicating it is 
invisible.

2. Publish the changes.

Figure 2 - 13  Modifier Group Properties Window
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To configure a recipe:

A recipe communicates to your consumers what comes with a menu item. A recipe also allows for the
easy removal of a topping or ingredient when placing an order. A recipe assumes your kitchen staff
prepares a menu item with the same modifier items every time and only need to be made aware of
when to remove an item. The kitchen chit displays the menu item and the removed modifier item. 

For example, your restaurant may prepare a turkey sandwich with lettuce, tomato, onion, and may-
onnaise. Your web menu lists these items in the description, and in a separate modifier group. A con-
sumer who does not want tomatoes clears the check mark next to the tomatoes modifier item. The
online receipt and the kitchen chit display, ‘Turkey Sandwich, No Tomatoes.’

1. In the menu tree, right-click the sales item for which you want to configure a recipe and 
select Configure Default Web Modifiers from the menu that appears.The Configure Default 
Web Modifiers screen appears.  

2. Under ‘Configure Recipe for Selected Web Items,’ select Recipe Option for each modifier item 
that is part of the default recipe.

3. (Optional) Click Move Recipe Options into Separate Group to create a separate group with 
the recipe modifier items. If you share this group between sales items, it is necessary to con-
figure the recipes for each individual sales item. Recipe configuration does not transfer 
between menu items.

4. Click OK. An Operation Complete prompt appears.
5. Click Close. The system adds a Recipe group to the sales item.
6. (Optional) Change the Web Modifier Group Name, description, and other items, as neces-

sary.
7. Publish the changes.

Figure 2 - 14  Configure Default Web Modifiers
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To configure a default modifier item:

You can set a default web modifier item for a menu item. Use this feature to help reduce errors when
a consumer forgets to select a modifier. In most cases, an item with a default modifier contains a
minimum selection of ‘1.’ For example, for a hamburger, you can set a default meat temperature to
medium, or a default side to french fries.

1. In the menu tree, right-click the sales item for which you want to select a default modifier, 
and select Configure Default Web Modifiers from the menu that appears. The Configure 
Default Web Modifiers screen appears.

2. Under ‘Item Default,’ select the modifier item to set as the default.
3. Click OK. An Operation Complete prompt appears.
4. Click Close.
5. Publish the changes.

To allow a consumer to order extra of a modifier:

In some scenarios, it may be desirable to allow a consumer to order ‘extra’ or ‘double’ of a modifier
item. You can configure a modifier item to allow consumers to change the quantity of a modifier
item.

1. In the menu tree, select the menu item.
2. Under ‘Item Properties,’ select QtyModifierItem from the ‘Item Ordering Behavior’ drop-

down list.
3. Select the modifier group for the modifier item.
4. In ‘Item Properties,’ change the maximum quantity per item to a number greater than zero.
5. Publish the changes. 
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Working with Menus
Menu Configurator allows you to create and manage multiple menus, and you can control the attri-
butes for each menu. You may want to configure some menus for particular order modes. 

To add an additional menu:

Aloha Online Ordering can provide a separate menu for each of the order mode services you offer,
such as Pickup and Delivery. You may find this helpful in situations where the delivery menu does not
offer as many items for order as the pickup menu, or when the catering menu offers menu items in
larger sizes than the delivery or pickup menu. When placing an order, the consumer selects the order
mode, such as pickup or delivery, and Aloha Online Ordering displays the corresponding menu.

You can create a duplicate menu of a previously created menu, but before doing so, ensure you com-
plete all the necessary design changes, such as item naming, spelling, descriptions, modifier group
splitting, etc. Copying a design menu prior to completing the design results in dual maintenance. 

On the ordering screen for the mobile web platform, the ‘Is this a catering order?” button appears
regardless if you configure a catering menu in Menu Configurator or not. If your only menu is defined
for catering, the system automatically selects the button for you. If you do not define any menu for
catering, the button is disabled. 

1. Select Web Menu > Menu Management. The Menu Management screen appears.

2. Click New Menu.
3. Type the name for the new menu.
4. (Optional) Type an id number for the menu. Aloha Online Ordering uses the External ID as 

the Menu ID.
5. Select the menu type for the new menu, Retail or Catering.
6. Select the supported order modes for the new menu, Pickup, Delivery, or Pickup and Deliv-

ery.

Figure 2 - 15  Menu Management
2 - 22 Building Your Online Menu Aloha Online Ordering User Guide



 

7. (Optional), select any menu attribute overrides, such as Web, Call Center, or Mobile. The 
menu applies to each menu attribute override you select, however; if you clear all menu attri-
bute overrides, the menu applies to all three attribute overrides. For example, if you select 
Web, the menu only applies to Web and not to the other two options. 

8. Click OK. The system adds the new menu.

To control the menus a consumer sees by access method:

A menu attribute override controls the availability of a menu based on the method by which a con-
sumer accesses the web menu to place an order. Aloha Online Ordering allows you to place an order
from a mobile device, call center, or desktop web. A web menu to display for call center ordering is
not available to mobile devices or a desktop web.

By default, the system does not assign a menu attribute override to a menu. Without an override, the
menu is available for all methods of ordering. You only select a menu attribute override to restrict
the selected menu to a specific method of ordering. If you restrict a menu, it is necessary to configure
the store location in Web Admin to accept orders by this method.

1. Select Web Menu > Menu Management.
2. Select the menu for which you want to configure a menu attribute override.
3. Select the attribute override to apply to the menu.
4. Click OK.

To share an existing submenu:

When you plan to use a submenu from one menu with another menu, you can share an existing sub-
menu. The system reflects changes made to one submenu in both submenus automatically, includ-
ing manual updates and the promotion of POS changes. 

1. In the menu tree, right-click the menu to which to add a submenu from another menu and 
select Share Existing Submenu from the menu that appears. The Share Existing Submenu 
screen appears.

2. Select the submenu to share.
3. Click OK.
4. Publish the changes.

To view the new menu and add items to it, select Web Menu > Active Menu, and select the 
name of the new menu.
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Assigning a Menu to a Site Location
Once you create your online ordering menus, you assign them to each store. You can apply a menu
setting so it takes effect for a particular menu. Settings in Aloha Online Ordering adheres to the fol-
lowing hierarchy, from highest to lowest priority: 

1. Site
2. Menu
3. Company

To assign a menu to a site location:

When you create a menu, you must assign the menu to a site location, even if you only created one
menu. If you do not assign a menu to a site location, the site location does not appear on the loca-
tions page of the online ordering site and a consumer cannot place an order for the site location.

Companies with two menus, such as individual and catering, most often use this feature, particularly
if catering is not available at all sites. 

You assign a menu to a site location in Web Admin. 

1. In Web Admin, select Designs > Site Menu Assignment.
2. Select the menu to assign from the drop-down list.
3. Under ‘Selected Sites,’ select the store location for which to assign a menu, and click 

Remove Selected. The system moves the store location to ‘Available Sites.’ To remove the 
menu, under ‘Available Sites,’ select the store location, and click Add Selected. The system 
moves the store location to ‘Selected Sites.’

4. Click Update.

It is best practice to use menu or site settings to override your company settings, but not 
practice both.
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To override company and site settings for a menu:

Menu settings allows you to select and manage submenus of a menu. You can override a select num-
ber of company and site settings for a menu. You override these settings in Web Admin. The settings
you can override are:  

1. In Web Admin, select Designs > Menu Settings.
2. Select the menu from the drop-down list.
3. Click Add Menu Setting. 

4. Type the setting you want to override.
5. Type the value for the setting.
6. Click Update. Once you add the setting you can then edit it. 

Settings Default Value

BufferAM 30
BufferPM 60
DefaultSubMenuID <blank>
DeliveryTimeGranuality <blank>
DeliveryTimesAsRange False
MaxOrderLineCount 40
MaxOrderTotalAmount 50
MenuLeadTimeDays <blank>
MinOrderTotalAmount 0
PickupTimeGranularity <blank>

Menu Configurator assigns the submenu ID. You can determine the submenu ID in Web 
Admin at Designs > Exclusions > Submenu Site Exclusions. 

Figure 2 - 16  Menu Settings Screen
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Working with Quick Combos
You can configure Aloha Quick Combo items for Aloha Online Ordering, allowing consumers to order
multiple groups of sales items from a single menu item. Prior to building a quick combo menu item, it
is necessary to activate a web sales group in Company Settings Setup. You use a web sales group to
configure quick combo menu items.

Prior to building a quick combo menu item in Aloha Online Ordering, it is important to understand:

• All quick combos for the web menu require a corresponding quick combo promo in the POS.
• Each web sales group has a hard-coded minimum and maximum sales item selection of ‘1,’ 

thereby, requiring each component of a quick combo have its own web sales group.
• You can only add items to the quick combo in Menu Configurator, when it is associated with a 

quick combo in the POS.

To activate a web sales group in Web Admin:

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select the set from the ‘Choose Settings Set’ drop-down list.
3. Select UseWebSalesGroup.
4. Click Edit Setting.
5. Type true for the value.
6. Click Update.

To build a quick combo menu item:

1. In Menu Configurator, right-click a submenu and select Create New Web Menu Items from 
the menu that appears. The Create New Web Menu Items screen appears.

2. Select an item that is part of a quick combo, and click OK.
3. In the menu tree, select the new web menu item.

4. In ‘Item Properties,’ type the name to appear on the web menu for the quick combo menu 
item. Use a name that reflects the quick combo name, such as ‘Chicken Wing Combo.’

5. Enter the quick combo POS ID as the ‘Promo ID.’

Figure 2 - 17  Web Menu Item Properties Windows
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6. In the menu tree, right-click the new web menu item again and select Create New Web 
Items from the menu that appears. 

7. Select the remaining items belonging to the quick combo, and click OK.
8. In the menu tree, right-click the new web menu item again, and select Create New Web 

Sales Group from the menu that appears.

9. Select each item for the first component, type the name for the component, and click Cre-
ate. For example, for the first component of a Chicken Wing Combo, select each Wings item, 
such as Regular Wings and Boneless Wings, type Wings as the component name, and click 
Create.

10. Repeat for each additional component for the quick combo.

11. Publish the changes.

Figure 2 - 18  Create Web Sales Group

Figure 2 - 19  Quick Combo Menu Example

Select the items.

Type the 
component 
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To rank the order for shared web sales groups:

When you share a web sales group in Menu Configurator, the system assigns a ranking order which
you can change using the up and down arrows, as well as the items inside of web sales groups. This
allows you to customize the order in which the web sales groups and the items appear on your
menus. 

1. In the menu tree, select either a web sales group or web sales item. 
2. Click the up arrow to move the web sales group or item up in the list or click the down 

arrow to move the web sales group or item down in the list. 

Figure 2 - 20  Up and Down Arrows in the Menu Tree
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Excluding a Menu Element from a Site
You may need to hide certain elements of your menu from specific sites, using exclusions, so they
cannot be sold at that location. You would do this for any number of reasons, such as a specific store
location may not have the inventory necessary to prepare the menu element the store does not offer
the menu element. You can exclude a submenu, menu item, modifier item, sales item, or sales item
option from a certain location. For each of these, you can exclude these elements singularly, or by site
or site groups, 

To exclude a menu element from a site:

You can specify a submenu to exclude for the online ordering site of a specific location. If you have
site groups configured, you can also use site groups to quickly assign the exclusion of a submenu to
multiple sites. 

1. In Web Admin, select Designs > Exclusions > Menu Item Site Exclusions (shown), Submenu 
Site Exclusions, Sales Item Site Exclusions, or Sales Item Option Site Exclusions. The 
appropriate screen appears.  

2. If needed, filter the list by name or one of the following criteria: 

3. Use the ‘Select’ column on the left side of the screen to make your selections. The number 
you select tally at the bottom of the screen. 

Figure 2 - 21  Menu Item Site Exclusion Screen

Function Available Sorting Criteria
Submenu Sub Menu Id Referencing 

Menus
Visible Excluded Site Count

Menu Item Menu Item Id Referencing 
Menus

Visible Excluded Site Count

Sales Item Sales Item Id Referencing 
Menu\Menu 
Item

Visible Excluded Site Count

Sales Item Option Sales Item 
Option Id

Referencing 
Option Groups

Visible Excluded Site Count
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4. Click Edit x items at the bottom of the screen. The Edit Assigned Sites screen appears. 

5. To exclude items from your online menu, perform the following: 
a. Select the sites from the ‘Available Sites’ list and click > to move the sites to the ‘Selected 

Sites’ list. 
b. Select Exclude on the bottom of the screen. 

6. To include excluded items from your online menu, perform the following: 
a. Select the sites from the ‘Available Sites’ list and click > to move the sites to the ‘Selected 

Sites’ list. 
b. Select Include on the bottom of the screen. 

7. Click Update. You can click Info for each element to quickly view the included and excluded 
sites for the element and click the X in the top right corner to exit the screen. 

Figure 2 - 22  Edit Assigned Sites Screen
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8. Click Edit on the right side of the screen to display the Edit Assigned Sites screen.  

9. Exit the appropriate screen. 

To exclude a menu item:

You can hide a menu item for a specific store location. For example, a specific store location may not
have the inventory necessary to prepare a menu item. If you have site groups configured, you can
also use site groups to quickly assign the exclusion of a menu item to multiple sites.  

1. In Web Admin, select Designs > Exclusions > Menu Item Site Exclusions. The menu item 
site exclusion screen appears.

2. Select the menu item to exclude.
3. Click Edit. The Edit Assigned Sites screen appears. 
4. If you have site groups configured, select a site group from the ‘Add/Remove by Site Group’ 

list. 
5. To assign the exclusion by adding the sites found in the site group, click Add Selected Group. 

The sites included in the site group appear in the ‘Selected Sites’ list. 

To unassign the exclusion by removing the sites found in the site group, click Remove 
Selected Group. The system removes sites included in the site group from the ‘Selected Sites’ 
list. 

Figure 2 - 23  Item Site Info Screen

Figure 2 - 24  Menu Site Exclusion
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6. Under ‘Selected Sites,’ select the store location for which to exclude a menu item, and click 
Remove Selected. The system moves the store location to ‘Available Sites.’ To remove the 
exclusion, under ‘Available Sites,’ select the store location, and click Add Selected. The sys-
tem moves the store location to ‘Selected Sites.’

7. Click Update.

To exclude a modifier:

You can hide a modifier item for a specific store location. For example, a store location may not have
the inventory necessary to provide a specific modifier item. If you have site groups configured, you
can also use site groups to quickly assign the exclusion of a menu item to multiple sites.  

1. In Web Admin, select Designs > Exclusions > Sales Item Option Site Exclusions. The menu 
site exclusions screen appears. The system considers all items with an associate price to be a 
sales item.

2. Select the modifier item to exclude.
3. Click Edit. The Edit Assigned Sites screen appears. 
4. If you have site groups configured, select a site group from the ‘Add/Remove by Site Group’ 

list. 
5. To assign the exclusion by adding the sites found in the site group, click Add Selected Group. 

The sites included in the site group appear in the ‘Selected Sites’ list. 

To unassign the exclusion by removing the sites found in the site group, click Remove 
Selected Group. The system removes sites included in the site group from the ‘Selected Sites’ 
list. 

6. Under ‘Selected Sites,’ select the store location for which to exclude a modifier item, and click 
Remove Selected. The system moves the store location to ‘Available Sites.’ To remove the 
exclusion, under ‘Available Sites,’ select the store location, and click Add Selected. The sys-
tem moves the store location to ‘Selected Sites.’ 

7. Click Update.

Figure 2 - 25  Sales Item Option
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To exclude a sales item:

You can hide a sales item for a specific store location. For example, a specific store location may not
have the inventory necessary to prepare a sales item. If you have site groups configured, you can also
use site groups to quickly assign the exclusion of a menu item to multiple sites.  

1. In Web Admin, select Designs > Exclusions > Sales Item Site Exclusions. The sales item site 
exclusion screen appears.

2. Select the sales item to exclude.
3. Click Edit. The Edit Assigned Sites screen appears. 
4. If you have site groups configured, select a site group from the ‘Add/Remove by Site Group’ 

list. 
5. To assign the exclusion by adding the sites found in the site group, click Add Selected Group. 

The sites included in the site group appear in the ‘Selected Sites’ list. 

To unassign the exclusion by removing the sites found in the site group, click Remove 
Selected Group. The system removes sites included in the site group from the ‘Selected Sites’ 
list. 

6. Under ‘Selected Sites,’ select the store location for which to exclude a menu item, and click 
Remove Selected. The system moves the store location to ‘Available Sites.’ To remove the 
exclusion, under ‘Available Sites,’ select the store location, and click Add Selected. The sys-
tem moves the store location to ‘Selected Sites.’

7. Click Update.

To exclude a sales item option:

You can hide a sales item option for a specific store location. For example, a specific store location
may not have the inventory necessary to prepare a sales item option. If you have site groups config-
ured, you can also use site groups to quickly assign the exclusion of a menu item to multiple sites.  

1. In Web Admin, select Designs > Exclusions > Sales Item Option Site Exclusions. The sales 
item option site exclusion screen appears.

2. Select the sales item option to exclude.
3. Click Edit. The Edit Assigned Sites screen appears. 

Figure 2 - 26  Sales Item Site Exclusion

Figure 2 - 27  Sales Item Option Site Exclusion
Aloha Online Ordering User Guide Building Your Online Menu 2 - 33



4. If you have site groups configured, select a site group from the ‘Add/Remove by Site Group’ 
list. 

5. To assign the exclusion by adding the sites found in the site group, click Add Selected Group. 
The sites included in the site group appear in the ‘Selected Sites’ list. 

To unassign the exclusion by removing the sites found in the site group, click Remove 
Selected Group. The system removes sites included in the site group from the ‘Selected Sites’ 
list. 

6. Under ‘Selected Sites,’ select the store location for which to exclude a menu item, and click 
Remove Selected. The system moves the store location to ‘Available Sites.’ To remove the 
exclusion, under ‘Available Sites,’ select the store location, and click Add Selected. The sys-
tem moves the store location to ‘Selected Sites.’

7. Click Update.

Promoting POS Changes
Menu Configurator imports POS changes nightly, but does not automatically import them into your
web menu. You must manually implement any POS changes to the web menu. When you log in to
Menu Configurator, a prompt appears, notifying you of potential changes, which then allows you to
activate a Promotion Wizard for the configuration of the imports before you publish them to your
web menu.

1. Select File > Check Out Design. If POS changes exist for import, a prompt appears.
2. Click Yes. The Promotion Wizard appears.
3. Review the available changes. Click the printer icon on the bottom right side of the screen to 

print a list of the available changes. Common import changes that appear in the Promotion 
Wizard.

• Price Updates - Allows for increases and decreases in price for sales and modifier items.
• Modifier Group Changes - Displays the possible addition or removal of modifier items 

from modifier groups. When you approve deleted items, the system deletes them from 
the web menu. You can approve the addition of modifier items, or wait until after the pro-
motion process. Until the publish process is complete, deleted items appear with a red 
strike through them, and the menu path also appears in red.

4. Build menu items or modifiers through the Promotion Wizard. If you prefer, you can build 
menu items after the Promotion Wizard. The wizard lists all changes not being implemented.

5. Click OK.
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Reviewing Price Overrides
Using Web Admin, you can review price overrides for your menu items and modifiers. For example, if
you have multiple locations, you may sell an item for different prices at each location, or at a specific
location. 

While Aloha Online Ordering pulls database information from the master store, which is the pre-
ferred database used to build the web menu, the system pulls pricing information from all stores.
The system defines the price of an item at the master store as the default price. If a site location
prices an item at a different price, the system creates an override price for that item for that location.
When a consumer views the item on the web menu for this location, they see the override price. 

For example, your restaurant contains three locations in different cities. Stores one and two sell a
Caesar Salad for $5.00, whereas store three sells a Caesar Salad for $7.00. Store one is the master
store, and thus the default price is $5.00. Since store three sells the item at a different price, the sys-
tem creates an override price for the item. When a consumer selects store three for an online order,
and views a Caesar Salad, they see a price of $7.00 accompanying the item.

You can review the price overrides.

1. In Web Admin, select Designs > Price Overrides > Item Price Overrides.

2. Select a location from the ‘Choose Site’ drop-down list. The system displays the items con-
taining a price override.

Figure 2 - 28  Price Overrides

To review modifier price overrides, select Designs > Price Overrides > Item Price Overrides. 
To review Promo Price Overrides, select Designs > Price Overrides > Promo Price Overrides.
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Making a Backup of a Menu
When you are finished designing your menu, or switching to another menu, you can make a backup
of the current menu in Menu Configurator. Note: To back up an existing menu, you must first log into
Menu Configurator as a ClientAdmin or ClientSupport member. 

To back up an existing menu:

1. Select Export/Import > Save XML. 
2. Select the directory where your .xml files are stored and click OK. A confirmation message 

appears.  

3. Click Close. 

Restoring a Menu
You can return to a menu you designed by restoring it in Menu Configurator. Note: To restore an
existing menu, you must first log into Menu Configurator as a ClientAdmin or ClientSupport member.

To restore a menu:

1. Select Export/Import > Load XML. 
2. Browse to the directory where your .xml files are stored and click OK. The system restores 

the menu with no confirmation message. 

Figure 2 - 29  XML File Save Confirmation
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About Graphics and Content
You can customize your online ordering site, within certain parameters, to match your company branding.
You can modify elements, such as the background page or one of the other pages, to match your web site
to provide a seamless online ordering experience for your consumers. Customizing the elements is not a
prerequisite for Aloha Online Ordering functionality. Your online ordering site comes with default graphics
and elements in place and ready to use without you having to do any customization. You can even add pic-
tures of your menu items to entice your consumers as they make their selections. 

Compare and contrast the stock site landing ordering page (page_landing.png) and a stock header
(header.png) with a customized site landing ordering page and header.   

Figure 3 - 1  Stock Landing Ordering Page and Header

Figure 3 - 2  Custom Landing Ordering Page and Header
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Follow these tips when designing and customizing graphics and elements for your online ordering site to
enhance the consumer-ordering experience: 

• Easy to read.
• Easy to navigate and understand.
• Consistent in layout and design.
• Quick to load in the web browser.

This chapter describes how to customize the pages and content for your online ordering site.

Before You Begin
Prior to customizing the graphics and elements of your web site, review the material in this section to famil-
iarize yourself with the package of standard page design elements, the basic online ordering process, and
the elements available for customization.

The Graphics and Content section of Web Admin contains .css and .txt files. Although users with the
‘Graphic Admin’ access level can access these files, Aloha Online Ordering neither supports nor recom-
mends altering these items. If you choose to edit these files, you are responsible for testing the customiza-
tion of these files. Should a site error occur as a result of the customization of these files and you cannot
resolve the error, the Aloha Online Ordering team can only upload the stock .css and .txt files back to your
online ordering web site.
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Understanding the Standard Page Design Elements

The following table identifies and defines the various types of design elements within an online ordering
site, and provides customization tips specific to each type of element.

Table 1: Standard Page Design Elements 

Element Type # of Files
File 
Format

Purpose Customization Tips

Button Graphics 28+ PNG The interactive buttons initi-
ate the program actions that 
drive the online ordering pro-
cess. Text automatically over-
lays most buttons throughout 
the ordering process.

DO: Customize the visual 
appearance of the buttons 
to match your company 
branding.
DO NOT: Change the origi-
nal button dimensions, PNG 
file naming conventions, or 
button text.

Universal, Independent, 
and Optional Graphics

40+ PNG The universal and indepen-
dent graphics provide back-
ground color, visual content 
organization, and opportuni-
ties for incorporating custom 
images. Applying a consistent 
design theme across these 
graphics and all other page 
design elements ensures a 
consistent and logical online 
ordering experience.

DO: Customize the visual 
appearance of the indepen-
dent graphics to match your 
company branding.
DO NOT: Change the origi-
nal dimensions or PNG file 
naming conventions.

Primary Page Graphics 5 PNG The primary page graphics 
serve as layout templates 
designed to organize the con-
tent.

DO: Become familiar with 
the standard online ordering 
page layout sections and 
their respective positioning 
and dimensions.
DO NOT: Design new 
graphics with dimensions 
different from their original 
dimensions. You cannot 
modify the positioning and 
dimensions of each section 
to accommodate element 
dimension variations.
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Understanding the Online Ordering Process

The following graphic demonstrates the online ordering process and the pages presented to the consumer
during the online ordering process. The ordering process may vary for your company, depending on the
online ordering functionality you selected. 

Each page presented to a consumer, as indicated in the above order flow, relies on an element file listed in
the table below.

Figure 3 - 3  Online Order Flow

Element File Corresponding Step

page-landing.png 1,2

page_start.png 8

page_menu.png 9

page_text.png 3,4,5,6,7,9,10

page_thankyou.png 11
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Additionally, the following elements always appear to the consumer when accessing the online ordering
site. 

Reviewing the Available Design Elements

Aloha Online Ordering contains a number of different design elements available for you to customize.Refer
to Design Elements for a list and description of the design elements, including the corresponding pixel
height and width.

Customizing Graphics and Elements
The Aloha Online Ordering team preloads your site with the necessary stock element files and graphics
you can use for your online ordering site. You can also customize these files as long as they adhere to the
size and shape specifications required for these files.

Use the Graphics and Content section of Web Admin to store and manage your graphics and element files. 

To use customized graphics and element files:

1. Download the specific file from the Graphics and Content page.
2. Edit the file.
3. Upload the edited file to the Graphics and Content page.
4. Refresh your ordering site.

To download the current version of the graphic or element file in use on your online ordering web
site:

1. In Web Admin, select Designs > Graphics and Content.
2. Under ‘Content Key,’ type the file name or a phrase within the file name, and press Enter. The 

matching results appear.
3. Select the file to download.
4. Click Download. The system downloads the file to your computer.

Element File Description

background.png The browser background color.

footer.png The site footer.

header.png The site header.

nav_bar.png The site navigation bar background.

page_text_repeat.png Enables page expansion whenever the standard page height is exceeded.

To download all the graphics and element files instead of only one file, select Download Zip. 
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To upload edited files to the Graphics and Content page:

Once you finish customizing a file you download, you can upload the edited file to the Graphics and Con-
tent page of Web Admin. The file you upload automatically replaces the corresponding file. You also use
these steps to upload graphic files of your menu items. 

1. Select Designs > Graphics and Content. 
2. Click Upload to upload a single file.

-OR-

Click Upload Zip to upload a zip file containing multiple files. 

The Upload Content screen appears.

3. Click Choose File.
4. Navigate to and select the file to upload.
5. Click Open. The system returns to the Upload Content screen with the file name listed next to 

‘Choose File.’
6. Click Upload File. The system uploads the file.

Figure 3 - 4  Graphics and Content Screen

Figure 3 - 5  Upload Content

Upload 
Refresh 
Ordering Site

 Upload Zip
3 - 8 Customizing Your Graphics and Content Aloha Online Ordering User Guide



 

7. Click Close to exit the Upload Content screen.
8. Click Refresh Ordering Site to publish your changes. 

Designing Graphical Menu Categories
The menu categories in Aloha Online Ordering default to text menu categories (as shown in the example
on the right below); however, you have the option of designing graphical menu categories (as shown in the
example on the left below). Use graphical menu categories as an excellent alternative design solution, par-
ticularly if the left-side menu area in the primary page element files (page_start.png and page_menu.png)
is not wide enough to accommodate the default text version of the text menu categories.

It may take up to five minutes for the new files to appear on your online ordering site. Delet-
ing the browser cache can also be beneficial. 

Figure 3 - 6  Graphical Menu Category and Text Menu Category
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The following table references the menu element pages. 

Element Name
Pixel 
Width

Pixel 
Height

Description Important Notes

submenu_[cate-
gory#].png

176 30 The left side menu category but-
ton. Appears in the primary 
menu category list. Modify the 
height as needed in conjunction 
with modifying the correspond-
ing expected dimensions listed 
in the AlohaOnline.css file.

The system automatically 
assigns the category number 
for each menu category but-
ton during the menu configu-
ration process. Contact your 
menu builder to locate these 
numbers.
You can also include non-
selectable graphics for menu 
sub-categorization as needed.

submenu_[cate-
gory#]_hover.png

176 30 Hover version of submenu_[cat-
egory#].png.

submenu_[cate-
gory#]_selected.png

176 30 Selected version of sub-
menu_[category#].png.

submenutitle_[cate-
gory#].png

517 130 Appears as the menu category 
header graphics. Incorporates 
photos, images, and text as 
desired.

You cannot modify the height 
and width.

button_catego-
ry_more.png

176 30 Appears when more menu cate-
gories are available than can be 
accommodated in the space pro-
vided on the primary page ele-
ment. Must be activated for 16 or 
more submenu categories.

Menus requiring the use of 
this button tend to not be user-
friendly as they overwhelm 
consumers with choices. 
When possible, reduce or 
consolidate the number of cat-
egory offerings.

button_catego-
ry_more_hover.png

176 30 Hover version of button_catego-
ry_more.png.

background_timese-
lectionfields.png

685 80 Graphic to display behind the 
date and time on the Time.aspx 
page.

promotion_timeselec-
tion.png

228 300 Highlights site specific messag-
ing on the time.aspx page.

background_order-
type[#]section.png

228 300 Highlights the individual order 
modes on the time.aspx page.

Each order mode has its own 
background graphic using 
number. 

background_order-
typeselection-
base.png

685 300 Large graphic behind order 
modes and site specific messag-
ing.
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Working with the Advanced Landing Page
Adding the Advanced Landing page allows you to remove a step from the online ordering process by add-
ing Login, Delivery, and Pickup options to the initial page a consumer sees when accessing your online
ordering site. To add the Advanced Landing Page to your online ordering site requires you to configure a
number of company settings. Optionally, you may update the graphics related to the Advanced Landing
page.  

Figure 3 - 7  Advanced Landing Page Enabled

Figure 3 - 8  Advanced Landing Page Not Enabled
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Updating Company Settings

Update the following company settings to configure the Advanced Landing page. Refer to “To add or edit a
company setting:” on page 1-8 for more information.  

Updating Graphics on the Advanced Landing Page

The Advanced Landing page adds the following elements, which you may want to customize for your
online ordering site.

• page_landing_advanced.png- This element contains the same dimension and layout as the 
page_landing.png. 

• Delivery buttons - The Advanced Landing page adds the following delivery buttons:

• button_down.png
• button_down_hover.png

Company setting Value for Advanced Landing page Action

AdvancedLandingPage true Enables the advanced landing 
page.

StartOrderURL ‘/’ Necessary when you enable the 
advanced landing page.

StoreLocatorRequiresAd-
dress

false Necessary when you enable the 
advanced landing page.

LandingPageAccountLogin-
SuccessfulURL

You have three options:
1. ‘/-’ - User remains on landing page.
2. ‘/AccountDashboard.aspx’ - System 
directs user to the Account Dashboard 
page.
3. ‘/AccountInfo.aspx’ - Systems directs 
the user to the Manage Account page.

Controls the page the system redi-
rects a user after logging in at the 
advanced landing page.

DisableDeliveryLanding true - Hides the delivery option.
false - Does not hide the delivery option.

Controls whether the user sees the 
option for delivery for online orders.
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Changing the Text on the Advanced Landing Page

You can change the text, such as ‘Order For Delivery’ and ‘Order For Pickup,’ on the Advanced Landing
page.

To change the text that appears on the Advanced Landing page:

1. In Web Admin, select Configuration > Messages Setup.
2. Select the message to edit. On the Advanced Landing page, the Delivery Line Header and the 

Pickup Line Header each contain two lines. For example, the default text for line one is ‘Order For,’ 
and the default text for line two is ‘Delivery’ for delivery, and ‘Pickup’ for pickup. The settings are:

• WebOrder.LandingPageAdvanced.DeliveryLineOneHeader
• WebOrder.LandingPageAdvanced.DeliveryLineTwoHeader
• WebOrder.LandingPageAdvanced.PickupLineOneHeader
• WebOrder.LandingPageAdvanced.PickupLineTwoHeader

3. Click Edit. The Edit Message screen appears.
4. Type the custom message.
5. Click Update.

Understanding Store Locator Behavior with the 
Advanced Landing Page

When using the Advanced Landing page, the way in which you set the Store Locator value further deter-
mines how the system presents information about nearby stores to the consumer for delivery orders. You
use company settings to define Store Locator behavior.

Company Setting Behavior

StoreLocatorEnabled = true The system takes the delivery address information from the consumer on 
the Advanced Landing page and transfers the information to the address 
fields on the Store Locator page, presenting the consumer with the 
nearby stores.

StoreLocatorEnabled = false The system does not prompt the user to enter a delivery address. 
Instead, the system directs the user to a page with a list of store loca-
tions.

StoreLocatorEnabled = false
LocationsURL = (a valid URL)

The system redirects the consumer to the specified URL when they 
select the Delivery button.
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Customizing Submenu Names
You can customize the text of the submenu names appearing on the left side menu and at the top of each
open submenu. 

You customize the submenu text by editing Template.xml.

1. Select Designs > Graphics and Content, and download Template.xml. Refer to “To download 
the current version of the graphic or element file in use on your online ordering web site:” on 
page 3-7 for more information.

2. Open Template.xml using Notepad, or another .xml editor.
3. Locate the following sections:

• <dynamicText id=”Category”> - Controls the submenu text listed on the left side menu.
• <dynamicText id=”CategoryTitle”> - Controls the text listed at the top of each open sub-

menu on the right side of the menu.
4. Change the following fields to best meet your own design needs:

• fontName - Controls the type of font. You must upload the font file to the Graphics and Con-
tent section. Valid values include ‘fontname.ttf’ or ‘fontname.otf’

• fontSize - Controls the size of the font. Use caution as font size can impact the amount of text 
the system displays. Valid values include 8, 9, 10, 11, 12, 14, 16, etc.

• fontStyle - Controls the font style. Valid values include: ‘regular’ or ‘bold.’
• fontColor - Controls the main color of the text. Adjust the color using HEX codes.
• hoverColor - Controls the text color when the user hovers the mouse over the text. Adjust the 

color using HEX codes.

Figure 3 - 9  Submenu Selected

The submenu names 
you can change.
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• selectedColor - Controls the text color when the user selects a submenu. Adjust the color 
using HEX codes. 

5. Save Template.xml.
6. In Web Admin, select Designs > Graphics and Content, and upload Template.xml. Refer to “To 

upload edited files to the Graphics and Content page:” on page 3-8 for more information. 
7. Click Refresh Ordering Site.

Figure 3 - 10  Hex Color Codes
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Adding Social Media Plugins
You can add Facebook, Twitter, and Pinterest plugins to your online ordering site to more easily connect
with your consumers. You can add Facebook, Twitter, and Pinterest icons to launch to your social media
pages, allow consumers to follow your social media pages, and launch a Twitter share popup.

When you enable Twitter Badge, Facebook Badge, or Pinterest Badge, the system displays these on the
footer at all times on the ordering pages. When you enable Twitter Share, Twitter Follow, Facebook Send,
and Facebook Like, the system displays these only on the order confirmation page. Review the following
examples to determine which social media settings to enable:   

Figure 3 - 11  Facebook, Pinterest, and Twitter Icons

Figure 3 - 12  Twitter and Facebook Launch

Facebook, 
Pinterest, and 
Twitter icons
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Update the following company settings to configure the Social Media settings. Refer to “To add or edit a
company setting:” on page 1-8 for more information.

Figure 3 - 13  Twitter Share and Twitter Follow

Figure 3 - 14  Facebook Like and Facebook Send

Company Setting Example Value

SocialMediaFacebookBadgeURL http://www.facebook.com/<YourUserNameHere>

SocialMediaFacebookLikeURL http://www.facebook.com/<YourUserNameHere>

SocialMediaFacebookSendURL http://www.facebook.com/<YourUserNameHere>

SocialMediaPinterestBadgeURL http://www.pinterest.com/<YourUserNameHere>

SocialMediaTwitterBadgeURL http://twitter.com/#!/<YourUserNameHere>

SocialMediaTwitterFollowURL http://twitter.com/#!/<YourUserNameHere>

SocialMediaTwitterShareMessage I just ordered from

SocialMediaTwitterShareURL http://twitter.com/#!/<YourUserNameHere>
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Working with the Contact Us Page
Aloha Online Ordering provides multiple ways by which you can add a Contact Us page to your online
ordering web site. You can elect not to include a Contact Us page, redirect consumers to another web site,
add a custom html form of your own design, or use the Aloha Online Ordering standard form. By default,
Aloha Online Ordering does not include a Contact Us page. 

Aloha Online Ordering prioritizes the Contact Us page options as follows:

• If you do not select any options, the system does not a display a Contact Us page.
• If you configure your Contact Us page to redirect to another web site, this setting takes prece-

dence over all others.
• If you configure a custom html form and you do not designate a URL to another page, the system 

presents the custom html page.
• If you configure the Aloha Online Ordering standard form and you do not specify a URL to another 

page or a custom html page, the system presents the Aloha Online Ordering standard form.

Redirecting to Another URL

You can use the Contact Us option to redirect the user to another URL. Edit the company setting, Contac-
tUsURL, and specify the URL for the page that contains your contact us page. Refer “To add or edit a com-
pany setting:” on page 1-8. 

Once you add the URL, the system adds the Contact Us link to the navigation bar. When the consumer
selects Contact Us, the system launches a new window with the specified URL 

Presenting a Custom HTML Form

You can also present an html form of your own design. Aloha Online Ordering contains an html form you
can edit for your own use. 

1. In Web Admin, select Designs > Graphics and Content, and download Contact.html. Refer to 
“To download the current version of the graphic or element file in use on your online ordering web 
site:” on page 3-7 for more information.

2. Edit Contact.html to your specifications using Notepad or another html editor.
3. In Web Admin, select Designs > Graphics and Content, and upload Contact.html. Refer “To 

upload edited files to the Graphics and Content page:” on page 3-8 for more information. 
4. Click Refresh Ordering Site.

Figure 3 - 15  ContactUsURL Company Setting

Figure 3 - 16  Custom HTML
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Presenting the Aloha Online Ordering Standard Form

You can choose to present the standard form to a consumer who clicks contact us in the navigation bar.
The consumer can type an email message that goes to an email address you specify in company settings.

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select ContactUsSendToEmailAddress to direct where to send the contact us email message.
3. Click Edit Setting.
4. Type the email address you want to receive the contact us email messages.
5. Click Update.
6. Select ContactUsEmailSubject.
7. Click Edit Setting.
8. Type the email subject line for the Contact Us email message.
9. Click Update.

Adding Pictures of Menu Items
Adding pictures of your menu items can be a great way to assist your consumers in making their food
selections. Aloha Online Ordering enables you to add pictures of menu and modifier items. You upload the
pictures to the Graphics and Content page of Web Admin, and then you use Menu Configurator to associ-
ate the menu item to the picture.

Figure 3 - 17  Standard Contact Us Form

Figure 3 - 18  Menu Item Example
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The following table demonstrates the dimensions for each image used on a menu. To use different image
sizes requires changes to AlohaOnline.css. Contact the Aloha Online Ordering team for more information.  

Uploading Pictures of Menu Items

You upload pictures of your menu items to the Graphics and Content section of Web Admin. Refer to “To
upload edited files to the Graphics and Content page:” on page 3-8 for information on how to upload
graphic files. Name the files in such a way to help you identify the menu item and the pixel size, such as
‘100x80_CheeseBread.png.’

Associating a Picture to a Menu Item

After you upload the pictures of your menu items to Graphics and Content, you then associate the picture
of a menu item to the menu item in Menu Configurator. The picture displays alongside the item and its
description in a submenu. You can also define a popup image to appear in the modifier popup window.

1. In Menu Configurator, select the menu item for which you want to associate a picture.

2. In Item Properties, type IMAGE as the ‘Advanced Style Setting.’
3. Type the file name for ‘Popup Image Name.’ Type the file name exactly as it appears in Graphics 

and Content. If the item is does not appear in a popup window, skip this step.
4. Type the file name for the Web Menu List Image. Type the file name exactly as it appears in 

Graphics and Content.
5. Publish the changes.

Image file name Width (pixels) Height (pixels0

Menu list image name. User defines 
the file name

100 80

Popup image name. User defines the 
file name

250 450

panel_header_image.png 820 33

panel_back_image.png 820 10

panel_bottom_image.png 820 21

Figure 3 - 19  Associating A Food Graphic
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Hiding the Display of the Submenu Name
Aloha Online Ordering provides you the option to hide the submenu name on your online ordering site. 

1. Select the submenu for which you want to hide the header text.
2. In Item Properties, select False from the ‘Show Header’ drop-down list.

3. Publish the changes.

Figure 3 - 20  With and Without Header

To display the submenu text header, select True from the ‘Show Header’ drop-down list. The sys-
tem displays the submenu name.
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Customizing Images for Mobile Web
You can tailor the appearance of your online ordering site for consumers who access it on mobile devices.
You can customize the various pages, such as the Landing page, General pages, and the Order Entry
pages. With each page, you can customize the look of your online ordering site for mobile devices so that
it matches your branding.

Customizing the General Pages for Mobile Web

For the general pages of your mobile web site, you can customize the background color of the site menu
and popup window, the primary button (the button appearing on the right), and the secondary button (but
button appearing on the left). 

You can customize the following:

• Site Menu - Set the background color.
• Primary Button - Set the gradient colors and borders for primary buttons.

Figure 3 - 21  Site Menu and Primary and Secondary Button

Figure 3 - 22  Popup Background
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• Primary Button Hover - Set the gradient colors for the primary hover buttons.
• Primary Button Active - Set the gradient colors for the primary active buttons.
• Secondary Button - Set the gradient colors and borders for secondary buttons.
• Secondary Button Hover - Set the gradient colors for secondary hover buttons.
• Secondary Button Active - Set the gradient colors for secondary active buttons.
• Popup Background - Set the background color for popup windows.

To customize the mobile web settings:

1. In Web Admin, select Designs > Mobile Site Configuration.
2. Make the desired changes.
3. Click Save Changes. 
4. Click Refresh Ordering Site.

Customizing the Splash and Landing Page for Mobile Web

You can customize the splash and landing page for mobile web. A user arrives at the landing page when
they launch the mobile application, and the image associated with the landing page is the first image they
see. Most restaurants use an image consisting of their logo and some details regarding online ordering. To
customize the colors of the landing page, refer to “To customize the mobile web settings:” on page 3-23. 

You can customize the following: 

• Text and Background - Set the background and text color.
• Logo Image - Set the image to display on the splash page.The file name for the mobile web land-

ing page is main-image.png. Upload an image with the pixel width and height of 664 x 350. You 
upload the image to Designs > Mobile Site Configuration.

• Pickup Tab Header - Sets the color for the pickup tab on the splash page.
• Delivery Tab Header - Sets the color for the delivery tab on the splash page.
• Tab Body - Sets the background color for tab body on the splash page. 

Figure 3 - 23  Landing Page
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To upload a logo image:

1. In Web Admin, select Designs > Mobile Site Configuration.
2. Click Upload Logo.
3. Click Choose File.
4. Navigate to and select the logo file.
5. Click Open.
6. Click Upload File.
7. Click Save Changes.
8. Click Refresh Ordering Site. 

Customizing the Order Entry Page for Mobile Web

The Order Entry pages allows a consumer to enter the items for order and to view their subtotal. You can
customize the colors for the Order Entry page. To customize the Order Entry pages, refer to “To customize
the mobile web settings:” on page 3-23. 

You can customize the following:

• Navigation Bar - Sets the background and text color for the navigation header on the order entry 
page.

• Cart Circle - Sets the background and text color the cart circle image on the order entry page.
• Sub-Menu List (Menu List) - Sets the gradient colors for menu categories on the order entry 

page.
• Order Entry Subtotal - Sets the background color for the item subtotal field on the order entry 

page. 

Figure 3 - 24  Cart Circle and Menu (Submenu) List

Figure 3 - 25  Order Entry Subtotal
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Adding a Mobile Web Image for a Submenu

Each submenu can have a unique image to the left of the submenu title, which can assist consumers in
making their selections. If you do not add an image for the submenu name, the system places a default
icon in place of the image.  

To add a mobile web image for a submenu you must:

• Set the MobileWebHasSubMenuPictures company setting to true. Refer to “To add or edit a com-
pany setting:” on page 1-8 for more information.

• Upload an image with a pixel width and height of 136 x 136 for the submenu to Designs > Graphic 
and Content. Recommendation: Name the file in a way to help you identify the submenu for 
which to use the image. Refer to “To upload edited files to the Graphics and Content page:” on 
page 3-8 for more information.

Adding a Mobile Web Image for a Menu Item

Each menu item can have a unique image to the left of the menu item title, which can assist consumers in
making their selections. If you do not add an image for the menu item, the system places a default icon in
place of the image.

Figure 3 - 26  Submenu Mobile Web

Figure 3 - 27  Menu Item Mobile Web

mobile web image

default icon
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To add a mobile web image for a menu item you must:

• Set the MobileWebHasMenuItemPictures company setting to true. Refer to “To add or edit a com-
pany setting:” on page 1-8 for more information.

• Upload an image with a pixel width and height of 136 x 136 with a file name of mobile_[Web Menu 
List Image Name]. The ‘Web Menu List Image’ is the image item name used on desktop web. The 
file format for the mobile image must be the same as the desktop web, either JPG or PNG. Refer to 
“To upload edited files to the Graphics and Content page:” on page 3-8 for more information.
3 - 26 Customizing Your Graphics and Content Aloha Online Ordering User Guide



4Working with 
Comps, Promos, and 
Upsells
Working with Comps ..................................................................................................................................4-3
Configuring a Sales Item Group for Comps ........................................................................................ 4-4
Configuring a Comp ............................................................................................................................... 4-4

Working with Promos...............................................................................................................................4-10
Working with Transaction Upsells ..........................................................................................................4-12

Configuring Transaction Upsell Graphics.......................................................................................... 4-14
Aloha Online Ordering User Guide Working with Comps, Promos, and Upsells 4 - 1



4 - 2 Working with Comps, Promos, and Upsells Aloha Online Ordering User Guide



 

Aloha Online Ordering enables you to create comps and promos for you to offer on your online
ordering site to your consumers. You can also prompt your consumers to add additional items when
they select specific items for order, referred to as a transaction upsell. Use the Comps function to cre-
ate unique incentives just for your online ordering consumers. You must create a generic comp in the
Aloha POS to which you associate multiple comps from Web Admin. To also offer the promos config-
ured in the Aloha POS to your online consumers, you must create an association between the promo
you create in Web Admin with the specific promo in the Aloha POS.

Working with Comps
A comp allows you to offer an incentive, such as a discount, to consumers using your online ordering
site. When you configure a comp, the system adds a Coupon Code field to the Order Confirmation
and Payment page. The consumer enters the coupon code provided to them, clicks Apply, and the
system applies the discount to the consumer order.  

With a comp, you can: 

• Offer a discount as an amount or a percentage.
• Limit the amount of the comp.
• Require a minimum purchase amount to receive the comp.
• Base the comp on the size of the order or on frequency of visits.

For the successful use of comps as part of your online ordering site, a comp must meet the following
requirements:

• Every online ordering comp must have a corresponding comp in the POS; however, you can 
associate multiple online ordering comps to a single comp in the POS.

• You must define the corresponding POS comp as a ‘Prompt for amount’ comp in the POS. 
When you define a comp as ‘percentage off’ in Web Admin, Aloha Online Ordering performs 
the calculation and sends the appropriate discount to the POS.

• A consumer can add multiple non-recurring comps to their order, yet they can only add one 
recurring comp to their order.

Figure 4 - 1  Order Confirmation and Payment Page
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Configuring a Sales Item Group for Comps
You can optionally offer a comp discount that applies only when a guest orders specific eligible items.
Once you create a sales item group, you attach the group to the ‘Sales Item Group’ drop-down list for
the applicable comp. 

To create a sales item group for a comp:

1. Select Designs > Discounts > Sales Item Groups.
2. Click Add Sales Item Group. The Add Sales Item Group screen appears.
3. Type a name for the sales item group.
4. Type a description for the sales item group.
5. Click Update. The system returns to the Sales Item Group screen.
6. Select the sales item group you created from the ‘Select a Sales item Group to add or 

remove Sales Items from’ drop-down list. The system populates the screen with all of your 
sales items.

7. Select a sales item to include in the sales item group.
8. Click Edit.
9. Click Selected.
10. Click Update.
11. Repeat steps 7 through 10 for each additional item to include in the sales item group.
12. Exit the Sales Item Group function.

Configuring a Comp
After you configure your comps in the POS, access Web Admin to configure your comps for Aloha
Online Ordering. You can configure the times of a specific day of the week for when the comp is avail-
able. For example, you can offer a comp that is available between the hours of 6:00 p.m. to 10:00

Figure 4 - 2  Sales Item Group Selection
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p.m. on each Friday. By default, when you configure a comp, the comp applies to all sites; however,
you can assign a comp to a specific site. You may want to do this for a particular site that wants to
offer a discount within a specific market in which that site resides. 

1. In WebAdmin, select Designs > Discounts > Comps.
2. Select Add Comp to create a new comp. 

3. Type the name to appear for the comp on the Web site virtual receipt.
4. Type a description to help identify the comp.
5. Enter the corresponding POS Id for the comp.
6. Type the online comp code, which is the code you want consumers to enter at the Verify Pay-

ment page.
7. Select a start and end date for the comp.
8. Select Account Required, to restrict the comp to registered consumers.
9. Select Enabled to activate the comp.
10. Select a comp type from the ‘Reduction Type’ drop-down list.

• Flat Amount - Reduces the check by a dollar amount.
• Percentage - Reduces the check by a percentage without a dollar maximum.
• Capped Percentage - Reduces the check by a percentage with a dollar maximum.
• Goal Price - Reduces the price of the item to a specified price. Applies to sales items 

within a specific sales group. Refer to “Configuring a Goal Price Comp” on page 4-8 for 
more information.

11. Enter the amount or percentage of the discount.
12. For capped percentage discounts, enter the maximum reduction amount.
13. (Optional) Enter a transaction minimum amount for the comp.

Refer to the NCR Aloha Table Service Reference Guide or the NCR Aloha Quick Service Refer-
ence Guide.

Figure 4 - 3  Add Comp Screen - Configuration Details Tab
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14. Select a comp control from the ‘Comp Usage Threshold’ drop-down list.

• PerCustomerUsageCount - Controls the number of times a consumer can use the comp. 
For example, if you set the control at ‘5,’ then each consumer can use this comp only five 
times. 

• TotalUsageCount - Controls the total number of times all consumers can use the comp. 
For example, if you set the control at ‘1,000,’ then the system only allows the use of the 
comp one thousand times, regardless of the specific consumer.

• PerCustomerUsageAmount - Controls the maximum amount each consumer can 
receive from the comp. For example, if you set the control at ‘$50.00,’ then each consumer 
can receive a maximum of ‘$50.00’ from the comp code, regardless of the number of 
orders.

• TotalUsageAmount - Controls the maximum amount of discounts allowed by the comp. 
For example, if you set the control at ‘$5,000.00,’ then the system only allows the use of 
the comp until you provide ‘$5,000.00’ worth of discounts.

• PerCustomerRecurringCount - Defines the comp as available to a consumer each time 
they place a certain number of orders. For example, if you set the control at ‘5,’ then the 
consumer can use the comp after every fifth order.

• PerCustomerRecurringAmount - Defines the comp as available to the consumer after 
reaching a dollar amount threshold of orders. For example, if you set the control at 
‘$200.00,’ then the consumer can use the comp for every $200 they spend.

15. Enter the maximum number or amount for the comp usage threshold you selected.
16. Enter the recurring number for the usage threshold, if you selected a recurring threshold 

comp control.
17. If you are using a sales item group to offer a comp discount that applies only when a guest 

orders specific eligible items, select the sales group you created earlier. 
18. For goal price comp discounts, click Auto-Apply for the system to apply the discount without 

the need to perform additional actions. If you clear ‘Auto-Apply,’ the consumer can use the 
Goal Price discount by entering a discount code at checkout. The system prevents you from 
selecting ‘Auto-Apply’ for any other discount type. 

19. Select the Configuration Periods tab.  

20. Click Edit for the day of the week on which to make the comp available. 
21. Select Enabled to make the comp available for that day. 
22. Set the start time for the period by either typing the hour, minute, and AM or PM, or by using 

the up and down arrows to select the time. 
23. Set the end time for the period by either typing the hour, minute, and AM or PM, or by using 

the up and down arrows to select the time. 
24. Click Update to complete the configuration period for the day of the week. 

Figure 4 - 4  Configuration Periods Tab
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25. Repeat steps 20 through 24 for each day of the week on which the guest can use the comp. 
26. Select the Assigned Sites tab. 

27. To assign a comp to a site, perform one of the following: 

• To assign a comp by adding the sites from a site group, select a site group from the 
‘Add/Remove by Site Group’ list and click Add Selected Group. The sites included in the 
site group appear in the ‘Selected Sites’ list. 

• To unassign a comp by removing the sites found in the site group, select a site group 
from the ‘Add/Remove by Site Group’ list and click Remove Selected Group. The sites 
included in the site group are removed from the ‘Selected Sites’ list. 

• To assign a comp to a single site, select the site from the ‘Available Sites’ list box and click 
Add Selected to move the site to the ‘Selected Sites’ list box. 

• To assign a comp to all sites, click Add All to move all sites to the ‘Selected Sites’ list box. 
Notes: This is the default behavior when you first add a comp. 

• To exclude a comp from a single site, select the site from the ‘Selected Sites’ list box 
and click Remove Selected to move the site to the ‘Available Sites’ list box. 

• To exclude a comp from all sites, click Remove All to move all sites to the ‘Available 
Sites’ list box. 

28. Click Update.

Understanding Recurring Comps
The following rules apply to the ‘PerCustomerRecurringCount’ and ‘PerCustomerRecurringAmount’
comp usage threshold controls:

• Only a consumer with a registered account can apply a recurring comp to their order.
• A consumer can only have one active recurring comp. 
• The system does not automatically apply a recurring comp. The consumer must apply the 

comp code. The system only auto-applies goal price comps.
• When a consumer meets the conditions for a recurring comp, the system applies the comp to 

the next order. For example, a recurring comp provides $10 off every fifth order. After placing 
five orders, the consumer earns the discount to apply to their next order. 

Figure 4 - 5  Assigned Sites Tab
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• Residual comp value does not carry over. For example, a consumer receives a reward for $10 
off. On their next order, they only spend $8.00. They receive a comp for $8.00 and the system 
does not retain the $2.00 comp.

• When tracking order amounts for recurring comp purposes, the system carries forward the 
amount over the value. For example, you set a comp to give consumers $10 off for every 
$200 spent. A consumer has spent $190, and on their next purchase they spend $45, putting 
them over the threshold. On their next order, they receive the $10 comp, and the system con-
siders them to have already accumulated $35 towards the next $200 threshold.

• A consumer can use non-recurring comps in conjunction with a recurring comp.
• When a recurring comp triggers on an order, the system hides the coupon entry field, thereby 

prohibiting the consumer from entering another recurring comp for the order the recurring 
comp is triggering. For example, you set a comp to give $10 off for every $200 in purchases. 
The consumer places an order giving them $230 worth of purchases. On their next order, the 
$10 discount automatically shows up when the consumer progresses to the Order and Pay-
ment confirmation screen without the need to enter any sort of coupon code and the system 
hides the coupon code entry field.

Understanding Comp Rejection Reasons
The following lists the possible reasons the system may reject the comp a consumer attempts to
apply to their order.

• CompNotEnabled - The comp is not enabled for use.
• BeforeStartDate - The order date is before the comp start date.
• AfterEndDate - The order date is after the comp end date.
• TransactionMinimumNotMet - The order does not meet the minimum transaction amount 

for the comp.
• CustomerAccountRequired - The comp requires the user be a registered consumer.
• TotalUsageCountExceeded - The order exceeds the maximum number of usages for the 

comp.
• TotalUsageAmountExceeded - The order exceeds the maximum amount of redemptions for 

the comp.
• CustomerUsageCountExceeded - The system cannot apply the comp because the consumer 

previously exceeded the maximum number of usages for the comp.
• CustomerUsageAmountExceeded - The system cannot apply the comp because the con-

sumer previously redeemed the comp for the maximum amount. 
• RecurringCompAlreadyBeingTracked - The system cannot apply the comp because it is a 

recurring comp and the consumer is already tracking against a different recurring comp.

Configuring a Goal Price Comp
A goal price comp is a reduction type that applies a dynamic discount to each sales item within a spe-
cific sales item group. You configure the end price (goal price) and the system reduces the amount to
the end price, leaving the remaining amount as the discount of the comp. Using a goal price comp,
you can create a specific for a range of items that normally have a different price and reduce the
price to the same flat amount. For example, you may create a comp where all large pizzas reduce to a
flat price of $10.00 on Monday. Within your database, large pizzas vary in price from $13.95 to
$17.95. With the goal price set at $10.00, a $13.95 pizza receives a $3.95 discount, whereas a $17.05
pizza receives a $7.95 discount.
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Things to keep in mind regarding a goal price comp:

• To use a goal price comp, you must first enable the Goal Price comp functionality. 
• Before creating a goal price comp, you must create a sales group for the comp.
• A goal price comp must have a corresponding comp on the POS; however, you can associate 

multiple goal price comps (auto-applied or discount-coded) to a single comp on the POS.
• The system allows more than one auto-applied goal price comp within the same order so the 

guest can receive multiple discounts. 
• The ‘Account Required’ setting is not supported with the ‘Auto-Apply’ feature.
• A goal price comp does not support the following settings:

• Max Reduction Amount
• Transaction Minimum Amount
• Comp Usage Threshold
• Max Usage Count / Amt
• Recurring Usage Count / Amt

To enable the Goal price comp functionality:

1. Select Company Settings Setup. 
2. Select UseGoalPriceComps, 
3. Click Edit Settings. 
4. Set the value to True and click Edit. 

To create a goal price comp:

After you enable the Goal Price functionality and create the sales item group, you can create the goal
price comp.

1. Select Designs > Discounts > Comps.
2. Select Add Comp.

Figure 4 - 6  Goal Price Comp Configuration
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3. Type a name to appear for the comp on the web site virtual receipt.
4. Type a description for the comp.
5. Enter the POS comp ID.
6. Type the online comp code, which is the code you want consumers to enter at the Order 

Confirmation and Payment screen.
7. Select a start and end date for the comp.
8. Select Enabled to activate the comp.
9. Select Goal Price from the ‘Reduction Type’ drop-down list. When you select Goal Price, the 

system adds the Configuration Periods tab and the Assigned Sites tab.
10. Enter the goal price of the item. 
11. Select the sales item group you created from the ‘Sales Item Group’ drop-down list. 
12. Select Auto-Apply.
13. Type the number of modifiers you want to allow the guest to order for free from the ‘Free 

Modifier Count’ drop-down list. This allows the guest to add a specified number of modifiers 
of their choosing before the system starts charging a price. For example, on a 3-topping pizza, 
the guest can order onions, pepperoni, and black olives at no charge, and then add bacon for 
a price. 

14. Select the Configuration Periods tab. By default, the system enables the comp for every day 
of the week. If you do not configure a specific day, then the comp is valid for every day of the 
week. To enable the goal price comp for specific days of the week, select the day, click Edit, 
select Enabled, edit the start and end time, if necessary, and click Update.

15. Select the Assigned Sites tab.
16. Under ‘Available Sites,’ select the store to which you want to assign the goal price, and click 

Add Selected. The system moves the selected stores to ‘Selected Sites.’
17. Click Update.

Working with Promos
Aloha Online Ordering supports the use of promos that exist in the Aloha POS to deliver offers and
incentives to consumers using your online ordering site. As Aloha Online Ordering imports menu
data into Menu Configurator for you to design your menu, Aloha Online Ordering also imports the
promos from your POS for use. Consumers can enter a designated code to apply the use of the
promo to their order. Aloha Online Ordering uses the settings for a promo as defined by the Aloha
POS. 

For successful implementation of promos in your online ordering system, promos must meet the fol-
lowing requirements:

• Aloha POS v6.7 or later, and must be using Quick Service. Table Service is not supported.
• ATO v12.1.5 or later. 
• A promo for Aloha Online Ordering must have a corresponding promo in the POS.
• In the Aloha POS, you must configure the promo according to the following:

• With the type set of ‘BOGO,’ or ‘Coupon.’
• Set as active.
• Clear ‘Manager Needed.’
• For ‘coupon’ type promos, clear ‘User selects each qualified item.’
• Set the ‘Max Per Check’ value to greater than ‘0.0. 

Refer to the NCR Aloha Quick Service Reference Guide for more information.
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To configure a promo:

After configuring your promos in the Aloha POS, you configure promos for Aloha Online Ordering in
Web Admin.

1. In Web Admin, select Designs > Discounts > Promos.
2. Select Add Promo Code.

3. Select the promo from the ‘POS Promo’ drop-down list. 
4. Type the online promo code a consumer must enter to receive the promo on their order.
5. Select Enabled to activate the promo.
6. Click Update.

Applying a Promo
The following are true when applying a promo to an online order:

• After entering the coupon code, the consumer must click Apply to apply the promo to their 
order.

• The system applies the promo to the lowest priced item in the My Order section.
• A consumer can apply only one instance of a promo per online order.
• If a consumer enters a second promo code, the system erases the first promo code applied to 

the order, and applies the promo that corresponds to the second promo code.
• If a consumer modifies the contents of an order after applying a promo, the system automat-

ically deletes the previously applied promo, and the consumer must re-enter the promo code.

Figure 4 - 7  Edit Promo Code 
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When the system successfully applies a promo, the system places a ‘Promo Applied’ notification on
the ‘My Order’ portion of the screen. 

If the system cannot successfully apply a promo to the order, a notification appears under the Cou-
pon Code entry location with a reason as to why the promo could not be applied to the order.  

Working with Transaction Upsells
Use transaction upsells to prompt consumers to purchase additional items, based on the current
items in their order. Things to keep in mind regarding transaction upsells:

• Include items you can easily upsell. Recommendation: Include items you can sell without 
modification.

• You can only use items included on a visible submenu.

Figure 4 - 8  Promo Applied

Figure 4 - 9  Promo Rejection Notice
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• If you include an item with a required modifier, the upsell popup does not display the 
required modifier selection.

• If you include an item with a recipe or an item default, the system does not provide the con-
sumer to make these selections. The system only displays the sales item.

The transaction upsell process works as follows:

• When a consumer clicks Checkout, the system analyzes the items in the online guest check to 
determine if the guest check contains any sales items with an assigned upsell suggestion 
group. 

• If the guest check contains an item with an assigned upsell suggestion group, the system fur-
ther analyzes the guest check to determine if the guest check contains any of the sales items 
from the upsell suggestion group.

• If the guest check does contain items from the upsell suggestion group, the system does not 
display the upsell popup.

• If the guest check does not contains items from the upsell suggestion group, the system dis-
plays the upsell popup.

• The system displays the upsell popup only once, after the consumer clicks Checkout.

You configure transaction upsells by creating a sales item group, associating the sales item group to a
suggestion group, and then associate the suggestion group to a sales item. You can also associate
graphics with the items. For example, the sales item group includes the suggested items, such as ‘Gal-
lon Sweet Tea,’ ‘Gallon Unsweet Tea,’ and ‘Gallon Lemonade.’ You then create a suggestion group,
such as ‘Gallon Drinks 1.’ Finally, you associate the suggestion group to a sales item. In the example,
you may add the suggestion group ‘Gallon Drinks 1’ to the sales item ‘Chicken Tender Platter.’

To configure a sales item group for a transaction upsell:

1. In Web Admin, select Designs > Upsell Configuration > Sales Item Group Setup.
2. Click Add Sales Item Group. The Add Sales Item Group screen appears.

3. Type a name for the sales item group.
4. Type a description for the sales item group. The description appears on the online ordering 

menu.
5. Click Update.
6. Select the sales item group you created from the ‘Select a Sales Item Group to add or 

remove Sales Items from’ drop-down list. The system lists the menu items in your database 
for you to select for the sales item group.

7. Select a sales item to include in the sales item group.

Figure 4 - 10  Add Sales Item Group

Figure 4 - 11  
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8. Click Edit.
9. Click Selected.
10. Click Update.
11. (Optional) Repeat steps 7 through 10 for each additional item to include in the sales item 

group.
12. Exit the Sales Item Group Setup function.

To configure an upsell suggestion:

1. Select Designs > Upsell Configuration > Upsell Suggestion Setup 
2. Click Add Suggestion. The Add Upsell Suggestion screen appears. 

3. Type the name for the upsell suggestion.
4. Click Update. The system adds the upsell suggestion.
5. Click the + icon corresponding to the upsell suggestion.
6. Click New. 
7. Select the sales item group you created from the ‘Suggested Sales Item Group’ drop-down 

list. 
8. Click New to add additional sales item groups to the upsell suggestion. By default, the online 

ordering menu displays the sales group in the order you associate them with the sales item. 
To change the positioning of a group, enter a new sequence number and click Update. 

9. (Optional) Select Quantity Selection to allow the consumer to select a specific quantity of 
the upsell item. By default, the system clears the selection and uses the default value for all 
items in the group.

10. (Optional) Type an override description for the upsell configuration. By default, the system 
uses the description from the Sales Item Group configuration.

11. Click Update.

To assign sales items to an upsell suggestion:

1. Select Designs > Upsell Configuration > Upsell Suggestion Assignment.
2. Select the upsell suggestion from the ‘Choose Upsell Suggestion’ drop-down list.
3. Under ‘Available Sales Items,’ locate the item for which you want to associate with the upsell 

suggestion, and click Add Selected. The system moves the selected items to ‘Sales items 
which trigger Suggestion.’ To remove an item from a transaction upsell, under ‘Sales Items 
which trigger Suggestion,’ select the item, and click Remove Selected. The system moves the 
item to ‘Available Sales Items.’

4. Click Update.

Configuring Transaction Upsell Graphics
Aloha Online Ordering uses two graphic files for transaction upsell, that appear in the upsell pop-up
window, which you can customize. Refer to “Customizing Graphics and Elements” on page 3-7 for
more information. Those files are:

• Up-sellBackground.png
• Up-sellTitle.png

Figure 4 - 12  Add Upsell Suggestion Screen
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Additionally, the image associated with a menu item also appears when you include an item as part
of a transaction upsell.
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In Web Admin, you can manage the data for consumers who have online ordering accounts with you.
Consumers can create an account for themselves at your online ordering site, or you may elect to cre-
ate an account for a consumer. You can review consumer account data, edit consumer account infor-
mation, unlock account logins, and reset passwords. If you employ call center functionality, these
users access Accounts Review to add consumer accounts, and to select consumer accounts to initiate
orders for consumer. Through company settings, you can initiate a weekly export of your consumer
data.

Additionally, you can create contact reasons to appear on the Contact Information page. Contact rea-
sons allow your consumers to designate if they want you to contact them for specific reasons, such
as promotional offers. You configure the specific contact reason to display on the Contact Informa-
tion page. 

As an added security measure for your consumers, you can create security questions to which your
consumers must provide an answer to reset their password.

Working with Accounts Review
Accounts Review enables you to view information regarding your consumers. Access Accounts Review
in Web Admin by selecting Customer Accounts > Accounts Review. The system displays a grid con-
taining your existing consumer accounts.

The Accounts Review page includes the following information:

Figure 5 - 1  Accounts Review Page

Field Description

First Name The first name of the consumer.
Last Name The last name of the consumer.
Email Address The email address of the consumer.
Business Name The name of the business.
Department Name The name of the department within the business.
Loyalty Card Number The loyalty card number of the consumer.
Voice Phone The phone number of the consumer.
Extension The extension number, if any.
Has Login True: The consumer created an online ordering account.

False: The consumer does not have an online ordering account.
Is Tax Exempt True: The consumer is tax exempt.

False: The consumer is not tax exempt.
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In some scenarios, you may need to add and edit consumer accounts. For example, a consumer may
have difficulty creating an online ordering account, and you can do so for them. In other situations,
you may edit consumer information to add loyalty card information, to update a mailing address, to
change an email address, and more.

If you employ call center functionality, the call center employee accesses consumer accounts to
review consumer information and to initiate consumer orders. Employees with call center functional-
ity can also have customer accounts.

Upon the creation of a new online ordering account, whether the consumer creates the account at
your online ordering site or an employee creates the account for them, the system sends a welcome
email to the consumer.

To add a consumer account:

When adding consumer accounts, the system requires the following information: First Name, Last
Name, Email Address, AdressLine1, City, Postal, Security Question, and Security Answer.

1. In Web Admin, select Customer Accounts > Accounts Review.
2. Click Add. The Add Customer screen appears.
3. Type the consumer first name.
4. Type the consumer last name.
5. Type the consumer email address.
6. (Optional) Type a secondary email address.
7. Type the business name.
8. (Optional) Type the department name.
9. Enter the consumer’s voice phone number.
10. (Optional) Enter the phone number extension. 
11. (Optional) Enter an alternate phone number for the consumer.
12. (Optional) Enter the extension for the alternate phone number.
13. (Optional) Select Pay At Store Allowed to allow the consumer to pay at the store.
14. Select Tax Exempt for tax exempt consumers.
15. Enter the Tax Payer ID for tax exempt consumers.
16. For call center employees, select Call Center/Restaurant Portal Operator.
17. Enter the customer address.
18. Enter the city.
19. Select the state from the drop-down list.
20. Enter the postal code.
21. (Optional) Enter the Loyalty card number of the consumer.
22. Type a security question and answer for the consumer.

Tax Payer Id The tax payer Id number of the tax exempt organization. If the business is 
not tax exempt, this field remains blank.

Has Login True: The consumer has an account login.
False: The consumer does not have an account login.

Order History The order history of the consumer. Click Order History to view a listing of 
the previous orders of the consumer.

Start Call Center Order Allows persons with call center functionality to start an order for the 
selected consumer.

Start Restaurant Portal 
Order

Allows persons with Restaurant Portal functionality to start an order for the 
selected consumer.

Field Description
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23. Enter any notes about the consumer.
24. Click Save.

To edit a consumer account:

1. Select Customer Accounts > Accounts Review.
2. Select the consumer account.
3. Click Edit.
4. Make the desired changes.
5. Click Save.

Exporting Consumer Data 
In company settings, you can elect to export consumer data and the system emails the spreadsheet
in an .xls format every Sunday at 4 a.m. central standard time. The spreadsheet contains information
regarding consumers who successfully submitted orders to your online ordering site. The export
does not filter out consumers who ordered from you but did not create an account. 

The system can only send the export in .xls format and only at 4 a.m. central standard time. You can-
not change these settings. 

The export includes the following information:

• First and last name
• Email address
• Secondary email address
• Business name
• Department name
• Voice phone number and extension
• Alternate phone number and extension
• Loyalty number
• Is tax exempt
• Tax payer ID
• Pay at store allowed
• Call center operator
• Date of last order
• Amount of last order
• Total amount spent
• Total number of orders
• Average order amount
• Contact reasons external IDs
• Contact reason names
• Site external ID
• Site name
• Address, city, state and zip code of the consumer
• Creation date
• Last location where the consumer placed their order. 

Call the Online Ordering support team to enable ‘Data Export’ for your company and pro-
vide the email addresses of the recipients. 
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To configure an email address for receipt of conumer export reports:

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select AccountManagementEmailAddress.
3. Click Edit Setting.
4. Type the email addresses to which you want to send the report. Use a semi-colon to sepa-

rate multiple email addresses.
5. Click Update.

Working with Login Management
Login management enables you to view and manage the consumer accounts created for your online
ordering site. You can view the last login and activity of a consumer account, add a login, delete a
login, and export a grid of logins. 

To unlock a login:

1. In Web Admin, select Customer Accounts > Login Management.
2. Select the consumer account.
3. Click Unlock. A message appears.
4. Click OK.

To reset a password:

1. In Web Admin, select Customer Accounts > Login Management.
2. Select the consumer login account.
3. Click Reset Password. The Password Reset Successful prompt appears and the system sends 

the new password to the consumer email address.
4. Click Close.

Figure 5 - 2  Customer Accounts Login Screen
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To add a login:

1. In Web Admin, select Customer Accounts > Login Management.
2. Click Add Login. The Add Customer Login screen appears.

3. Enter the consumer email address.
4. Type a password for the consumer login, and retype the password.
5. Type a security question.
6. Type a security answer.
7. Click Save.

To delete a login:

1. In Web Admin, select Customers Accounts > Login Management.
2. Select the consumer login account.
3. Click Delete Login. The Delete Login Successful message appears and the system deletes the 

consumer login.
4. Click Close.

To export the login management data:

1. In Web Admin, select Customer Accounts > Login Management.
2. Click Export Grid. The system exports CustomerDetails.xls to your computer. The export con-

tains the following information:

• User name
• Email
• Comment
• Is approved
• Is locked out
• Last lockout date
• Creation date

Figure 5 - 3  Add Customer Login
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• Last login date
• Last activity date
• Last password changed date
• Is online (at the time of the export).

Working with Contact Reasons
Contact reasons allow your consumers to designate if they want you to contact them for any particu-
lar reason, such as information or promotional offers. Aloha Online Ordering displays the contact
reasons you create on the Contact Information page before the consumer gets to the Payment page
for anonymous orders, and on the Manage My Account page for registered consumer accounts. By
default, the system preselects reason codes, and the consumer must clear the option to opt out. 

To add a contact reason:

1. In Web Admin, select Customer Accounts > Contact Reasons.
2. Click Add Contact Reason.

3. Type the text for the contact reason. The system displays the text you enter here on your 
online ordering site.

4. Type a description for the contact reason. The description does not appear on your online 
ordering site.

5. Select Is Visible to activate the contact reason.
6. (Optional) Enter an external ID number. External systems may require this number as a ref-

erence.
7. Click Update.

To edit a contact reason:

1. In Web Admin, select Customer Accounts > Contact Reasons.
2. Select the contact reason you want to edit.
3. Click Edit Contact Reason.
4. Make the desired changes.
5. Click Update.

Figure 5 - 4  Contact Reason

Figure 5 - 5  Contact Reason Entry
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Working with Security Questions
Security questions enable you to present questions to a consumer for which they must provide an
answer to reset their password. You can add, edit, and delete security questions. 

To add a security question:

1. In Web Admin, select Customer Accounts > Security Questions.
2. Click Add Security Question. The Edit Security Question screen appears.
3. Type the security question you want your consumers to answer.
4. Click Update.

To edit or delete a security question:

1. In Web Admin, select Customer Accounts > Security Questions.
2. Click the security question to edit or delete.
3. Click Edit Security Question, make the necessary changes, and click Update.

-OR-

Click Delete Security Question to remove the security question.

Configuring reCAPTCHA 
reCAPTCHA is a free service from Google that helps protect websites from spam and user acccount
hacking by offering a set of image recognition tests to verify the user is human and not a robot (or
bot). Once the service verifies the user is a human and not a robot logging in to the Aloha Online
Ordering website, reCAPTCHA allows access. In addition to configuring reCAPTCHA in Web Admin,
you must also add the domain name to the reCAPTCHA console. 

Figure 5 - 6  reCaptcha Image Test
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To configure reCAPTCHA:

1. In Web Admin, select Configuration > Company Settings Setup. 
2. Select a set from the ‘Choose Settings Set’ drop-down list. 
3. Begin typing UseCaptcha until the setting appears and click Edit Setting. If it does not appear, 

click Add Setting. 
4. Verify or type UseCaptcha in ‘Setting.’ 
5. Type True in ‘Value.’ 
6. Click Update. 
7. Exit the Company Settings Setup function. 

To log into Aloha Online Ordering using reCAPTCHA:

1. Log into Aloha Online Ordering. The reCAPTCHA box appears above the ‘Sign in’ button. 
2. Click I’m not a robot. An image test appears. 
3. Complete the image test, as directed. Once verified, the system logs you into the Aloha 

Online Ordering site. 

About Order Management 
Order Management enables you to review online orders submitted by consumers. You can view all of
your consumer orders, or use the filter to search for consumer orders within a specific range. You can
also start a consumer order.

Working with Orders Review
Orders Review enables you to search for consumer orders, review them, and retrieve the status of a
POS order. You can filter the report results in a number of different ways. For example, you can filter
the order source by selecting ‘Web,’ ‘Mobile,’ or ‘MobileWeb’ to enable you to review the source of
online orders.You can also export data by pressing the export button on the bottom left side of the
screen.

Reviewing Consumer Orders
To review your orders, in Web Admin, select Order Management > Orders Review, and click Search.
The system displays the one hundred most recent orders.

The Orders Review screen contains a search filter on the left side of the screen. Select the desired fil-
ters for your search, and click Search. You can filter your search by any of the following:

• Consumer first name
• Consumer last name
• Consumer email address
• Consumer phone number
• The minimum amount of an order
• The maximum amount of an order

Figure 5 - 7  Orders Review Screen
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• All sites, or a specific site location
• The external ID
• The status of the order - Unordered, Validated, Submitted, PendingOperation, Deleted, or 

CreditProcessed
• The status of the site - NotAcceptingOrders, PreLive, PublicLive, or CallInOrdersOnly
• The source of the order - All sources, Web, Mobile, or MobileWeb
• The minimum order time
• The maximum order time
• The last modified minimum
• The last modified maximum
• The date of the order
• The level of detail for the order - Summary or Detail

The system returns search results to the right of the filter with the following information:

Retrieving the POS Status of an Order
If you are using Aloha Takeout, you can retrieve the POS status of an individual order as long as the
EnableGetOrder company setting is set to ‘true.’

Field Description

Location The store location for the order.
Order ID The online order number.
Customer The name of the consumer.
First Name The first name of the consumer.
Last Name The last name of the consumer.
Email The email address of the consumer.
Phone Number The phone number of the consumer.
Above Store Status The possible values include:

Deleted
Submitted
Validated
Unordered

POS Status The possible values include:
In Delay - Future order not yet released to the POS.
In Delay - Order not yet released to the POS - Error.
Timed Out - Order canceled once submitted to time out error.
Ready/Prepared - Order released to the POS.
N/A - Site not using ATO.

Available Time The available time for the order.
Payment The payment tender for the order, or Pay at Site.
Last Modified The last time of the consumer or an employee with call center 

operator access modified the order.
Total The total amount for the order.
Actions The option to modify or cancel a future order.
Operator The ability to view or start orders as a call center operator, or as a 

restaurant portal order.
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To enable the retrieval of the POS status:

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select EnableGetOrder.
3. Click Edit Setting.
4. Type true for the value.
5. Click Update.

To retrieve the POS status of an order:

1. In Web Admin, select Order Management > Orders Review.
2. Search for the order.
3. In the search results, click the Order Id of the order on the right side of the screen. The Order 

Details screen appears.

4. Click Get POS Status. The system updates the Order Details screen with the order status.

Starting a Consumer Order
You can also start a consumer order from the Order Management screen. Select Order Manage-
ment > Start Order. The system launches your online ordering site in a new browser window.

Figure 5 - 8  Order Details Screen
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Analytics and reports are essential in gauging the progress of your restaurant and determining the
success or failure of your business. In a corporation, reports provide an important link from the store
level to corporate. The Company Dashboard and Reports options enable you to review online order-
ing transaction data for your company, for specific site locations, and to identify your top consumers
and items for order.

Working with Company Dashboard
Company Dashboard enables you to view the data concerning your online ordering site and provides
you with information to help you evaluate the effectiveness of your online ordering site. For example,
if you see a high percentage of abandoned order attempts, you may want to review your menu setup. 

In Web Admin, access the Company Dashboard at Analytics > Company Dashboard.  

The Company Dashboard contains three sections: Key Statistics, Reports, and filter options. 

The options for the available dashboard reports, located at the top of the screen, include:

Figure 6 - 1  Company Dashboard

Report Description

Total Sales Displays the totals sales according to your filter selections.
Catering vs. Retail Displays a comparison between catering and retail according to your filter 

selections. Use the information to evaluate your sales by menu.
Delivery vs. Pickup Displays a comparison between pickup and delivery orders according to 

your filter selections. Use the information to evaluate your sales by order 
mode.

Top 10 Sites Displays the top 10 sites based on sales count according to your filter selec-
tions.

Key statistics
Available 
Dashboard 

Report filter 
options
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The key statistics, located on the left side of the screen, include the following:

The filter options, located at the bottom of the screen, include:

You can export the dashboard information by clicking Export. An export link appears on both Key Sta-
tistics and the filter options.

Working with Site Dashboard
Site Dashboard, similar to Company Dashboard, enables you to view sales information for a specific
site location. In Web Admin, access the Site Dashboard at Analytics > Site Dashboard, and select the
specific site from the ‘Choose Site’ drop-down list on the top left side of the screen.

The differences between Site Dashboard and Company Dashboard are:

• You cannot export data from Site Dashboard.
• Under Key Statistics, Site Dashboard includes the number of orders and total dollar amount 

for future day orders.

Column Description

Synchronization Details the date of the last design import, the last time you published the 
design, and the last time you saved the design.

Recent Activity Summarizes the total sales and the average sale for the previous day, 
current day, and all future orders.

Yesterday’s Orders Summarizes the following:
Start attempts
Successful starts
Abandoned
Browse only
Order errors
Completion attempts
Successful completions
Placement rate
Success rate

Filter Description

$ or # Filter the report by total online order sales, or by the total number of 
online orders

State Select a specific state by which to filter the report.
Store Select a specific store by which to filter the report.
Time frame Select a time frame by which to filter the report. Options include one day 

(1d), one week (1w), one month (1m), Month to date (mtd), three 
months (3m), six months (6m), and one year (1y). 
6 - 4 Accessing Customer Dashboard and Reports Aloha Online Ordering User Guide



 

Working with Reports
Reports enable you to identify your top consumers, consumers who have not ordered from you in
the last thirty days, and the top ordered items from your online ordering site. You can export the
report details to an Excel file format or to a .csv file.

Aloha Online Ordering includes four reports:

Top Customers

The Top Customers report lists your top 100 customers according to dollar amount spent. The report
includes the consumer information, the total amount of money spent online, the total number of
orders, and the average total per order. 

Top Customer Trends

Similar to the Top Customers report, the Top Customer Trends report breaks down the sales informa-
tion by last 90 and 30 days. 

No Orders in 30 Days

The No Orders in 30 Days report displays consumers who have not placed an online order within the
last thirty days. The report includes the first name, last name, email address, phone number, and
address of the consumer, and the last order the consumer placed. 

Top Items

The Top Items report displays the top items purchased through the web menu according to the total
amount sold. This report includes the design ID, sales item ID, item ID, item name, price, and total
number of items sold. 

Figure 6 - 2  Top Customers Report (Excel Format)

Figure 6 - 3  Top Customer Trends Report (Excel Format)

Figure 6 - 4  No Orders in 30 Days Report (Excel Format)

Figure 6 - 5  Top Items Report (Excel Format)
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To run a report: 

1. In Web Admin, select Analytics > Customer Reports.
2. Click the report you want to run from the list on the left side of the screen. The system dis-

plays the report.
3. (Optional) Under ‘Export Options,’ select the export format and click Export Grid.
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This chapter provides instructions concerning miscellaneous online ordering features, which you
may want to include as part of your online ordering site. These options include adding a special
instructions text box, adding a navigation safeguard, quick ordering, group ordering, First Data Val-
ueLink gift card integration, offering ASAP delivery for online orders, configuring loyalty for your
online ordering site, and configuring gift cards for online orders.

Adding a Special Instructions Text Box
You can add a special instructions text box to the modifier pop-up window to allow consumers to
add notes regarding an item. These notes print on the kitchen chit. You add the special instructions
text box by modifying Template.xml. 

Figure 7 - 1  Add Special Instructions
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1. In Web Admin, select Designs > Graphics and Content, and download Template.xml. Refer 
to “To download the current version of the graphic or element file in use on your online 
ordering web site:” on page 3-7 for more information.

2. Edit Template.xml using Notepad or another xml editor.

3. Locate <paged ID=”DEFAULT”>.
4. Enter <tab id=”SPECIALINSTRUCTIONS’ draw_mode=”section” /> after <tab id=”UPSELL” 

draw_mode=”section”/> and before </page>.
5. Save Template.xml.
6. In Web Admin, select Designs > Graphics and Content, and upload the edited Template.xml. 

Refer “To upload edited files to the Graphics and Content page:” on page 3-8 for more infor-
mation. 

7. Click Refresh Ordering Site.

Adding a Navigation Safeguard
Adding a navigation safeguard helps prevent your consumers from unknowingly navigating away
from your online ordering site before completing their order. When the consumer attempts to navi-
gate away from your online ordering site, the system displays a pop-up window and gives the con-

Figure 7 - 2  Template.xml
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sumer the option to stay on the page and complete their order, or to leave the page and not
complete their order. You control the feature through the LeavingVerifyPaymentPageAlert company
setting. 

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select the appropriate set from the ‘Choose Settings Set’ drop-down list.
3. Select LeavingVerifyPaymentPageAlert.
4. Click Edit Setting.
5. Type true to activate the feature, or type false to deactivate the feature. 
6. Click Update.

Figure 7 - 3  Navigation Safeguard
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Supporting Quick Ordering
Quick ordering enables consumers with an account to quickly repeat a favorite or past order. Quick
ordering assumes the consumer wants to place the order using the exact items and modifier selec-
tions of their favorite or past order without any other item additions, removals, or modifications.
Additionally, quick ordering assumes the consumer wants to use the same order mode. You enable
quick ordering through the AccountDashboardQuickOrdering company setting.

Quick ordering requires a consumer to have a registered account. When the consumer clicks Quick
Order, the system prompts the consumer to select a pickup or delivery time and their method of pay-
ment.  

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select the appropriate set from the ‘Choose Settings Set’ drop-down list.
3. Select AccountDashboardQuickOrdering.
4. Click Edit Setting.
5. Type True to activate quick ordering, and type False to deactivate quick ordering.
6. Click Update.

Figure 7 - 4  One Click Ordering
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Supporting Group Ordering
Group ordering enables a registered consumer, referred to as the Event Organizer, to create an order
and invite others to submit their order as part of one group order. The system sends an email mes-
sage to the invitees, who can then add their items for order to the ticket. When all invitees complete
their order, or the time limit set by the Event Organizer arrives, the Event Organizer submits the items
for order as one order with a single payment. A consumer can also create an address book to use on
their next order. 

Configuring Group Ordering
You enable group ordering by editing the AvailableOrderTypes company setting. Additionally, group
ordering adds two new graphic files, which you can customize:

• Page_grouporder_thankyou.png - Displays the thank you page for the invitee. The system 
uses the same image and dimensions as the page_thankyou.png.

• background_ordertypeXsection.png - You can place images behind both the standard and 
group order modes on the time.aspx page. The names of those files are: standard mode (first 
position) background_ordertype1section.png, and group order (second position) back-
ground_ordertype2section.png. 

To configure group ordering:

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select the appropriate set from the ‘Choose Settings Set’ drop-down list.
3. Select AvailableOrderTypes.
4. Click Edit Setting.
5. Add GroupByInvitation to the value with a semi-colon separating it and ‘standard,’ which the 

value already contains. The new value appears as ‘standard; GroupByInvitation.’
6. Click Update.
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Using Group Ordering
The consumer handles the details of a group order; however, they may require assistance or have
questions regarding the group ordering process.

Understanding the Flow of a Group Order
The following provides an overview of the flow of a group order:  

Figure 7 - 5  Flow of a Group Order
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1. The event organizer accesses your online ordering site, logs in, and selects Group Order By 
Invitation. The system displays the Group Order Details page.

When the group organizer chooses Group Order by Invitation and they are not logged in, the 
message, “You must be logged in to start a group order by invitation. Would you like to log in 
or create an account?” appears. If the group organizer clicks OK, the system directs them to 
the Sign In page. If the group organizer clicks No, the system treats the order as a standard 
order. 

2. The event organizer selects the following:

• The store location
• The target time for the order.
• The deadline for response by the invitees.
• The invitees for the group order.

3. The event organizer clicks Send Invites.

Figure 7 - 6  Group Order By Invitation

Figure 7 - 7  You Must Be Logged In to Start a Group Order by Invitation Message
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4. The system sends an email message to the invitees with details about the order and a link to 
start their order.

5. Each invitee clicks the link, selects their items for order, and clicks Submit.

6. The event organizer can review the group order at the Account Dashboard page to see which 
invittees have responded to the Group Order. 

Figure 7 - 8  Group Order Tracking
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7. The event organizer must build and complete the order for submission. Prior to building the 
order, the event organizer can send a reminder email message to the invitees. When the 
event organizer clicks Build Order, the invitees can no longer edit or submit items for order.  

8. The event organizer can review the items for order, add or remove items, and then click 
Checkout. The system lists the items and identifies the person ordering the item.

Creating a Group Address Book
A consumer can create an address book for group ordering for online orders. A consumer can create
the address book at the customer profile page or on the group order details page.

Figure 7 - 9  Group Order
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To create an address book at the customer profile page:

1. The consumer logs in to their online ordering account.
2. The consumer selects My Account > My Profile. The Group Order Address Book appears at 

the bottom of the page.

3. The consumer types the name and email address of the person and clicks Add.
4. Repeat for each additional person to add to the address book.
5. The consumer clicks Update.

To create an address book while creating an order:

1. The consumer must first start a group order.
2. At the Invite Others page, the consumer clicks Open Address Book.

3. The consumer types the name and email address of the person and clicks Add.
4. The consumer clicks Save to the right of the name and address of the person to add them to 

the address book.

Figure 7 - 10  Group Order Address Book Page

To delete a name from the address book, the consumer selects the name and the red ‘X’ to 
the right of the name. To edit a name, the consumer selects a name and the pencil icon to 
the right of the name. Make the necessary changes and click Update. 

Figure 7 - 11  Invite Others Page
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Working with Call Center Ordering
The Call Center Ordering feature within Aloha Online Ordering allows a user with the Call Center
Operator role to place orders on behalf of consumer. This features applies to restaurants that use
third party call center operators, or that operate their own internal order desk. 

Working with Gift Cards
For restaurants offering gift cards to their consumers, Aloha Online Ordering supports the accep-
tance of Aloha Stored Value and FirstData ValueLink cards as payment for online orders. Additionally,
Aloha Online Ordering allows consumers to query their gift card balance on the Account Dashboard
page, and the system includes any remaining gift card balance on order receipts and order confirma-
tion email messages.

Configuring Basic Requirements for Gift Cards
You can configure gift cards for use with Aloha Online Ordering. Use Web Admin to enable gift cards
to allow a consumer to use a gift card as payment for an online order. You must also create a prepaid
tender in the Aloha POS and map the prepaid tender in Aloha Takeout.

Enabling a Prepaid Tender in the Aloha POS
You must create a prepaid tender for the Aloha POS, and you must set the tender as ‘Active.’ After you
create the tender, you can then map it to Aloha Takeout. 

1. In CFC or Aloha Manager, select Maintenance > Payments > Tenders > Tenders tab.
2. Click the New drop-down arrow, select Generic as the tender type, and click OK.
3. Under the ‘Settings’ group bar, type a name to easily identify this as the gift card prepaid ten-

der for Aloha Online Ordering.
4. Select Active.
5. Click Save and exit the Tenders function.
6. Refresh the data.

Mapping the Prepaid Tender in Aloha Takeout
You must associate the prepaid tender you created for the Aloha POS with Aloha Takeout. 

1. In CFC or Aloha Manager, select the Aloha Takeout icon.
2. Select Maintenance > Takeout Configuration > Takeout Settings > Tenders tab.
3. Click the Add drop-down arrow, select an Aloha Takeout tender type, and click OK.
4. Select the POS tender you created from the ‘Tender ID’ drop-down list.
5. Click Save and exit the Tenders function.
6. Refresh the data.  

Refer to the NCR Aloha Online Ordering Call Centering Ordering Feature Focus Guide for 
more information.

Refer to the NCR Aloha Takeout Implementation Guide for more information.
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Enabling Gift Cards in Web Admin
Once you configure the prepaid tender for the Aloha POS and associate the prepaid tender to Aloha
Takeout, you can configure gift cards for online ordering in Web Admin. To enable gift cards in Web
Admin, you must:

• Contact the Aloha Online Ordering team to confirm the Default Payments Enterprise Id. Your 
Aloha Gift Card Enterprise Id contained in Aloha Insight must match the Default Payments 
Enterprise Id in Web Admin.

• Configure the Site External Id in Web Admin for each site location to match the Id used to 
identify the specific site Id in Aloha Insight. Refer to “Adding a Site Location” on page 1-14 for 
more information on editing a site location in Web Admin.

• Set the GiftCardEntryVisible company setting to true.

Configuring Aloha Stored Value Gift Card Integration
Supporting Aloha Stored Value gift cards involves three different modules. You must perform the fol-
lowing:

Aloha POS

• Ensure you configure the Aloha POS with all the pre-requisite for supporting Aloha Loyalty 
transactions. 

• Ensure you configure and map the loyalty comps and promotions to the loyalty bonus plans 
configured in Aloha Enterprise/Loyalty. 

Aloha Enterprise 

• Ensure you have an Enterprise account. You must access Support@alohaenterprise.com and 
request the Aloha Stored Value Web Services application is added to the company database. 

• Ensure you configure your user accounts, and the requirements for your site setup, loyalty 
cards, bonus plans, and rewards. 

If you need to be given partial access to certain web service methods, the company can grant or deny
access to each of the methods independently. This does not include the CheckServices method since
it is a system live check. 

To security access for individual web service methods:

1. Sign into the Aloha Enterprise portal. 
2. Click System Setup. 
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3. Click Security Class Setup. 

4. Select FullAccess from ‘Security Class Name’ and click Edit. The Edit FullAccess Security Class 
screen appears. 

Figure 7 - 12  Full Access Security Class

Figure 7 - 13  Edit Full Access Security Class Screen
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5. Under the ‘Access Allowed’ group box, select Applications. The Assign Applications to FullAc-
cess screen appears. 

6. Select Aloha Stored Value Web Services from the ‘Unassigned Applications’ list box and click 
> to move it to the ‘Assigned Applications’ list box. 

7. Click Save to return to the Edit FullAccess Security Class screen. 
8. Click Security Rights. The Assign Rights to Security Class FullAccess screen appears. 

Figure 7 - 14  Assign Applications to FullAccess Screen

Figure 7 - 15  Assign Rights to Security Class FullAccess Screen
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9. Select Aloha Stored Value Web Service from the ‘Applications’ drop-down list. 

10. Assign and unassign rights for each Stored Value function, as necessary. 
11. Click Save to return to the Edit FullAccess Security Class screen. 
12. Click Save. 

Aloha Online WebAdmin

After you create the Security Class, you must configure a new user in the Aloha Enterprise website.
The user name and password properties associated with the user is used in the request. Note: The
‘Force users to change their password every x days’ option for the security class is not enforced by the
Aloha Stored Value web service; however, in the event you modify the password, you need to update
your request attribute to contain the new value. 

Ensure you contact the Online Ordering support team at support@alohaenterprise.com for the fol-
lowing settings:

• The loyalty processor. The Online Ordering support team configures this. 
• Aloha Enterprise company ID
• Aloha Enterprise username
• Aloha Enterprise password

Configuring First Data ValueLink Gift Card Integration
For restaurants offering First Data ValueLink gift cards to their consumers, Aloha Online Ordering
supports the acceptance of these cards as payment for online orders. Additionally, Aloha Online
Ordering allows consumers to query their gift card balance on the Account Dashboard page, and the
system includes any remaining gift card balance on order receipts and order confirmation email mes-
sages. 

Figure 7 - 16  Assign and Unassign Rights
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Prior to enabling this feature, obtain the following from First Data: your merchant ID, terminal ID,
DataWire ID, Service ID, and Application ID. Once you receive this information, contact the Aloha
Online Ordering team at support@alohaenterprise.com for assistance in completing the configura-
tion for your company in Web Admin.

If necessary, you can override site specific settings for a site location in Site Settings.

To configure site specific settings for the First Data ValueLink integration:

1. In Web Admin, select Configuration > Site Setup > Sites.
2. Select the store location.
3. Click Edit Site.
4. Select the Site Settings tab.

5. Type the Terminal Id to override the Terminal Id established at the company level.
6. Type the Merchant Id to override the Merchant Id established at the company level.
7. Type the DataWire Id to override the DataWire Id established at the company level.
8. Click Update and exit Site Settings.

Offering ASAP Delivery for Online Orders
You may be able to prepare and deliver food faster than the first available time listed on your online
ordering site. ASAP delivery allows you to provide your consumers the option of receiving their food
earlier than the first available listed time. If the consumer does not select the first available listed
time, the system does not prompt the consumer with the option for accepting an earlier delivery.

You control this feature through the EnableASAPDelivery company setting. By default, the system
sets the value to false. 

The feature includes three messages, which you can customize. The three messages are:

• WebOrder.Time.ASAPDeliveryQuestion - Displays a prompt to the consumer with the 
option to receive their order before their selected time. The prompt appears on the 
Time.aspx page, and on the AccountDashboard.aspx page when using Quick Ordering. For 

Figure 7 - 17  Site Settings
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example, the consumer selects the first available time of 8:45 a.m. The system prompts the 
consumer with the following question, ‘Would you accept delivery before 8.45 a.m.?’

• WebOrder.Time.ASAPTimeSuffix - Appends the message time from ‘8:45 a.m.’ to ‘or sooner’ 
to the online ordering quote time.

• WebOrder.Order.ASAPOrderNotesMessage - Adds the message ‘Customer accepts sooner 
delivery’ to the order notes sent to the kitchen notifying them they must prepare and deliver 
the order as soon as possible. 

To configure the EnableASAPDelivery company setting:

1. In Web Admin, select Configuration > Company Settings Setup.
2. Select the appropriate set from the ‘Choose Settings Set’ drop-down list.
3. Select EnableASAPDelivery.
4. Click Edit Setting.
5. Type true.
6. Click Update.

Configuring Loyalty for Online Ordering
You can allow a consumer to add their loyalty program number to submit with their order to accumu-
late loyalty points; however, a consumer can only redeem loyalty rewards at the store location. You
can also add a loyalty lookup option to your online ordering site to enable consumer to search for
their loyalty account number. 

Aloha Online Ordering currently only supports Aloha Loyalty. Prior to enabling Aloha Loyalty for your
online ordering site, you must configure your loyalty program at Aloha Insight. In Web Admin, you
control the appearance of the loyalty options on your online ordering site through two company set-
tings, LoyaltyNumberVisible and ValidLoyaltyFields. Prior to configuring these company settings, con-
tact the Aloha Online Ordering team at support@alohaenterprise.com to enable loyalty functionality
for your online ordering site. 

The following table list the possible values for the loyalty company settings and the resulting appear-
ance on the online ordering site.  

Company Settings and Values 
Combination Online Ordering Site Appearance

LoyaltyNumberVisible = False
ValidLoyaltyFields = False

Does not display a loyalty text box or loyalty lookup button.

LoyaltyNumberVisible = True
ValidLoyaltyFields = False

Displays a loyalty text box, but does not display a loyalty 
lookup button.

LoyaltyNumberVisible = False
ValidLoyaltyFields = True

Does not display a loyalty text box or loyalty lookup button.

LoyaltyNumberVisible = True
ValidLoyaltyFields = True

Displays a loyalty text box and a loyalty lookup button.
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Displaying Caloric Information on Menus
In accordance to Section 4205 of the Patient Protection and Affordable Care Act (ACA), federal regula-
tions in the United States mandate that restaurants disclose the proper nutrition labeling to help con-
sumers make more informed food choices when dining out. The legislation requires restaurant
chains with 20 or more locations to post the calories for each standard menu item on menus, menu
boards, and drive-thru boards, as well as be able to provide more detailed nutritional information,
upon request. The act addresses the issues of obesity and chronic disease in Americans by raising
awareness of the calories consumed. In addition, establishments within the United States must also
provide a statement regarding calorie intake guidelines and any written or accessible nutrition infor-
mation available upon request. 

You can configure your menus to adhere to these regulations by displaying the count of calories for
each menu item, a legal caloric intake disclaimer, and access to any nutrition information. 

Passing the Payment Card Security Code 
To increase fraud protection, most card brands use a security validation code with a payment card,
such as a CVV (card validation value), which is typically a three-digit number on the back of the card.
Although CVV is used by Visa, the term is generally used by all card brands. You can maximize profits
and limit revenue loss from credit card payments by passing the security code to complete an online
order. You must enable the POS to accept the security code value in Maintenance > Payments > Ten-
ders > Security Verifications tab. 

To enable the passing of the payment card security code:

1. Select Configuration > Company Settings Setup. 
2. Type CVV in the ‘Setting’ text box until you find the ‘CVVEnabled’ value. 
3. Click Edit Setting. 

4. Type True in the ‘Value’ text box. 
5. Click Update. 

Refer to the FDA Food Menu Labeling Feature Focus Guide for complete information on dis-
playing caloric information on menus. 

Figure 7 - 18  CVVEnabled Setting
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When enabled, the Security Code option appears for a desktop user. 

The Security Code also appears for a mobile web user. 

Configuring Connected Payments with 
Aloha Online Ordering 
Connected Payments is a payment solution from NCR that ensures complete payment data security
and transmission protection, from PIN pad to payment processor, by inserting a token in place of
sensitive cardholder data. 

Configuring Aloha Online Ordering to support Connected Payments is a two-step process inside Web
Admin. In the first step, you enter the token provider account number and specify that the system
uses Connected Payments in Company Setup. 

Figure 7 - 19  Security Code on a Desktop Platform

Figure 7 - 20  Security Code on a Mobile Web Platform
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To configure Aloha Online to support Connected Payments:

1. In Web Admin, select Configuration > Company Setup. 
2. Click Edit Company to display the Edit Company screen.  

3. Type the account number provided to each merchant by Connected Payments in ‘TokenPro-
viderAccountNum.’

4. Select Connected Payments from the ‘TokenProviderType’ drop-down list. 
5. Click Save and Close to exit the screen. 

In the second step, you must configure the ‘UseTokenizedPayments’ setting, either at the company
level or the site level. Company settings control the configuration for all your site locations; however,
you can override these settings on a site-by-site basis in Site Settings Setup. You would configure the
setting by site, if you have tokenization enabled for the parent company but a particular site does not
support tokenization. 

To configure the system to use tokenized payments for the company:

1. Select Configuration > Company Settings Setup. 
2. Select a set to use from the ‘Choose Settings Set’ drop-down list. 
3. Begin typing in the ‘Setting’ text box until you find UseTokenizedPayments. 
4. Click Edit Setting. 

Figure 7 - 21  Edit Company Screen

Figure 7 - 22  Company Level - UseTokenizedPayments
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5. Type UseTokenizedPayments in ‘Setting.’
6. Type True in ‘Value.’
7. Click Update.

To configure the system to use tokenized payments for the site:

1. Select Configuration > Site Setup > Sites. 
2. Select the site from the list and click Edit Site. 

3. Type True in ‘Use Tokenized Payments.’
4. Click Update to exit the screen. 

Figure 7 - 23  Site Level - User Tokenized Payments
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Using Connected Payments with Online Ordering
When you enable Connected Payments and the guest pays with a credit card, they are presented with
an additional NCR Secure Payment screen. When the consumer fills out the information on the
screen, Connected Payments returns a token in place of the sensitive cardholder data. Then the con-
sumer completes the order as normal. 

As of AOO v17.2, the consumer can store the payment card data for one or more payment cards for
future use (saved card). This capability is available for both the Desktop and Mobile Web platforms. 

Integrating with Aloha Takeout
When using Aloha Takeout, the system sends the ‘Business name’ value to Aloha Takeout and popu-
lates the ‘Company’ option in the guest record of Aloha Takeout. Any associated information is
included. This feature is not supported with the Advanced Restaurant product. 

Address notes added to Aloha Takeout allows you to add any delivery instructions or details about
the delivery for an order. An API user can include the address notes in an API call. To do this, add the
‘AddressNotes’ parameter to the Put Calculate Tax and Total API call. 

Figure 7 - 24  NCR Secure Payment Screen
7 - 24 Configuring Other Online Ordering Features Aloha Online Ordering User Guide



 

Configuring Google Analytics
Google analytics lets you measure your advertising return on investment, as well as track your social
networking sites and applications. You can add Google Analytics tracking code to track the number of
visits to the Aloha Online Ordering website. Upon entering your code, it may take up to twenty-four
hours before your site data appears in your Google Analytics account. 

To configure Google Analytics tracking code:

1. In Web Admin, select Configuration > Company Settings Setup. 
2. Select a set from the ‘Choose Settings Set’ drop-down list. 
3. Begin typing GoogleAnalyticsTrackingCode until the setting appears and click Edit Setting. If 

it does not appear, click Add Setting. 
4. Type the tracking code in ‘Value.’ 
5. Click Update. 
6. Exit the Company Settings Setup function. 

It is also possible to provide access to Google Maps on your hosted Aloha Online Ordering website
for your consumer to use when searching for a store location using the default Google Maps API key.
Provide a Google Maps API key specific to your company to gain insight into the usage of the Google
Maps API by your consumers. 

To provide a company specific Google Maps API key:

1. In Web Admin, select Configuration > Company Settings Setup. 
2. Select a set from the ‘Choose Settings Set’ drop-down list. 
3. Click Add Setting. The Add Setting dialog box appears. 
4. Type GoogleMapsAPIKey in ‘Setting.’
5. Type the company specific key in ‘Value.’ 
6. Click Update. 
7. Exit the Company Settings Setup function. 

Supporting Item Availability Updates
The Item Availability feature provides a method for notifying employees and consumers of the cur-
rent quantity on hand or an item, preventing the ordering of an item on the menu that is currently
not available. As the item is sold, the available quantity decreases. When the quantity is completely
depleted, or set to unavailable, you cannot order the item. Conversely, you can set an unavailable
item as available. 

You can configure Aloha Online Ordering to receive item availability updates through Aloha Takeout
(ATO). To do this, you must integrate Aloha Takeout with the Omni-Channel Decision Support Plat-
form (ODSP). You must be on Aloha Takeout v17.1, or later. 

Refer to the Item Availability Feature Focus Guide for complete information on configuring 
and using the Item Availability function in the Aloha POS and/or Aloha Kitchen. 

Implement the instructions in the Configuring NCR Aloha Takeout to Use with ODSP Quick 
Reference Guide prior to the Aloha Online Ordering configuration. 
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In Web Admin, you must add the Enterprise Unit ID for the site. Once configured, any item that is fully
depleted or marked as unavailable in the POS does not appear for selection in the online menu.
When the item is marked as available, it reappears in the online menu. 

To add the Enterprise Unit ID in Web Admin:

1. In Web Admin, select Configuration > Site Setup > Sites. 
2. Select a site from the list and click Edit Site. The Edit Site screen appears. 
3. Select the Submission Details tab. 

4. Type the Enterprise Unit ID. This is the same unit ID you obtained when configuring ATO to 
integrate with ODSP. 

5. Click Update and exit the Edit Site screen. 

Supporting GDPR with Aloha Online 
Ordering
General Data Protection Regulation (GDPR) is an initiative to protect personal data an lays out rules
for organizations to follow when collecting and processing personal information. The focus of GDPR
primarily gives individuals control over the exposure of their personal data and they must give con-
sent to use it for marketing purposes. Although GDPR was initiated for the European Union, all global
applications must adhere to these regulations, regardless of the country in which they are developed. 

Figure 7 - 25  Edit Site - Submission Details Tab

Refer to the GDPR with Aloha Online Ordering Feature Focus Guide for information on con-
figuring and complying with the General Data Protection Regulation. 
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The following table lists the availab , the available values, and the default value,
if any. Pay special attention to the r  online ordering site to work properly. 

The table lists the company setting

If the setting is not availab

Setting Values

AccountCreationSubject  consumer Text value up to 199 charac-
ters. Example: Welcome to 
Aloha Online Ordering. 

AccountDashboardPreviousOrderCo umer to dis- Numeric value from 0 to 20. 
Default: 3

AccountDashboardQuickOrdering vorite or a 
actly’ to the 

True: Enables quick ordering.
False: Disables quick ordering. 
(Default)

AccountManagementDisplayName ated email Text value up to 199 charac-
ters. Example: Aloha Diner 
Management

AccountManagementEmailAddress

CompanA
le company settings, how they affect Aloha Online Ordering, their purpose
equired company settings, as it is necessary to edit those settings for your

s in alphabetical order.

Table 1: Available Company Settings. 

le, by default, you must use the Add Setting function. 

Related To Purpose

Account/Email Denotes the subject line for email message sent to
upon creation of an account.

unt Account Dashboard Specifies the number of historical orders of a cons
play on the Account Dashboard page.

Quick Ordering Enables a consumer to place an order saved as a fa
previous order with minimal clicks. Adds ‘Repeat Ex
account page.

Account/Email Displays as the ‘From’ name of automatically gener
messages sent to consumers with an account.

Account/Email

y Settings
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Acc o consumers Text value up to 199 charac-
ters. Example: ‘Here is Your 
Password Information’

Add
Adv True: Uses advanced landing 

page.
False: Uses standard landing 
page.

Allo on the online All: Displays ‘Pay at Site’ and 
‘Pay Online’ options. (Default)
Pickup: Displays only ‘Pay at 
Site.’
Online: Displays only ‘Pay 
Online.’

Allo o a different True: Allows menu change.
False: Does not allow menu 
change. (Default)

Allo u. You must 
ent card. 

Default: Visa;Master-
card;Amex;Discover

Allo True: Displays the extension 
option. (Default) 
False: Does not display the 
extension option.

And
App
App
App
Ass  at the site or 

ASVAtSite’ to 
d the ASV gift 

age ‘Amount 
t is processed 
ltyAndASVAt-
ubmit an 

True
False

Set Values
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ountPasswordResetSubject Password/Email Denotes the subject line for email messages sent t
who click Forgot Password.

DepositTimeout Deposits
ancedLandingPage Enables the Advanced Landing page.

wedPaymentLocations Payments Specifies the accepted payment options to appear 
ordering page.

wMenuChange Menu Changes Allows a consumer with an active order to switch t
menu, if you use multiple menus.

wedPaymentMethods Payments Specifies the tenders available on your online men
use the format xxxx; and list each supported paym

wPhoneExtension Consumer Record Displays the telephone extension option.

roidAPPURL Android Specifies the URL address for an Android app. 
lyTaxToDeliveryFee Delivery
URL
Version

ignLoyaltyAndASVAtSite Loyalty Establishes whether you access stored loyalty data
use cloud storage. When you set ‘AssignLoyaltyAnd
True (meaning processing is performed in store), an
card covers the full amount of the order, the mess
Due will be deducted from Gift Card when paymen
at the Site’ appears. When you set both ‘AssignLoya
Site’ and ‘EnableATODeposits’ to True, you cannot s
order. 

ting Related To Purpose
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Aut PI. Related 
 from the Get 
t set 
oApply-

True
False

Ava  page. Standard: Displays standard 
pick-up and delivery orders. 
(Default)
GroupByName: Allows a con-
sumer to place an order under 
a certain name.
GroupByInvitation: Allows 
for Group Orders by Invitation.
Note: You can apply all set-
tings by separating each set-
ting by a semicolon. Example: 
‘Standard;GroupBy-
Name;GroupByInvitation’ The 
order in which you enter the 
values determines the order in 
which they appear on the 
online ordering site.

Bro
Bro ha Online 

m.
Numeric value from 1 to 30. 
Default: 7.

Buf ens at which 
.

Numeric value from 0 to 1440. 
Default: 30

Buf oses at which Numeric value from 0 to 1440. 
Default: 60

Cac
Che

Set Values
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oApplyWholeDayPriceChanges Price Changes This setting is currently only for the Aloha Online A
Options: Filtering price changes in effect for all day
Menu call requires two company settings. you mus
‘UseItemPriceCompatabilityMode’ to False and ‘Aut
WholeDayPriceChanges’ to True. 

ilableOrderTypes Group Ordering Allows different order types to appear on the Time

wseMenuMode
wserCacheExpirationDays Defines the number of days the system retains Alo

Ordering cookies before automatically purging the
ferAM Hours Specifies the number of minutes after the store op

the online ordering site can begin accepting orders
ferPM Hours Specifies the number of minutes before the store cl

the online ordering site stops accepting orders.
heExpirationHours Hours
ckInUseAutoTender

ting Related To Purpose
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Col with the mod-
tions to 
nd contents 

True: Collapsed view. The con-
sumer must click a modifier 
group to expand and select a 
modifier.
False: Expanded view.All mod-
ifier groups and associated 
modifiers appear for editing. 
(Default)

Com When you 
owser.

Example: http://alohad-
iner.com

Com
Con t to the email Text value up to 199 charac-

ters. Default: Aloha Online 
Ordering Customer Feedback

Con ds feedback Example: manager@alohad-
iner.com

Con  bar. When 
b browser. 
ontact.html 

Your web site Contact Us page 
URL. Example: http://alohad-
iner.com/contact

Con ing site con- Numeric value from 1 to 1440. 
Default: 300. 

Cre
pre
Cre
Cre
Cre
Cre
Cre

Set Values
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lapseModifierGroups Order Entry Specifies whether the modifier dialog box appears 
ifier options list. Note: Use Modifier group descrip
enable the consumer to understand the purpose a
of the modifier group.

panyURL Localization Adds the URL as a home link in the navigation bar. 
click this link, the web page opens in a new web br

panyURLPart
tactUsEmailSubject Email Denotes the subject line of the email message sen

address listed in ContactUsSentToEmailAddress.

tactUsSendToEmailAddress Email Denotes the email address to which the system sen
email messages. 

tactUsURL Support Adds the URL as a Contact Us link in the navigation
you click this link, the web page opens in a new we
Note: You can create a Contact Us page using the c
file or the Aloha Online standard form.

tentCacheCheckDelay Specifies the amount of time (in seconds) for receiv
tent updates from the web server.

ditServiceTenderNameAmericanEx-
ss
ditServiceTenderNameCreditGeneric
ditServiceTenderNameDiscover
ditServiceTenderNameJCB
ditServiceTenderNameMasterCard
ditServiceTenderNameVisa

ting Related To Purpose
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Cult  ordering site. 
ing a lan-

itional modifi-

de-DE: Germany
en-US: English (Default) 
es-MX: Mexican Spanish
es-PA: Panamian Spanish
es-CO: Colombian Spanish
es-CL: Chile Spanish
es-EC: Ecuador Spanish
es-SV: El Salvador Spanish
es-GT: Guatemala Spanish
en-PR: Puerto Rico English
en-GB: Great Britain English
en-CA: Canadian English
en-AU: Australian English
es-ES: Spain Spanish
pt-BR: Brazilian Portuguese
pt-PT: Portugal Portuguese

Cus e consumer Required: You must complete 
the business and department 
boxes to submit an order.
Optional: Displays the busi-
ness and department boxes, 
but does not require the con-
sumer to complete them to 
submit an order. (Default)
Disabled: Does not display 
the business and department 
boxes.

CVV
Def  site displays 

ccess the 
Setup. Con-
 creating mul-

The auto-generated number 
when creating multiple 
designs.

Def

Set Values
a Online Ordering User Guide 

ure Languages Defines the language text to display on your online
These values are case-sensitive. Note: When choos
guage other than English, the system requires add
cations. Contact support@alohaenterprise.com.

tomerBusinessFields Order Entry Displays the business and department boxes for th
to complete to submit an order. 

Enabled
aultDesignID Menu Specifies which web site design the online ordering

before a consumer selects a specific store. Note: A
design identification numbers in Designs > Design 
tact the Aloha Online Implementation Team before
tiple designs.

aultMenuID Menu
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Del m holds an 
r ATO depos-

his setting 
are visible.

Numeric value from 1 to 60. If 
you set the value to 0, all 
orders are future orders 
(required for ATO deposits). 
Default: 15

Del or the first 
calculate in 

Any whole number. Default: 
0. 

Del livery quote 
 the con-
ess) elapses 
ion appears 
 to continue 
quate time to 
en accessing 
 ordering 

NextAvailableRange: Time 
based on the next available 
increment only if the next 
available time from the site 
exceeds the delivery range. 
Note: You must set Delivery-
TimeAsRange as ‘true’ to acti-
vate this feature. 
NextAvailableSlot: Time 
based on the next available 
increment of time according to 
the DeliveryTimeGranularity 
variable. (Default)
NextAvailableTime: Time 
based on the new order prep 
time from the site plus an 
additional five minutes.

Del h the con- Numeric values of 15, 20, 25, 
30, 35, 40, 45, 50, 55, or 60. 
Example: For 20, the pick-up 
options appear as 2:00, 2:20, 
2:40.

Del  time as a 

eGranularity 
 a range of 

True: Displays quoted deliv-
ery time as a range of time.
False: Displays quoted deliv-
ery time as an exact time. 
(Default)

Set Values
a Online Ordering User Guide 

ayedOrderThresholdMinutes Deposits Specifies the amount of time (in minutes) the syste
order based on the promise time and is required fo
its. The value must match the on-site prep times. T
also determines the amount of time future orders 

iveryLeadTimeHours Delivery Specifies the exact number of hours in the future f
available order time for delivery orders. The hours 
exact calendar hours from the current time. 

iveryTimeExceededBehavior Delivery Specifies the calculation to use for updating the de
time when the initial order quote time (provided to
sumer at the beginning of the online ordering proc
before the consumer submits the order. A notificat
to the consumer, which the consumer must accept
with the order. This allows the kitchen to have ade
prepare the order, despite the lapse in time betwe
the menu and placing the order through the online
page.

iveryTimeGranularity Delivery Specifies the increment of time (in minutes) in whic
sumer order delivery time options appear.

iveryTimesAsRange Delivery Determines whether to display the quoted delivery
range of time.
Example: If the value is set to ‘true,’ and DeliveryTim
is set to ‘30,’ the consumer sees the delivery time in
time, such as 12:00-12:30 and 12:30-1:00.
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Disa e version of 
t this option 

mmands, and 

True: Disables advanced set-
tings (Default)
False: Enables advanced set-
tings

Disa dvanced True: Does not display the 
delivery option.
False: Displays the delivery 
option. (Default)

Ena ry order ear- True: Activates ASAP delivery.
False: Disables ASAP delivery. 
(Default)

Ena he consumer 
s not require 

uired modifi-

True: Displays the ‘Order As Is’ 
button.
False: Does not display ‘Order 
As Is’ button. (Default)

Ena e of order 
ent card, a 
another form 
nfiguration of 
1

True: Enables instant authori-
zation.
False: Disables instant autho-
rization. (Default)

Ena
Ena r creates a 

hen they cre-
rotection Reg-

True: Enables GDPR function-
ality.
False: Does not enable GDPR 
functionality. (Default)

Ena r submission 
sk to retrieve 

ation in Web 
s include: ‘In 
rder not 
d once sub-
’ (order 

True: Provides an order sta-
tus in Orders Review.
False: Does not provide an 
order status in Orders Review. 
(Default)

Set Values
a Online Ordering User Guide 

bleAdvancedCommands Controls the activation of features depending on th
Aloha Takeout. If you use ATO v14.1, and higher, se
to False, meaning you want to enable advanced co
use ATO Capacity and ATO deposits. 

bleDeliveryLanding Delivery Controls the display of the delivery option on the A
Landing page.

bleASAPOnDelivery Delivery Offers consumers the option to receive their delive
lier than the first available time listed.

bleAsIsOrdering Order Entry Adds ‘Order As Is’ on the web menu item allowing t
to skip the modifier pop-up window if the item doe
any modifier groups. Note: If an item contains req
ers, the ‘Order As Is’ button does not appear.

bleATODeposits Deposits Charges a debit or credit card transaction at the tim
submittal. If a merchant processor declines a paym
notification appears to the consumer and requires 
of payment. This feature may require additional co
ATO and the Aloha POS. Note: Requires ATO v14.1.

bleFacebookLogin
bleGDPR GDPR Makes the privacy policy available when a consume

new account. The consumer agrees to the terms w
ate their account. This is part of the General Data P
ulation (GDPR) requirements. 

bleGetOrder Order submission Adds the ability to check the status of an order afte
by the consumer. Aloha Online uses a scheduled ta
the information from the POS and post the inform
Admin under ‘Orders Review.’ The possible statuse
Delay’ (future order not yet released to POS), ‘??’ (o
released to POS- Error), ‘Timed Out’ (order cancele
mitted due to time out error), and ‘Ready/Prepared
released to POS).
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Ena . Note: This 
here you con-

True: Enables the PayPal pay-
ment option.
False: Disables the PayPal pay-
ment option. (Default)

Ena  bypasses the True: Bypasses the store loca-
tor page.
False: Does not bypass the 
store locator page. (Default)

Ena
grat
Enh vanced Pizza 

 Pizza 
 Table Service 

True: Enables the use of 
Advanced Pizza.
False: Enables the use of Basic 
Pizza. (Default)

FAQ h the naviga- True: Displays an FAQ tav.
False: Does not display an 
FAQ tab. (Default)

Fax  allows for an True: Enables fax failover.
False: Disables fax failover. 
(Default)

Fax ail based fax Example: fax@alohad-
iner.com

Fax Example: somefaxdo-
main.com

Fee
Gift for payment. 

Value (ASV) 
True: Displays the gift card 
entry option.
False: Does not display the gift 
card entry option. (Default)

Goo ided to Goo-
t may take up 
 in your Goo-

Your Google Analytics code 
snippet, ‘xx-xxxx.’

Set Values
a Online Ordering User Guide 

blePayPalHere PayPal Adds the ability to add PayPal as a payment option
setting adds the PayPal tab to the Sites function, w
figure the PayPal settings for the site location.

bleSingleSiteFlow Store Locator Specifies if a consumer on the online ordering page
store locator when there is only one store location.

bleTimeZonePrepTimeForInte-
edSubmit

Order Submission

ancedPizza Pizza Determines if you use the pizza configuration for Ad
or Basic Pizza, for your web menu. Note: Advanced
requires Aloha Quick Service v6.7 or later, or Aloha
v12.3, or later. 

Enabled Order Entry Allows the consumer to access an FAQ page throug
tion bar of the online ordering site.

FailoverAllowed Fax failover Defines whether to enable fax failover. Fax failover
order to be submitted by fax if the store is offline.

FailoverOriginationAddress Fax failover Specifies the ‘from’ email address to use for an em
service.

FailoverServiceEmailDomain Fax failover Specifies the domain address of the fax service.

dbackButton Feedback
CardEntryVisible Gift Cards Activates the Gift Card (Aloha Stored Value) option 

Aloha Online Ordering only supports Aloha Stored 
cards with PIN numbers for online ordering. 

gleAnalyticsTrackingCode Google Analytics Tracks usage statistics using the code snippet prov
gle Analytics customers. Upon entering your code, i
to twenty-four hours before your site data appears
gle Analytics account.
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Goo pany so that 
aps API by 

True
False

Gro t off and the 
es from plac-

tted to the 
 compile all 

Any whole number

Gro r inclusion in Numeric value from 2 to 100. 
Default: 10.

Gro ) required by 
er is ready for 

Any whole number. Default: 
60. 

Hid ear on the True: Displays the delivery 
zones.
False: Does not display the 
delivery zones. (Default)

Hid nd in the con- True: Hides the tax options.
False: Does not hide the tax 
options. (False)

Hos g site should 
cessor, when 
loha POS. 

s to the con-
nough so the 
b site times 

Numeric value from 1 to 
99999. Default: 30.

Imp Default: import@alohaor-
deronline.com

Imp
Imp

Set Values
a Online Ordering User Guide 

gleMapsAPIKey Google Analytics Provides a Google Maps API key specific to your com
you can gain insight into the usage of the Google M
your customers. 

upOrderInviteeCutoffMinutes Group Ordering Defines the time in minutes between the invitee cu
order placement cutoff. This setting prevents invite
ing an order after the group order has been submi
store. This setting also allows the organizer time to
orders before submitting them to the store.

upOrderMaxParticipantLimit Group Ordering Defines the maximum number of people eligible fo
a group order.

upOrderPlacementCutoff Group Ordering Specifies the minimum amount of time (in minutes
the store before an order submitted by the organiz
pick-up or delivery.

eDeliveryZones Delivery Specifies whether the polygonal delivery zones app
store locator page.

eTax Email Suppresses the tax options on the ordering page a
firmation email messages. 

tedCreditTimeoutSeconds Order submission Specifies the number of seconds the online orderin
wait for approval from the third party merchant pro
capturing payment upon order submission to the A
When the site times out, an error message appear
sumer. Recommendation: Keep the setting large e
card does not get charged at the same time the we
out.

ortEmailAddress Imports

ortNotificationRecipient Imports
ortStatusEmail Imports
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Incl
mu

 the check 
tal is equal to 
ed to qualify 
ld still pass 
 required 

ly discounts. 
 Site Setup > 

nimum dollar 
elivery in 
iscountIn-

 ‘ValidateMin-

True
False

iPho
iPho
IsUp
Item
Key  to expire the 

d Payments. 
wise 

Numeric value. Default: 90. 

Key iration of the Numeric value. Default: 2.

Lan
lUR

onsumer “/” - Remain on landing page.
“/AccountDashboard.aspx” - 
Go to the Account Dashboard 
page. (Default)
“/AccountInfo.aspx” - Go to 
the Manage Account page.

Lea umer 
ication page 

True: Enables the pop-up noti-
fication.
False: Disables the pop-up 
notification. (Default)

Loc our online 
 you are not 
tionality.

A valid URL address.

Set Values
a Online Ordering User Guide 

udeDiscountinSubtotalDeliveryMini-
mValidation

Validates the check subtotal against the amount of
after you apply discounts to determine if one subto
or greater than the minimum dollar amount requir
for a delivery order. If False, the check subtotal cou
validation even if the check subtotal dips below the
minimum dollar amount for delivery after you app
Required Options: You must access Configuration >
Sites > Edit Site > Site Settings tab and enter the mi
amount a consumer must purchase to qualify for d
‘Delivery Minimum.’ Related Options: The ‘IncludeD
SubtotalDeliveryMinimumValidation’ overrides the
MaxBySubtotal’ option. 

neAppURL iPhone Specifies the URL address for an iPhone app.
neAppVersion iPhone
CheckEnabled
PriceGrid

DurationDays Connected Pay-
ments

Allows you to specify the number of days at which
public keys for processing payments with Connecte
Always accept the default value of 90, unless other
instructed. 

RefreshBeforeExpirationDays Connected Pay-
ments

Allows you to specify the number of days to the exp
public keys to begin requesting new keys. 

dingPageAccountLoginSuccessfu-
L

Order Entry Controls the page to which the system directs the c
after logging in at the Advanced Landing page.

vingVerifyPaymentPageAlert Order Entry Enables a pop-up notification to appear if the cons
attempts to navigate away from the Payment Verif
before submitting the order.

ationsURL Store Locator Displays the link to your store locator website on y
ordering site navigation bar. Use this setting only if
using the Aloha Online Ordering store locator func
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Log re selecting a Browse: Requires a consumer 
to log in. This value requires 
additional custom develop-
ment to enable. Contact the 
Aloha Online Implementation 
team. 
None: Does not require a con-
sumer to log in.

Loy ogram num-
ing only sup-
mers can 
er must 

True: Displays loyalty option.
False: Does not display loyalty 
option. (Default)

Loy
Loy
Max  can have in a 

or this setting 
Numeric value from 1 to 999. 
Default: 40

Max er can place Numeric value from 1 to 90. 
Default: 30.

Max mber of line 
for this set-

Numeric value from 0 to 999. 
Default: 40. 

Max e order. If a 
ts them to 

Numeric value from 1 to 
100000. Default: 50. 

Max ich you must Numeric value from 1 to 
100000. Default: 0.00. 

Max ine ordering 
d display the 

Numeric value from 1 to 5. 
Default: 2. 

Max  the online 
e from the 

Numeric value from 1 to 15. 
Default: 8. 

Max Numeric Value

Set Values
a Online Ordering User Guide 

inRequirement Logging In Indicates if the consumer is required to log in befo
specific store location.

altyNumberVisible Loyalty Enables a consumer to enter their Aloha Loyalty pr
ber to submit with their order. Aloha Online Order
ports Aloha Loyalty cards at this time. Note: Consu
accumulate points while online; however, a consum
redeem points in the store.

altyOrderModeID
altyRewardSelectionEnabled
LineItemQty Order Entry Limits the maximum number of items a consumer

single order. Required Options: The default value f
and MaxOrderLineCount must match.

OrderFutureDayCount Order Entry Specifies the number of days in advance a consum
an online order.

OrderLineCount Order Entry Limits the maximum order size, according to the nu
items in a transaction. Required: The default value 
ting and MaxLineItemQty must match.

OrderTotalAmount Order Entry Specifies the maximum amount allowed for a singl
consumer reaches this amount, the system promp
decrease the amount of their order.

PayAtSite Order Entry Specifies the maximum amount for an order to wh
pay with a payment card. 

PrepRetryCount Order submission Defines the maximum number of attempts the onl
site can make to the site to retrieve the prep time an
promise time to the consumer.

PrepRetryTime Order submission Specifies the maximum length of time (in seconds)
ordering site allows for the retrieval of the prep tim
site to display the promise time to the consumer.

SameDayOrderTotalAmount
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Max d for a user- Default: 60. 

Max ubmit an Numeric value from 1 to 5. 
Default: 2. 

Max line ordering 
ubmit Order.

Numeric value from 1 to 60. 
Default: 30. 

Men Default: 1. 
Men
Men re you can Numeric value from 0 to 90. 

Min  a delivery 
he amount to 

Numeric value from 1 to 
10000. Default: 0. 

Min  a takeout 
he amount to 

Numeric value from 0 to 
10000. Default: 0. 

Mob
Mob
Mob
Mob
Mob
Mob
Mob
Mob
Mob
Mob
Mob
Mob
Mob
Mob
Mob

Set Values
a Online Ordering User Guide 

SpecialInstructionsLength Order Entry Specifies the maximum length of characters allowe
defined special instruction. 

SubmitRetryCount Order submission Specifies the number of times you can attempt to s
order after you click Submit Order. 

SubmitRetryTime Order submission Specifies the maximum number of seconds the on
site allows for submitting an order after you click S

uAlign Order Entry
uDescriptions Order Entry
uLeadTimeDays Order Entry Specifies the minimum number of days in the futu

place an order. 
DeliveryOrderTotalAmount Delivery Specifies the minimum dollar amount required for

order before the system prompts you to increase t
qualify for a delivery order. 

OrderTotalAmount Order Entry Specifies the minimum dollar amount required for
order before the system prompts you to increase t
qualify for a takeout order. 

ileBrowseMenuDesignID Mobile
ileBrowseMenuMenuId Mobile
ileCacheExpirationHours Mobile
ileDestinationInstructions Mobile
ileFeedback Mobile
ileLoginDuration Mobile
ileMaxLineItemQuantity Mobile
ileMaxOrderLineCount Mobile
ileMaxOrderTotalAmount Mobile
ileMenuLeadTimeDays Mobile
ileMinOrderTotalAmount Mobile
ileOrderCancelEnabled Mobile
ileWebHasMenuItemPictures Mobile
ileWebHasSubMenuPictures Mobile
ileWebItemListDescriptions Mobile
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Mod o appear as 
tions. A mod-

default value 
entire menu. 
roup.

Numeric value from 1 to 99. 
Default: 99. 

Nav RL menu link Text value up to 199 charac-
ters. Example: Aloha Diner’s 
Fan Club.

Nav me that Example: http://www.alohad-
iner.com/fans

Nav vBar2URL Text value up to 199 charac-
ters. 

Nav me that Example: http://www.alohad-
iner.com/specials

Nav vBar3URL Text value up to 199 charac-
ters. 

Nav me that Example: http://www.alohad-
iner.com/events

Nut Patient Pro-
ust be able 

an item on 
nk to a 

Ord es for receiv-
ation email 
ne email 
esses.

Example: corporatehq@alo-
hadiner.com

Set Values
a Online Ordering User Guide 

ifierRadioButtonListMax Order Entry Enables modifier groups with required selections t
drop-down selections instead of radio button selec
ifier group with more modifier selections than the 
for this setting displays as a drop-down across the 
Note: You cannot apply this to only one modifier g

Bar1Name Navigation Bar Specifies the display name to use for the NavBar1U
in the main navigation bar.

Bar1URL Navigation Bar Specifies the URL to associate with the NavBar1Na
appears in the main navigation bar.

Bar2Name Navigation Bar Specifies the display name to associate with the Na
menu link in the main navigation bar.

Bar2URL Navigation Bar Specifies the URL to associate with the NavBar2Na
appears in the main navigation bar.

Bar3Name Navigation Bar Specifies the display name to associate with the Na
menu link in the main navigation bar.

Bar3URL Navigation Bar Specifies the URL to associate with the NavBar3Na
appears in the main navigation bar.

ritionInformationURL Calories Enables you to comply with Section 4205 of the 
tection and Affordable Care Act where a guest m
to view any additional nutrition information for 
your online menu, upon request. This can be a li
hosted site or an approved URL on the Internet.

erBCCList Email Defines the blind carbon copy (BCC) email address
ing copies of automatically generated order notific
messages sent to consumer. To enter more than o
address, type a semicolon between the email addr
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Ord otification 
sted in Order-
UPPORTED.

‘’ - All Order Types. (Default)
‘$<WholeDollar>’ - Only 
orders equal to or exceeding 
the specified whole dollar 
amount.
‘<WholeNumber>’ - Only 
orders equal to or exceeding 
the amount of time in advance 
of an order submittal.
‘FUTUREDAY’ - Only future 
orders.
‘RETAIL’ - Only retail orders.
‘CATERING’ - Only catering 
orders.

Ord
Ord an cancel or 

elivery or 
Numeric value from 0 to 
10000. You must define a 
value other than blank or 0 to 
use this feature. 

Ord d before you 
y scheduled 

Numeric value from 0 to 1440. 
Default: 0
You must define a value other 
than blank or 0 to use this fea-
ture. 

Ord ent when Text value from 0 to 199 char-
acters. Example: ‘Order Can-
cellation Request’

Ord
Ord ated email 

ngs.
Numeric value up to 199 char-
acters. Example: ‘Aloha Diner 
Online Ordering’

Ord
Ord  appears in 

 name with 
True: Displays the option.
False: Does not display the 
option. (Default)

Set Values
a Online Ordering User Guide 

erBCCTrigger Email Specifies the types of online orders that require a n
email message to be sent to the email addresses li
BCCList. Note: THIS FEATURE IS CURRENTLY NOT S

erCancelEnabled Order Entry
erCancelorModifyThresholdAmount Order Entry Specifies the maximum dollar amount before you c

modify the order prior to the originally scheduled d
pick-up time.

erCancelorModifyThresholdMinutes Order Entry Specifies the minimum number of minutes allowe
can cancel or modify an order prior to the originall
delivery or pick-up time.

erCancelReceiptSubject Email Designates the subject line for the email message s
canceling an online order.

erCTTTimeoutSeconds Order Entry
erDisplayName Order Entry Displays as the ‘From’ name of automatically gener

messages associated with OrderEmailAddressSetti

erEmailAddress Email
erEnterRecipientName Email Specifies whether the ‘Who is this item for?’ option

the modifier dialog box. The system associates the
the item on the kitchen chit.
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Ord
tion

ppears on 
215 or later.

True: Displays the option.
False: Does not display the 
option. (Default)

Ord tification 
ired by store 
ail address, 

Example: ordererror@alohod-
iner.com

Ord
Ord  consumers Numeric value up to 199 char-

acters. Example: ‘Thank You 
For Your Order.’

Ord g site waits 
ite times out, 

Numeric value from 1 to 
99999. Default: 30.

Ord der summary 
one email 
esses.

Ord line ordering Text value up to 199 charac-
ters. Example: ‘Aloha Diner 
Online Ordering’

Pick or the first 
alculate in 

Any whole number. Default: 0. 

Pick k-up quote 
 the con-
ess) elapses 
ion appears 
 to continue 
quate time to 
en accessing 
ordering 

NextAvailableSlot: Time 
based on the next available 
increment of time according to 
the PickUpTimeGranularity 
value. (Default) 
NextAvailableTime: Time 
based on the new order prep 
time from the site plus an 
additional five minutes.

Set Values
a Online Ordering User Guide 

erEnterTransactionSpecialInstruc-
s

Order Entry Specifies whether the ‘Special Instructions’ option a
the Verify Payment page. Note: Requires ATO v1.2.

erErrorNotificationRecipient Email Defines the ‘To’ email address for receiving error no
email messages when immediate response is requ
or support staff. Note: To enter more than one em
type a semicolon between the email addresses.

erErrorsLogEnabled Error Logging
erReceiptSubject Email Email subject line for email messages generated to

who successfully submit an online order.

erSubmissionTimeoutSeconds Order Submission Specifies the number of seconds the online orderin
before submitting an order to the POS. When the s
an error message appears to the consumer.

erSummaryNotificationRecipient Email Defines the ‘To’ email address for receiving daily or
report email messages. Note: To enter more than 
address, type a semicolon between the email addr

erWebsiteTitle Localization Displays as the browser window name for your on
site.

upLeadTimeHours Order Entry Specifies the exact number of hours in the future f
available order time for pickup orders. The hours c
exact calendar hours from the current time. 

UpTimeExceededBehavior Order Entry Specifies the calculation to use for updating the pic
time when the initial order quote time (provided to
sumer at the beginning of the online ordering proc
before the consumer submits the order. A notificat
to the consumer, which the consumer must accept
with the order. This allows the kitchen to have ade
prepare the order, despite the lapse in time betwe
the menu and placing he order through the online 
page.
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Pick or displaying Numeric values from 15, 20, 
25, 30, 35, 40, 45, 50, 55, or 60. 
For example, when the value is 
‘20,’ the pick-up options 
appears as every twenty min-
utes, 2:00, 2:20, 2:40.

Por
Por
Por
Priv eb page. The Your company privacy policy 

URL, or leave blank to default 
to the custom HTML file. The 
Aloha Online Ordering team 
can provide you with a blank 
HTML file for you to write your 
privacy policy, which you can 
then upload to the Graphics 
and Content section of Web 
Admin. Sites cannot go live 
with the generic Radiant pol-
icy.

QAM
Rec  items, as None: Does not allow for no-

charge or free substitutions. 
Standard: Uses POS data for 
substitution and applies the 
same rules and behaviors 
online.

Req ss to submit True: Requires the entry of an 
address to place an order.
False: Does not require the 
entry of an address to place an 
order. (Default)

Set Values
a Online Ordering User Guide 

UpTimeGranularity Order Entry Specifies the increment of time (in minutes) used f
the consumer order pick-up time options.

tionAssistantItemGridMin
tionAssistantMaxFedPercentage
tionAssistantNumGraphics
acyPolicyURL Specifies the URL for your company privacy policy w

privacy policy launches in a new window.

ode_Paytronix
ipeSubstitutionMode Order Entry Allows for no-charge substitutions on certain menu

determined by the POS data. 

uireCustomerAddressFields Order Entry Controls whether a consumer must enter an addre
an order.
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Rev
Pric

d revenue 
ue center IDs 

helpful for a 
oha Online 

Sec
Skip hen a menu 

n order.
True: Does not display the 
modifier pop-up window if the 
item does not have modifiers; 
immediately added to the 
receipt. (Default)
False: Displays the modifier 
pop-up window despite a lack 
of modifiers.

Soc t of the online 
rects the con-

Example: http://face-
book.com/AlohaDiner

Soc t of the online 
rects the con-

Example: http://face-
book.com/AlohaDiner

Soc ith an option Example: http://face-
book.com/AlohaDiner.

Soc r the con-
ds.

Example: http://face-
book.com/AlohaDiner

Soc e online Example: http://pinterest.com/
AlohaDiner

Soc line ordering Example: http://twitter.com/
#!?/AlohaDiner

Soc  page. Note: 
umer as a fol-

Example: http://twitter.com/
#!?/AlohaDiner

Soc e online 
he value from 

Text value. Example: I just 
ordered the best pizza from

Set Values
a Online Ordering User Guide 

enueCenterToIgnoreOnImportOf-
eChanges

Price Changes Allows you to ignore price changes from designate
centers during an import. You must enter the reven
to ignore, separated by commas. This is especially 
third party system that imports price changes in Al
Ordering. 

urityQuestionMode Logging In
PopupIfNoModidifiers Order Entry Determines whether the pop-up window appears w

item without associated modifiers is selected for a

ialMediaFacebookBadgeURL Social Media Links the Facebook button icon on the bottom righ
ordering page to your Fan page. Note: This only di
sumer to your Fan page.

ialMediaFacebookBadgeURL Social Media Links the Facebook button icon on the bottom righ
ordering page to your Fan page. Note: This only di
sumer to your Fan page.

ialMediaFacebookLikeURl Social Media Displays the ‘Like’ button on the check-out page, w
to post to Facebook.

ialMediaFacebookSendURL Social Media Displays the ‘Send’ button on the checkout page fo
sumer to send a link of your Fan page to their frien

ialMediaPinterestBadgeURL Social Media Links the Pinterest badge on the bottom right of th
ordering page to your pinterest page.

ialMediaTwitterBadgeURL Social Media Links the Twitter icon on the bottom right of the on
page to your Twitter page.

ialMediaTwitterFollowURL Social Media Displays the Twitter follow button on the checkout
This launches your Twitter page and adds the cons
lower.

ialMediaTwitterShareMessage Social Media Pre-composes a tweet for the consumer to share th
ordering URL with their followers, and then posts t
the SocialMediaTwitterShareURL variable.
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Soc osed share Example: http://twitter.com/
#!?/AlohaDiner

Star tore locator 
thin your 
er to make 
tering or 

ead of from 

If you are using the Advanced 
Landing page, you must set 
this value to ‘/’

Stor re location in 
.

True: Displays only the near-
est store location within the 
specified search range display.
False: Displays all store loca-
tions within the specified 
search range display, listing 
the locations from closest to 
farthest. (Default)

Stor store. The sys-
nce from the 

Numeric value from 0 to 
10000. Default: 25. 

Stor d as ‘Browse- True: Displays only Browse-
only store locations.
False: Does not display 
Browse-only store locations. 
(Default)

Stor cations, 
ing page, the 
y drop-down 

True: Displays the store loca-
tions on a map.
False: Displays the store loca-
tions as a list. (Default)

Stor  store for 
mers. When a 
 the specified 
plays first in 
 the closet 

Numeric value from 0 to 1000. 
Default: 0. 

Set Values
a Online Ordering User Guide 

ialMediaTwitterShareURL Social Media Inserts the consumer’s Twitter URL into a pre-comp
tweet.

tOrderURL Order Entry Redirects your online ordering site to an external s
when a consumer initiates an online order from wi
online ordering site. This setting forces the consum
determinations, such as delivery or takeout, and ca
retail, using the external store locator web site inst
within your online ordering site.

eLocatorAutoSelectBestDeliverySite Localization Determines whether to display only the nearest sto
store locator results, or additional locations as well

eLocatorDeliverySearchRange Localization Specifies the maximum delivery distance from the 
tem conducts the search range in straight-line dista
exact coordinates of the store location.

eLocatorDisplayBrowseOnlySites Localization Specifies whether or not to display locations define
only’ in store locator search results.

eLocatorEnabled Localization Determines the visual format for displaying store lo
either map or a list. When using the Advanced Land
system carries over the info entered on the Deliver
to the address options within Store Locator. 

eLocatorExclusiveRadius Localization Specifies the radial distance around each company
which the store provides exclusive service to consu
consumer enters an address in store locator within
radius of an exclusive store, the exclusive store dis
the search results, even if the exclusive store is not
store to the consumer.

ting Related To Purpose
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Stor w. Required 
 to use this 

ates from Site 
cation.

Degree, minutes, and seconds 
in decimal format. Default: 
37.89961413.

Stor ew. Required 
 to use this 

ates from Site 
cation.

Degree, minutes, and seconds 
in decimal format. Default: -
94.26722325. 

Stor ing store loca-
quired 
 to use this 

Numeric value from 1 to 16, 
where 1 represents the largest 
viewable area and 16 rep-
resents the smallest viewable 
area. Default: 3. 

Stor  in the store Numeric value from 0 to 10. 
Default: 10. 

Stor  view the 
 False if you 

True: Requires address entry.
False: Does not require 
address entry. (Default) 

Stor e consumer 
clude a store 

Numeric value from 0 to 
10000. Default: 25. 

Stor re locator fea-
er address 

True: Miles. (Default)
False: Kilometers.

Stor
eryS

s within the True: Displays non-exclusive 
delivery sites.
False: Does not display non-
exclusive delivery sites. 
(Default)

Stor
tan

ther than by True: Displays results by rank 
and then distance.
False: Does not display results 
by rank and then distance. 
(Default) 

Set Values
a Online Ordering User Guide 

eLocatorInitialViewLatitude Localization Defines the latitude position of the default map vie
Options: You must set StoreLocatorEnabled to True
feature. Related Options: You can copy the coordin
Set-Up > Sites to focus the map view on the store lo

eLocatorInitialViewLongitude Localization Define the longitude position of the default map vi
Options: You must set StoreLocatorEnabled to True
feature. Related Options: You can copy the coordin
Set-Up > Sites to focus the map view on the store lo

eLocatorInitialViewZoom Localization Specifies the default map viewable area for display
tion included in the store locator search results. Re
Options: You must set StoreLocatorEnabled to True
feature.

eLocatorMaxReturnCount Localization Defines the maximum number of stores to display
locator search results.

eLocatorRequiresAddress Localization Requires you to enter your address before you can
menu. Required Options: You must set this value to
use the Advanced Landing page. 

eLocatorSearchRange Localization Defines the maximum distance allowed between th
address and the store locations for the system to in
location in the store locator search results.

eLocatorSearchRangeInMiles Localization Specifies the type of measurement used by the sto
ture to calculate the distance between the consum
and the store.

eLocatorShowNonExclusiveDeliv-
ites

Localization Controls the inclusion of non-exclusive delivery site
store locator search results.

eLocatorSortByRankingThenDis-
ce

Localization Displays the store locations according to ranking ra
distance. 

ting Related To Purpose
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Sub u appears, as ‘’ - Default text does not 
appear. (Default)
‘BOTH’ - Default text appears.

Sup port email Example: support@alohad-
iner.com

Sup ated system 
ociated with 

Text value up to 199 charac-
ters. Example: ‘Aloha Diner 
Online’

Term  The Terms of Your Terms of Use URL, or 
leave blank to default to the 
custom HTML file. The Aloha 
Online Ordering team can pro-
vide you with a blank HTML 
file for you to write your terms 
of use, which you can then 
upload to the Graphics and 
Content section of Web 
Admin. Sites cannot go live 
with the generic Radiant pol-
icy.

TipE te: You must True: Displays tip entry area 
on the payment page.
False: Does not display tip 
entry area on the payment 
page. (Default) 

Use
Use when provid-

 page. 
True: Uses ATO to control 
capacity restrictions. 
False: Does not use ATO to 
control capacity restrictions. 
(Default) 

Use  Aloha Online True
False

Use
Use

Set Values
a Online Ordering User Guide 

MenuTitle Order Entry Defines whether the display name for the submen
configured in Menu Configurator.

portSupportEmailAddress Email Specifies the ‘From’ email address for a system sup
messages sent to the consumer.

portDisplayName Email Displays as the ‘From’ name of automatically gener
support email messages sent to the consumer. Ass
the SupportEmailAddress setting.

sOfUseURL Localization Specifies the URL for your Terms of Use web page.
Use page launches in a new browser window.

ntryVisible Tips Allows the consumer to add tips to their order. No
use ATO v1.2.215 or later.

AdvancedTenders Tenders
ATOCapacity Order Submission Enables Aloha Online to use ATO capacity settings 

ing the consumer with a promise time on the Time

Captcha Logging In Uses the reCAPTCHA service when logging in to the
Ordering website. 

DefaultDateTimeSettings This is an internal setting.
DefaultNoSiteInRangeImages

ting Related To Purpose
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Use o an order. True: Allows applying Goal 
Price comps to an order.
False: Does not allow applying 
Goal Price comps to an order. 
(Default)

Uni  consumer is True
False

Use e price and fil-
ally, the price 
 special price 
PI call. This 
ions: Filtering 
u call 
emPriceCom-
riceChanges’ 

True
False

Use  bar. This set-
e set. Con-

mation.

True: Displays the order pro-
gression bar. 
False: Does not display the 
order progression bar. 
(Default) 

Use you enable 
y fees in Web 
nfigured in 

ure, consum-
elivery order 

True: Use the delivery fees 
defined in Aloha POS and ATO. 
False: Use the delivery fees 
defined in Web Admin. 
(Default) 

Use data for 
ata, the con-

system can-

True: Stores card data. 
(Default) 
False: Does not store card 
data.

Use CPS

Set Values
a Online Ordering User Guide 

GoalPriceComps Comps Specifies whether to auto-apply Goal Price comps t

queVoicePhoneValidation Validates the unique phone number entered by the
unique and not already in use by another. 

ItemPriceCompatibility Price Changes Pools the price change in effect all day into the bas
ters the price change from the Get Menu call. Typic
change is in effect all day and does not reflect the a
change event. This helps reduce the length of the A
setting is currently only for the AO API. Related Opt
price changes in effect for all day from the Get Men
requires two company settings. you must set ‘UseIt
patabilityMode’ to False and ‘AutoApplyWholeDayP
to True. 

OrderProgressionBar Order Entry Specifies whether to display the order progression
ting requires additional graphics with a unique nam
tact the Aloha Online Ordering team for more infor

SiteLevelDeliveryFees Delivery Controls the determination of delivery fees. When 
this feature, it is not necessary to configure deliver
Admin as Online Ordering uses the delivery fees co
the Aloha POS and ATO. When you enable this feat
ers do not see a delivery fee associated with their d
until they reach the Payment Verification page.
Note: Requires ATO v1.2.200 or later.

StoredPayments Payments Determines whether the system stores credit card 
future online orders. For the system to store card d
sumer must have an online ordering account. The 
not store card data from anonymous orders.

StoredPaymentsMethod Payments

ting Related To Purpose
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Use a Online True: Use the item price in 
Aloha Online. 
False: Use the item price in 
Aloha POS. (Default) 

Use s from the 
se quick com-

True: Enables a quick combo 
promo type. 
False: Does not enable a quick 
combo promo type.

Vali e numbers as 
this setting 

ber Lookup 
 and order 

True: Uses email addresses or 
phone numbers as a loyalty 
lookup metric. 
False: Does not use email 
addresses or phone numbers 
as a loyalty lookup metric.

Set Values
a Online Ordering User Guide 

TakeOutPrice Order Entry Specifies whether you use the price defined in Aloh
Ordering or Aloha Takeout. 

WebSalesGroup Order Entry Allows the ordering of a quick combo as menu item
menu page of the online ordering site. You must u
bos to use this feature. 

dLoyaltyFields Loyalty Defines whether to use email addresses and phon
the valid loyalty lookup metric. Related Options: If 
and ‘LoyaltyNumberVisible’ are set to true, the Mem
button appears on both the consumer information
confirmation pages.

ting Related To Purpose
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Ver erification. ‘’ - Additional options do not 
appear. (Default)
‘COMPANYNAME’ - Company 
name options appears.
‘FORMATTEDADDRESS’ - All 
address options associated 
with the consumer appear.

Wai rd before True: Enables the online 
ordering site to wait for pay-
ment authorization before 
submitting the order.
False: Submits the order 
before receiving payment 
authorization. The system 
sends the order to the POS, 
even if the payment is not 
valid. (Default) 

Wh
Wh
ZipC de for an 

e zip code.
Required: The consumer must 
enter a zip code to place an 
order. (Default) 
Optional: The zip code is visi-
ble, but entry is not required, 
to place an order.
Hidden: Zip code is not visible.

Set Values
a Online Ordering User Guide 

ifyPaymentDisplayedCustomerFields Payments Displays additional options during order payment v

tForPaymentAuthorization Order submission Allows for the authorization and charging of the ca
submitting the order to the POS. 

ere2GetItDefaultSiteFrameURL
ere2GetItNearbySitesFrameURL

odeVisibility Order Entry Specifies whether to require the entry of the zip co
order, make the zip code entry optional, or hide th

ting Related To Purpose
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B Email Templates 
and Variables
This appendix contains tables with the available email templates and their purpose, and another set
of tables with information regarding the variables for each email template and their purpose.

Email Templates
The following lists the email templates available for general use, such as new account confirmation,
and then those for use with the Group Order feature. 

Table 1: Email Templates 

Email Template Purpose

AccountCreated Sent when a consumer creates an account.
AlternateAccountCreated Sent when a consumer creates an account with an alternate 

account, such as with social media credentials. 
AuthenticatorEmail
EmailChanged Sent when a consumer associates their account with a different 

email. 
EmailProfile Sent when a consumer changes their profile. 
EmailVerification Sent when the system approves a valid email account. 
GroupInviteeAdded Sent when the group organizer adds an invitee to a group 

order.
GroupInviteeAddedDelivery Sent to the group organizer when an invitee is added to a group 

order upon selecting the Delivery order mode.
GroupInviteeAddedPickup Sent to the group organizer when an invitee is added to a group 

order upon selecting the Pickup order mode. 
GroupInviteeRemoved Sent to the group organizer when an invitee is removed from a 

group order. 
GroupOrderAllOrdersComplete Sent to the group organizer when all invitees complete their 

portion of a group order.
GroupOrderCancelled Sent to the group invitees when the organizer cancels a group 

order.
GroupOrderChanged Sent to the invitees when the group organizer changes the 

details of the order, such as the response time from the invi-
tees.

GroupOrderInviteeCutoff-
TimeReached

Sent to the group organizer when a group order reaches the 
cutoff time.

GroupOrderInviteeDeclined The system does not currently support this template.
GroupOrderInviteeReminder Sent to the invitees to remind them to submit their portion of a 

group order before the cutoff time.
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GroupOrderInviteeReopenedOrder Sent to the group organizer when an invitee reopens their 
order. 

GroupOrderInviteeSubmittedOrder Sent to the group organizer when an invitee submits their 
order.

LoginInfoChanged Sent to the consumer when their log in information changed. 
MobileOrderConfirmationCarryOut Sent when a consumer places a pickup order while using a 

mobile device.
MobileOrderConfirmationCurbSide Sent when a consumer places a curbside order while using a 

mobile device.
MobileOrderConfirmationDineIn Sent when a consumer places a dine-in order while using a 

mobile device.
MobileOrderFeedback Sent when a consumer submits feedback while using a mobile 

device. 
NOLOAccountVerification
OrderCancelled Sent when a consumer cancels an order.
OrderConfirmation Sent when a consumer confirms an order.
OrderConfirmationCatering Sent when a consumer places a catering order. 
OrderConfirmationDelivery Sent when a consumer places a delivery order. 
OrderConfirmationDeliveryCatering Sent when a consumer places a delivery catering order. 
OrderConfirmationDeliveryRetail Sent when a consumer places a delivery retail order. 
OrderConfirmationDineInRetail Sent when a consumer places a dine in retail order. 
OrderConfirmationPickup Sent when a consumer places a pickup order. 
OrderConfirmationPickupCatering Sent when a consumer places a pickup catering order. 
OrderConfirmationPickupRetail Sent when a consumer places a pickup retail order. 
OrderConfirmationRetail Sent when a consumer places a retail order. 
OrderConfirmationThirdPartyDelivery Sent when an order was placed from a third-party delivery ser-

vice. 
PasswordChanged Sent when a consumer their password changed. 
PasswordRecovered Sent when a consumer requests to have their password sent to 

them.
ResetPasswordEmail Sent when a consumer request to have their password 

changed. 
ResetPasswordUnregisteredUserEmail Sent when a consumer without an account request to have 

their password changed. 
SiteFaxFailoverOrder Sent when a site receives an order by a fax machine because of 

a site communication error.
SiteOrderCancellation Sent when a site receives an order cancellation. 
SiteOrderSubmission Sent when a site receives an order submission. 
TwoFactorAuthVerificationCode

Email Template Purpose
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Email Template Variables
The following tables contain the variables available and their purpose according to the email tem-
plate. The email template contains the variable, and when the system generates the email message it
uses the variable to complete the email with the defined content.

Table 2: Email Template Variables

Variable Purpose

Account Created Email Template
[%UserName%] Displays the consumer email address, as entered at the Online 

Ordering site.
[%PasswordQuestion%] Displays the secret question the consumer added when creating 

their account.
Password Recovered Email Template
[%Password%] Displays a system-generated password for the consumer consist-

ing of random characters.

Order Email Template
[%CustomerAltPhone%] Displays the alternate phone number, as defined by the con-

sumer’s online ordering account.
[%CustomerBusinessName%] Displays the business name, as defined by the consumer’s online 

ordering account.
[%CustomerEmail%] Displays the email address, as defined by the consumer’s online 

ordering account.
[%CustomerFirstName%] Displays the first name of the consumer. 
[%CustomerLastName%] Displays the last name of the consumer. 
[%CustomerLocation%] Displays the delivery address, as defined by the consumer. 
[%CustomerVoicePhone%] Displays the phone number, as defined by the consumer. 
[%EmailConfirmationSnippet%] Displays site-specific information, which you define at Configura-

tion > Site Setup > Sites > Site Messaging tab.
[%FaxFailoverMessage%] Displays a system generated message when you configure the 

company and site for fax failover, and the system initiates the 
action.

[%ConfirmationNumber%] Displays the confirmation number when the consumer com-
pletes the order. This value does not carry through to the site 
location.

[%OrderId%] Displays the order number when the consumer completes the 
order. This value does not carry through to the site location.

[%OrderReceipt%] Displays a block of text containing the details of the consumer 
online order, such as items, item comments, item quantities, 
item amounts, tax amount, and total amount. 

[%OrderTotal%] Displays the total amount of the order.
[%PaymentCardType%] Displays the credit card type used to pay for the online order, if 

the consumer used a credit card to tender the order.
[%PaymentDeferredMessage%] Displays a message that the payment was deferred. 
[%PaymentFailedMessage%] Displays a message that the payment failed. 
[%PaymentNoResponseMessage%] Displays a message that there was no response from the proces-

sor. 
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[%PaymentNotProcessedMessage%] Displays a message that the payment failed to process. 
[%PaymentSuccessfulMessage%] Displays a message that the payment was processed successful. 
[%PaymentLocation%] Displays ‘Paid Online’ or ‘Pay at Site,’ as selected by the con-

sumer. 
[%PosOrderNumber%] Displays the order number generated by the POS. 
[%PromisedTime%] Displays the pickup or delivery date and time the consumer 

selected
[%PromisedTimeDayOfWeek%] Displays the day of week and pickup or delivery date and time 

the consumer selected. 
[%SiteAddress%] Displays the address of the site, as defined in Configuration > 

Site Setup > Sites > Site Details tab.
[%SiteExternalId%] Displays the external ID of the site location, as defined in Config-

uration > Site Setup > Sites > Site Details tab.
[%SiteName%] Displays the name of the site location, as defined in Configura-

tion > Site Setup > Sites > Site Details tab.
[%SiteLocation%] Displays the address and phone number of the selected site, as 

defined in Configuration > Site Setup > Sites > Site Details tab. 
[%SitePhoneNumber%] Displays the voice phone number of the site location, as defined 

in Configuration > Site Setup > Sites > Site Details tab.
[%SpecialInstructions%] Displays any transaction-level special instructions entered by the 

consumer during the checkout process.
Group Order Invitee Added Email Template
[%GroupOrderName%] Displays the name given to the group order by the group orga-

nizer.
[%InviteeCutoffTime%] Displays the requested response time as entered by the group 

organizer within the group order details page. 
[%InviteeName%] Displays the name of the invitee as entered by the group orga-

nizer within the group order details page.
[%OrderAccessCode%] Contains the access code for the link to allow an invitee to 

launch a predefined site. Use this variable in conjunction with 
[%OrderingWebsite%].

[%OrderingWebsite%] Contains the URL to allow an invitee to launch a predefined site. 
Use this variable in conjunction with [%OrderAccessCode%].

[%OrganizerEmail%] Displays the email address of the group organizer of the group 
order.

[%OrganizerFirstName%] Displays the first name of the group organizer.
[%OrganizerLastName%] Displays the last name of the group organizer.
[%PromisedTime%] Displays the promise time of the group order, as selected by the 

group organizer.
[%SiteLocation%] Displays the address and phone number of the selected site, as 

defined in Configuration > Site Setup > Sites > Site Details tab. 
[%SiteName%] Displays the name of the site location, as defined in Configura-

tion > Site Setup > Sites > Site Details tab.
Group Order Invitee Removed Email Template

Variable Purpose
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[%GroupOrderName%] Displays the name given to the group order by the group orga-
nizer.

[%InviteeName%] Displays the name of the invitee as entered by the group orga-
nizer within the group order details page.

[%OrganizerEmail%] Displays the email address of the group organizer of the group 
order.

[%OrganizerFirstName%] Displays the first name of the group organizer.
[%OrganizerLastName%] Displays the last name of the group organizer.
[%SiteName%] Displays the name of the site location, as defined in Configura-

tion > Site Setup > Sites > Site Details tab.
Group Order Changed Template
[%GroupOrderName%] Displays the name given to the group order by the group orga-

nizer.
[%InviteeCutoffTime%] Displays the requested response time as entered by the group 

organizer within the group order details page. 
[%InviteeName%] Displays the name of the invitee as entered by the group orga-

nizer within the group order details page.
[%OrderAccessCode%] Contains the access code for the link to allow an invitee to 

launch a predefined site. Use this variable in conjunction with 
[%OrderingWebsite%].

[%OrderingWebsite%] Contains the URL to allow an invitee to launch a predefined site. 
Use this variable in conjunction with [%OrderAccessCode%].

[%OrganizerEmail%] Displays the email address of the group organizer of the group 
order.

[%OrganizerFirstName%] Displays the first name of the group organizer.
[%OrganizerLastName%] Displays the last name of the group organizer.
[%PromisedTime%] Displays the promise time of the group order, as selected by the 

group organizer.
[%SiteLocation%] Displays the address and phone number of the selected site, as 

defined in Configuration > Site Setup > Sites > Site Details tab. 
[%SiteName%] Displays the name of the site location, as defined in Configura-

tion > Site Setup > Sites > Site Details tab.
Group Order Cancelled Email Template
[%GroupOrderName%] Displays the name given to the group order by the group orga-

nizer.
[%InviteeName%] Displays the name of the invitee as entered by the group orga-

nizer within the group order details page.
[%OrganizerEmail%] Displays the email address of the group organizer of the group 

order.
[%OrganizerFirstName%] Displays the first name of the group organizer.
[%OrganizerLastName%] Displays the last name of the group organizer.
[%SiteName%] Displays the name of the site location, as defined in Configura-

tion > Site Setup > Sites > Site Details tab.
Group Order Invitee Submitted Order Template

Variable Purpose
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[%GroupOrderName%] Displays the name given to the group order by the group orga-
nizer.

[%InviteeCutoffTime%] Displays the requested response time as entered by the group 
organizer within the group order details page. 

[%InviteeEmail%] Displays the email address of the invitee as entered by the group 
organizer within the group order details page.

[%InviteeName%] Displays the name of the invitee as entered by the group orga-
nizer within the group order details page.

[%OrganizerFirstName%] Displays the first name of the group organizer.
[%PromisedTime%] Displays the promise time of the group order, as selected by the 

group organizer.
[%SiteLocation%] Displays the address and phone number of the selected site, as 

defined in Configuration > Site Setup > Sites > Site Details tab. 
[%SiteName%] Displays the name of the site location, as defined in Configura-

tion > Site Setup > Sites > Site Details tab.
Group Order Invitee Reopened Order Email Template
[%GroupOrderName%] Displays the name given to the group order by the group orga-

nizer.

[%InviteeCutoffTime%] Displays the requested response time as entered by the group 
organizer within the group order details page. 

[%InviteeEmail%] Displays the email address of the invitee as entered by the group 
organizer within the group order details page.

[%InviteeName%] Displays the name of the invitee as entered by the group orga-
nizer within the group order details page.

[%OrganizerFirstName%] Displays the first name of the group organizer.
[%PromisedTime%] Displays the promise time of the order, as selected by the group 

organizer.
[%SiteLocation%] Displays the address and phone number of the selected site, as 

defined in Configuration > Site Setup > Sites > Site Details tab. 
[%SiteName%] Displays the name of the site location, as defined in Configura-

tion > Site Setup > Sites > Site Details tab.
Group Order Invitee Reminder Email Template
[%GroupOrderName%] Displays the name given to the group order by the group orga-

nizer.
[%InviteeCutoffTime%] Displays the requested response time as entered by the group 

organizer within the group order details page. 
[%InviteeEmail%] Displays the email address of the invitee as entered by the group 

organizer within the group order details page.
[%InviteeName%] Displays the name of the invitee as entered by the group orga-

nizer within the group order details page.
[%OrderAccessCode%] Contains the access code for the link to allow an invitee to 

launch a predefined site. Use this variable in conjunction with 
[%OrderingWebsite%].

Variable Purpose
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[%OrderingWebsite%] Contains the URL to allow an invitee to launch a predefined site. 
Use this variable in conjunction with [%OrderAccessCode%].

[%OrganizerEmail%] Displays the email address of the group organizer of the group 
order.

[%PromisedTime%] Displays the promise time of the order, as selected by the group 
order organizer.

[%SiteLocation%] Displays the address and phone number of the selected site, as 
defined in Configuration > Site Setup > Sites > Site Details tab. 

[%SiteName%] Displays the name of the site location, as defined in Configura-
tion > Site Setup > Sites > Site Details tab.

Variable Purpose
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C Design Elements
This appendix contains a table identifying the available design elements, their pixel width and height,
a description of the element, and where possible, an example.

Table 1: Element Names 

Element Name Pixels Description Element Example (where 
possible)

Universal Elements
background.png 2x2 Tiled color that generates the 

browser background.

NOTE: The use of images is not 
supported.

footer.png 992x50 Site footer that appears on all 
pages.

header.png 992x106 Site header that appears on all 
pages.

nav.bar.png 992x35 Navigation bar that appears on 
all pages.

page_text_repeat.png 992x2 Expands the page height when 
the page exceeds standard 
height. Design the characteris-
tics of this element to match 
design characteristics of other 
elements, such as borders and 
receipt treatments. Should not 
include receipt background ele-
ments.

scroll.png 2x30 Receipt area scroll bar. Acti-
vated when a consumer adds 
multiple items to an order.

scroll_button.png 10x30 Receipt area scroll button.

scroll_menu_button.png 15x30 Item pop-up scroll button. 
Appears when there are more 
items in a category than can fit 
on a page.
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scroll_menu_pagedown.png 15x15 Item pop-up scroll button used 
for advancing pages. Appears 
when there are more modifiers 
for a specific menu item than 
can fit on the pop-up screen.

scroll_menu_pageup.png 15x15 Item pop-up scroll button used 
for returning to previous pages. 
Appears when there are more 
items in a category than can fit 
on a page.

Primary Page
page_landing.png 992x572 Appears on the first page when 

Aloha Online Ordering appears. 
Commonly referred to as the 
Splash page.

NOTE: You can avoid this page 
with a custom URL.

page_menu.png 992x572 Appears as the primary back-
ground for all item category 
pages. Contains the left-side 
menu background and the 
receipt area.

NOTE: You cannot customize 
this page per menu category.

page_start.png 992x572 Appears as the directional page 
instructing users to the left-side 
menu after selecting a time. 
Incorporates the left-side menu 
and the receipt area.

page_text.png 992x572 Displays the system generated 
text. Incorporates the receipt 
area, but not the left side 
menu.

Element Name Pixels Description Element Example (where 
possible)
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page_thankyou.png 992x572 Displays the final text or graph-
ics after receiving an order con-
firmation from the restaurant. 
Incorporates the receipt area.

Message Pop-Up Windows
left.png 12x213 Left edge of the pop-up win-

dow.
right.png 12x213 Right edge of the pop-up win-

dow.
middle.png 3x213 Center area of pop-up window.
Multi-Purpose Buttons
button.png 140x31 Standard button appearing on 

numerous pages.
button_hover.png 140x31 Hover version of button.png
button_left.png 140x31 Standard button used in vari-

ous situations to undo an 
action or to navigate back a 
page. 

button_left-hover.png 140x31 Hover version of button-
left.png

button_right.png 140x31 Standard button used in vari-
ous situations to perform a 
selection or to navigate for-
ward a page.

button_right_hover.png 140x31 Hover version of button-
right.png.

button_small.png 89x31 Narrow version of button.png.
button_small_hover.png 89x31 Hover version of but-

ton_small.png.
button_small.left.png 89x31 Narrow version of but-

ton_left.png.
button_small_left_hover.png 89x31 Hover version of but-

ton_small_left.png.
button_small-right.png 89x31 A narrow version of but-

ton_right.png.
button_small_right_hover.png 89x31 Hover version of but-

ton_small_right.png.

Element Name Pixels Description Element Example (where 
possible)
Aloha Online Ordering User Guide Design Elements C - 3



nav_button.png 124x33 Navigation bar button used for 
each main navigation bar 
action. Overlays nav_bar.png at 
arbitrary positions.
Not Recommended: Incorpo-
rating textured designs.

button_tiny.png 59x25 Appears on Check-Out page as 
‘Apply’ buttons.

button-tiny_hover.png 59x25 Hover version of but-
ton_tiny.png.

Modifier Pop-Up Buttons
button_additem_cancel.png 58x20 Adds a modifier to the order. 

Used on the item pop-up win-
dow where a consumer can 
specify modifier quantities. 
Incorporate appropriate text 
and a ‘cancel’ symbol in the 
design for this button.

button_qty_minus.png 13x13 Decreases the quantity to the 
next lower amount. Used on 
item pop-up windows where 
the consumer can specify mod-
ifier quantities. 

button_qty_plus.png 13x13 Increases the quantity to the 
next higher amount. Used on 
item pop-up windows where 
the consumer can specify mod-
ifier quantities. 

Virtual Receipt Buttons
button_receipt_can-
cel_item.png

18x18 Cancel button used in the 
receipt area. Positioned to the 
right of each item listed in the 
order.

button_receipt.png 120x28 The standard receipt area but-
ton.

button_receipt_hover.png 120x28 Hover version of button_re-
ceipt.png.

button_receipt_left.png 120x28 Receipt button used in various 
situations to undo an action or 
navigate to a previous page.

button_receipt_left_hover.png 120x28 Hover version of button_re-
ceipt-left.png.

button_receipt_right.png 120x28 Receipt button used in various 
situations to select or navigate 
forward a page.

button_re-
ceipt_right_hover.png

120x28 Hover version of button_re-
ceipt.png.

Element Name Pixels Description Element Example (where 
possible)
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Item Modifier Pop-Up Background
panel_back.png 564x10 Repeating middle section of 

the item modifier pop-up back-
ground. Enables the display of 
pop-up windows with varying 
heights.

panel_bottom.png 564x21 Item modifier pop-up footer.
panel_header.png 564x33 Item modifier pop-up header. 

Displays the item name and 
button_additem_can-
cel_item.png.

panel_back_image.png 820x10 Appears as the repeating mid-
dle section of the item modifier 
pop-up background only when 
menu item images are 
included.

panel_bottom_image.png 820x21 Appears as the modifier pop-
up footer only when menu item 
images are included.

panel_header_image.png 820x33 Item modifier when modifier 
images are included. 

Build Your Own (Pizza) Elements
symbol_additem_add.png 16x16 ‘Add’ symbol in Build Your Own 

to add a modifier. Appears on 
the right side of each listed 
modifier.

symbol_additem_cancel.png 16x16 ‘Cancel’ symbol used in Build 
Your Own to remove a modifier 
from an item. Appears on the 
right side of the modifier.

symbol_additem_left_ac-
tive.png

16x16 Displays when the consumer 
applies a modifier to the left 
side of the pizza.

symbol_additem_left-inac-
tive.png

16x16 Appears when the consumer 
has not applied a modifier to 
the left half of the pizza.

symbol_additem_right_ac-
tive.png

16x16 Displays when the consumer 
applies a modifier to the right 
side of the pizza. 

symbol_additem_right-inac-
tive.png

16x16 Appears when the consumer 
has not applied a modifier to 
the right half of the pizza.

symbol_additem_whole_ac-
tive.Png

16x16 Displays when the consumer 
applies a modifier to the whole 
pizza.

Element Name Pixels Description Element Example (where 
possible)
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symbol_additem_whole_inac-
tive.png

16x16 Appears when the consumer 
has not applied a modifier to 
the whole pizza.

tab_selected_byo.png 30x40 Appears below the selected 
tab. The system pushes the 
image to the bottom of the 
graphic with the assumption 
that the tab text is positioned 
above.

Store Locator Map Markers
marker_1.png 23x34 The store locator map marker 

to appear on the Google Maps 
results as part of the store loca-
tor feature.

marker_2.png 23x34 The store locator map marker 
to appear on the Google Maps 
results as part of the store loca-
tor feature.

marker_3.png 23x34 The store locator map marker 
to appear on the Google Maps 
results as part of the store loca-
tor feature.

marker_4.png 23x34 The store locator map marker 
to appear on the Google Maps 
results as part of the store loca-
tor feature.

marker_5.png 23x34 The store locator map marker 
to appear on the Google Maps 
results as part of the store loca-
tor feature.

Element Name Pixels Description Element Example (where 
possible)
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marker_6.png 23x34 The store locator map marker 
to appear on the Google Maps 
results as part of the store loca-
tor feature.

marker_7.png 23x34 The store locator map marker 
to appear on the Google Maps 
results as part of the store loca-
tor feature.

marker_8.png 23x34 The store locator map marker 
to appear on the Google Maps 
results as part of the store loca-
tor feature.

marker_9.png 23x34 The store locator map marker 
to appear on the Google Maps 
results as part of the store loca-
tor feature.

marker_10.png 23x34 The store locator map marker 
to appear on the Google Maps 
results as part of the store loca-
tor feature.

Element Name Pixels Description Element Example (where 
possible)
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General Index
A
Accounts Review 5 - 3
Advanced Landing Page

Changing the Text 3 - 13
Company Settings 3 - 12
Understanding Store Loca-

tor Behavior 3 - 13
Updating Graphics 3 - 12

C
Call Center Ordering 7 - 13
Capacity Management

Configuring Using Aloha On-
line Ordering 1 - 46

Configuring Using Aloha 
Takeout 1 - 46

Company Dashboard 6 - 3
Company Settings

Configuring 1 - 6
Create a Copy 1 - 8
Edit a Company Setting 1 - 

8
Comps

Configuring 4 - 4
Configuring a Goal Price 

Comp 4 - 8
Understanding Comp Rejec-

tion Reasons 4 - 8
Understanding Recurring 

Comps 4 - 7
Contact Reasons 5 - 8
Contact Us Page

Presenting a Custom HTML 
Form 3 - 18

Presenting the Aloha Online 
Ordering Standard 
Form 3 - 19

Redirecting to Another URL
3 - 18

Customer Accounts
Adding 5 - 4
Exporting 5 - 5

Customizing Graphics and 
Elements 3 - 7

D
Delivery Zone

Configuring 1 - 40

E
Email Template

Configuring 1 - 9
Emergency Close

Configuring 1 - 25

F
FAQ Page

Configuring 1 - 11

G
Graphical Menu Categories

Designing 3 - 9
Group Ordering 7 - 7

I
Instant Credit Card Charge

Enabling 1 - 48

L
Lead Times

Configuring 1 - 28
Login Management 5 - 6
Logs

Viewing 1 - 6

M
Member

Change Password 1 - 5
Create Web Admin 

Member 1 - 5
Edit or Delete a Member 1 - 

6
Understanding Member 

Roles 1 - 3
Menu

Checking Out 2 - 5
Publishing 2 - 6

Menu Configurator

About 2 - 3
Installing 2 - 5

Menu Item
Adding 2 - 10
Adding Pictures 3 - 19
Combining Like Items 2 - 

14
Deleting 2 - 11
Excluding a Menu Item 2 - 

31
Hiding 2 - 11
Moving to a Different 

Submenu 2 - 12
Offering by Day of the 

Week 2 - 13
Renaming 2 - 12

Menu Structure Overview 2 - 4
Menus

Add an Additional Menu 2 - 
22

Control the Menus to 
Display 2 - 23

Share an Existing 
Submenu 2 - 23

Messages
Configuring 1 - 13

Modifier Groups
Alphabetizing Modifier 

Items 2 - 18
Changing the Min/Max 

Selections 2 - 17
Creating 2 - 14
Renaming 2 - 18
Sharing 2 - 16
Splitting 2 - 16

Modifier Items
Configuring a Default Modi-

fier Item 2 - 21
Configuring a Recipe 2 - 20
Excluding a Modifier Item 2 

- 32
Hiding 2 - 19
Ordering Extra 2 - 21
Renaming 2 - 19
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N
Navigation Safeguard 7 - 4

O
Online Ordering Process 3 - 6
Orders

Retrieving POS Status 5 - 
11

Reviewing Orders 5 - 10
Starting a Customer Order

5 - 12
Orders Review 5 - 10

P
Prep Time Adjustment

Configuring 1 - 31
Price Overrides

Reviewing 2 - 35
Promos

Applying 4 - 11
Configuring 4 - 11

Promoting POS Changing 2 - 
34

Q
Quick Combo

Activating a Web Sales 
Group 2 - 26

Building a Quick Combo 
Item 2 - 26

Quick Ordering 7 - 6

R
Reports 6 - 5

S
Security Questions 5 - 9
Site Attribute

Assigning to a Site 
Location 1 - 26

Configuring 1 - 25
Editing or Deleting 1 - 27
Removing From a Site 

Location 1 - 27
Site Dashboard 6 - 4
Site Group

Configuring 1 - 36
Site Location

Adding a Site Location 1 - 
14

Adding Site Messaging 1 - 
18

Applying Specific Settings 1 
- 19

Assigning a Company Set 1 
- 22

Cloning a Site Location 1 - 
22

Configuring Mobile 
Settings 1 - 20

Configuring PayPal 
Settings 1 - 21

Defining the Delivery 
Hours 1 - 17

Defining the Store Hours 1 
- 17

Social Media Plugins
Adding 3 - 16

Special Instructions 7 - 3
Standard Page Design 
Elements 3 - 5
Submenu

Adding 2 - 8
Creating a Time of Day 

Restriction 2 - 9
Customizing Submenu 

Names 3 - 14
Excluding a Submenu 2 - 

29
Hiding the Display of the 

Submenu Name 3 - 
21

Renaming 2 - 8

T
Transaction Upsells

Configuring 4 - 13
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